- Fixes rhbz #1476851 tmux bell-action other not working
- Fixes rhbz #1476892 tmux update in F26 broke tmuxinator
This commit is contained in:
parent
012ad38b8f
commit
8357d20ea2
12
tmux-2.5-bell-action-other-ignored.diff
Normal file
12
tmux-2.5-bell-action-other-ignored.diff
Normal file
@ -0,0 +1,12 @@
|
||||
--- alerts.c-orig 2017-05-16 10:09:31.000000000 -0300
|
||||
+++ alerts.c 2017-08-04 22:46:34.352115185 -0300
|
||||
@@ -199,7 +199,7 @@
|
||||
|
||||
if (action == BELL_CURRENT && ws != w)
|
||||
action = BELL_NONE;
|
||||
- if (action == BELL_OTHER && ws != w)
|
||||
+ if (action == BELL_OTHER && ws == w)
|
||||
action = BELL_NONE;
|
||||
|
||||
if (!visual) {
|
||||
|
15
tmux-2.5-fail-on-no-target.diff
Normal file
15
tmux-2.5-fail-on-no-target.diff
Normal file
@ -0,0 +1,15 @@
|
||||
--- a/cmd-find.c
|
||||
+++ a/cmd-find.c
|
||||
@@ -977,8 +977,11 @@ cmd_find_target(struct cmd_find_state *fs, struct cmdq_item *item,
|
||||
} else if (cmd_find_from_client(¤t, item->client) == 0) {
|
||||
fs->current = ¤t;
|
||||
log_debug("%s: current is from client", __func__);
|
||||
- } else
|
||||
+ } else {
|
||||
+ if (~flags & CMD_FIND_QUIET)
|
||||
+ cmdq_error(item, "no current target");
|
||||
goto error;
|
||||
+ }
|
||||
if (!cmd_find_valid_state(fs->current))
|
||||
fatalx("invalid current find state");
|
||||
|
18
tmux.spec
18
tmux.spec
@ -1,6 +1,6 @@
|
||||
Name: tmux
|
||||
Version: 2.5
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: A terminal multiplexer
|
||||
|
||||
Group: Applications/System
|
||||
@ -9,9 +9,16 @@ Group: Applications/System
|
||||
License: ISC and BSD
|
||||
URL: https://tmux.github.io/
|
||||
Source0: https://github.com/tmux/%{name}/releases/download/%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
# Examples has been removed - so include the bash_completion here
|
||||
Source1: bash_completion_tmux.sh
|
||||
# tmuxinator wouldn't start with tmux 2.5
|
||||
# tmuxinator discussion: https://github.com/tmuxinator/tmuxinator/issues/536
|
||||
# tmux discussion (states that the patch won't be backported to 2.5):
|
||||
# https://github.com/tmux/tmux/issues/971
|
||||
Patch0: tmux-2.5-fail-on-no-target.diff
|
||||
#https://bugzilla.redhat.com/show_bug.cgi?id=1476851
|
||||
#https://github.com/tmux/tmux/issues/1027#issuecomment-319088791
|
||||
Patch1: tmux-2.5-bell-action-other-ignored.diff
|
||||
|
||||
BuildRequires: ncurses-devel
|
||||
BuildRequires: libevent-devel
|
||||
@ -24,7 +31,8 @@ intended to be a simple, modern, BSD-licensed alternative to programs such
|
||||
as GNU Screen.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%setup -q
|
||||
%autosetup
|
||||
|
||||
%build
|
||||
CFLAGS="$RPM_OPT_FLAGS -fPIC -pie -Wl,-z,relro -Wl,-z,now"
|
||||
@ -66,6 +74,10 @@ fi
|
||||
%{_datadir}/bash-completion/completions/tmux
|
||||
|
||||
%changelog
|
||||
* Sat Aug 05 2017 Filipe Rosset <rosset.filipe@gmail.com> - 2.5-4
|
||||
- Fixes rhbz #1476851 tmux bell-action other not working
|
||||
- Fixes rhbz #1476892 tmux update in F26 broke tmuxinator
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user