- New upstream release

This commit is contained in:
Sven Lankes 2009-11-09 21:27:51 +00:00
parent c6477146de
commit 73482c5a1d
6 changed files with 68 additions and 51 deletions

View File

@ -1 +1 @@
tmux-1.0.tar.gz tmux-1.1.tar.gz

View File

@ -1 +1 @@
716b12d9ea052f57d917bf2869d419df tmux-1.0.tar.gz faf2fc52ac3ae63d899f6fece2c112cd tmux-1.1.tar.gz

View File

@ -1,37 +1,40 @@
# correct directory /usr/local diff --git a/GNUmakefile b/GNUmakefile
index f8f1911..5e7b6f3 100644
--- a/GNUmakefile --- a/GNUmakefile
+++ b/GNUmakefile +++ b/GNUmakefile
@@ -8,7 +8,7 @@ @@ -23,7 +23,7 @@ VERSION= 1.1
CC?= gcc CC?= cc
CFLAGS+= -DBUILD="\"$(VERSION)\"" CFLAGS+= -DBUILD="\"$(VERSION)\""
-LDFLAGS+= -L/usr/local/lib -LDFLAGS+= -L/usr/local/lib
+LDFLAGS+= -L/usr/lib +LDFLAGS+= -L/usr/lib
LIBS+= LIBS+=
ifdef FDEBUG # Sun CC
@@ -30,7 +30,7 @@ @@ -51,7 +51,7 @@ CFLAGS+= -Wno-pointer-sign
endif endif
endif endif
-PREFIX?= /usr/local -PREFIX?= /usr/local
+PREFIX?= /usr/ +PREFIX?= /usr
INSTALLDIR= install -d INSTALLDIR= install -d
INSTALLBIN= install -g bin -o root -m 555 INSTALLBIN= install -g bin -o root -m 555
INSTALLMAN= install -g bin -o root -m 444 INSTALLMAN= install -g bin -o root -m 444
@@ -59,7 +59,7 @@ @@ -80,7 +80,7 @@ clean-all: clean clean-depend
install: all install: all
$(INSTALLDIR) $(DESTDIR)$(PREFIX)/bin $(INSTALLDIR) $(DESTDIR)$(PREFIX)/bin
$(INSTALLBIN) tmux $(DESTDIR)$(PREFIX)/bin/tmux $(INSTALLBIN) tmux $(DESTDIR)$(PREFIX)/bin/tmux
- $(INSTALLDIR) $(DESTDIR)$(PREFIX)/man/man1 - $(INSTALLDIR) $(DESTDIR)$(PREFIX)/man/man1
- $(INSTALLMAN) tmux.1 $(DESTDIR)$(PREFIX)/man/man1/tmux.1 - $(INSTALLMAN) tmux.1 $(DESTDIR)$(PREFIX)/man/man1/tmux.1
+ $(INSTALLDIR) $(DESTDIR)$(PREFIX)share/man/man1 + $(INSTALLDIR) $(DESTDIR)$(PREFIX)/share/man/man1
+ $(INSTALLMAN) tmux.1 $(DESTDIR)$(PREFIX)share/man/man1/tmux.1 + $(INSTALLMAN) tmux.1 $(DESTDIR)$(PREFIX)/share/man/man1/tmux.1
-include .depend -include .depend
diff --git a/Makefile b/Makefile
index f713677..c5b1ece 100644
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -9,7 +9,7 @@ @@ -24,7 +24,7 @@ VERSION= 1.1
CC?= cc CC?= cc
CFLAGS+= -DBUILD="\"$(VERSION)\"" CFLAGS+= -DBUILD="\"$(VERSION)\""
@ -40,7 +43,7 @@
LIBS+= LIBS+=
.ifdef FDEBUG .ifdef FDEBUG
@@ -32,7 +32,7 @@ @@ -47,7 +47,7 @@ CFLAGS+= -Wno-pointer-sign
.endif .endif
.endif .endif
@ -49,7 +52,7 @@
INSTALLDIR= install -d INSTALLDIR= install -d
INSTALLBIN= install -g bin -o root -m 555 INSTALLBIN= install -g bin -o root -m 555
INSTALLMAN= install -g bin -o root -m 444 INSTALLMAN= install -g bin -o root -m 444
@@ -64,5 +64,5 @@ @@ -79,5 +79,5 @@ clean-all: clean clean-depend
install: all install: all
${INSTALLDIR} ${DESTDIR}${PREFIX}/bin ${INSTALLDIR} ${DESTDIR}${PREFIX}/bin
${INSTALLBIN} tmux ${DESTDIR}${PREFIX}/bin/ ${INSTALLBIN} tmux ${DESTDIR}${PREFIX}/bin/

View File

@ -1,40 +1,46 @@
# setting /usr/bin/tmux with sgid and proper location of socket diff --git a/GNUmakefile b/GNUmakefile
index 5e7b6f3..c11120e 100644
--- a/GNUmakefile --- a/GNUmakefile
+++ b/GNUmakefile +++ b/GNUmakefile
@@ -32,7 +32,7 @@ @@ -53,7 +53,7 @@ endif
PREFIX?= /usr/
INSTALLDIR= install -d
-INSTALLBIN= install -g bin -o root -m 555
+INSTALLBIN= install -g utmp -o root -m 2755
INSTALLMAN= install -g bin -o root -m 444
SRCS= $(shell echo *.c|sed 's|osdep-[a-z0-9]*.c||g')
--- a/Makefile
+++ b/Makefile
@@ -34,7 +34,7 @@
PREFIX?= /usr PREFIX?= /usr
INSTALLDIR= install -d INSTALLDIR= install -d
-INSTALLBIN= install -g bin -o root -m 555 -INSTALLBIN= install -g bin -o root -m 555
+INSTALLBIN= install -g utmp -o root -m 2755 +INSTALLBIN= install -g tmux -o root -m 2755
INSTALLMAN= install -g bin -o root -m 444
SRCS= $(shell echo *.c|sed 's|osdep-[a-z0-9]*.c||g')
diff --git a/Makefile b/Makefile
index c5b1ece..9cb822a 100644
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,7 @@ CFLAGS+= -Wno-pointer-sign
PREFIX?= /usr
INSTALLDIR= install -d
-INSTALLBIN= install -g bin -o root -m 555
+INSTALLBIN= install -g tmux -o root -m 2755
INSTALLMAN= install -g bin -o root -m 444 INSTALLMAN= install -g bin -o root -m 444
SRCS!= echo *.c|sed 's|osdep-[a-z0-9]*.c||g' SRCS!= echo *.c|sed 's|osdep-[a-z0-9]*.c||g'
diff --git a/compat.h b/compat.h
index 68fde0a..d63e7d3 100644
--- a/compat.h --- a/compat.h
+++ b/compat.h +++ b/compat.h
@@ -25,7 +25,7 @@ @@ -26,6 +26,7 @@ typedef uint64_t u_int64_t;
#ifndef HAVE_PATHS_H #ifndef HAVE_PATHS_H
#define _PATH_BSHELL "/bin/sh" #define _PATH_BSHELL "/bin/sh"
-#define _PATH_TMP "/tmp/" #define _PATH_TMP "/tmp/"
+#define _PATH_VARRUN "/var/run/" +#define _PATH_VARRUN "/var/run/"
#define _PATH_DEVNULL "/dev/null" #define _PATH_DEVNULL "/dev/null"
#define _PATH_TTY "/dev/tty" #define _PATH_TTY "/dev/tty"
#define _PATH_DEV "/dev/" #define _PATH_DEV "/dev/"
diff --git a/tmux.c b/tmux.c
index b590ec1..8c07180 100644
--- a/tmux.c --- a/tmux.c
+++ b/tmux.c +++ b/tmux.c
@@ -239,7 +239,7 @@ @@ -264,7 +264,7 @@ makesockpath(const char *label)
u_int uid; u_int uid;
uid = getuid(); uid = getuid();

View File

@ -1,7 +1,8 @@
# Harden write and chdir because of ignored return value diff --git a/tty.c b/tty.c
index 9d30ed9..2535bf3 100644
--- a/tty.c --- a/tty.c
+++ b/tty.c +++ b/tty.c
@@ -336,7 +336,8 @@ @@ -283,7 +283,8 @@ tty_free(struct tty *tty)
void void
tty_raw(struct tty *tty, const char *s) tty_raw(struct tty *tty, const char *s)
{ {
@ -11,17 +12,18 @@
} }
void void
@@ -369,7 +370,8 @@ @@ -316,7 +317,9 @@ tty_puts(struct tty *tty, const char *s)
buffer_write(tty->out, s, strlen(s)); buffer_write(tty->out, s, strlen(s));
if (tty->log_fd != -1) if (tty->log_fd != -1)
- write(tty->log_fd, s, strlen(s)); - write(tty->log_fd, s, strlen(s));
+ if (write(tty->log_fd, s, strlen(s)) == -1) + if (write(tty->log_fd, s, strlen(s)) == -1)
+ fatal("write failed"); + fatal("write failed");
+
} }
void void
@@ -394,7 +396,8 @@ @@ -342,7 +345,8 @@ tty_putc(struct tty *tty, u_char ch)
} }
if (tty->log_fd != -1) if (tty->log_fd != -1)
@ -31,19 +33,22 @@
} }
void void
@@ -407,7 +410,8 @@ @@ -355,7 +359,9 @@ tty_pututf8(struct tty *tty, const struct grid_utf8 *gu)
break; break;
buffer_write8(tty->out, gu->data[i]); buffer_write8(tty->out, gu->data[i]);
if (tty->log_fd != -1) if (tty->log_fd != -1)
- write(tty->log_fd, &gu->data[i], 1); - write(tty->log_fd, &gu->data[i], 1);
+ if (write(tty->log_fd, &gu->data[i], 1) == -1) + if (write(tty->log_fd, &gu->data[i], 1) == -1)
+ fatal("write failed"); + fatal("write failed");
+
} }
width = utf8_width(gu->data); tty->cx += gu->width;
diff --git a/window.c b/window.c
index f4be17d..318d2e9 100644
--- a/window.c --- a/window.c
+++ b/window.c +++ b/window.c
@@ -490,7 +490,9 @@ @@ -516,7 +516,9 @@ window_pane_spawn(struct window_pane *wp, const char *cmd, const char *shell,
return (-1); return (-1);
case 0: case 0:
if (chdir(wp->cwd) != 0) if (chdir(wp->cwd) != 0)

View File

@ -1,6 +1,6 @@
Name: tmux Name: tmux
Version: 1.0 Version: 1.1
Release: 2%{?dist} Release: 1%{?dist}
Summary: A terminal multiplexer Summary: A terminal multiplexer
Group: Applications/System Group: Applications/System
@ -58,6 +58,9 @@ getent group tmux >/dev/null || groupadd -r tmux
%attr(775,root,tmux) %{_localstatedir}/run/tmux %attr(775,root,tmux) %{_localstatedir}/run/tmux
%changelog %changelog
* Mon Nov 09 2009 Sven Lankes <sven@lank.es> 1.1-1
- New upstream release
* Sun Nov 01 2009 Sven Lankes <sven@lank.es> 1.0-2 * Sun Nov 01 2009 Sven Lankes <sven@lank.es> 1.0-2
- Add debian patches - Add debian patches
- Add tmux group for improved socket handling - Add tmux group for improved socket handling