- New upstream release
This commit is contained in:
parent
0d3dc9b97b
commit
1c52c02600
@ -1 +1 @@
|
||||
tmux-1.2.tar.gz
|
||||
tmux-1.3.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
748fbe7bb5f86812e19bd6005ff21a5a tmux-1.2.tar.gz
|
||||
96e60cb206de2db0610b9fb6a64c2251 tmux-1.3.tar.gz
|
||||
|
@ -1,8 +1,6 @@
|
||||
diff --git a/GNUmakefile b/GNUmakefile
|
||||
index f8f1911..5e7b6f3 100644
|
||||
--- a/GNUmakefile
|
||||
+++ b/GNUmakefile
|
||||
@@ -23,7 +23,7 @@ VERSION= 1.1
|
||||
--- GNUmakefile.orig 2010-07-19 06:52:17.485212178 +0200
|
||||
+++ GNUmakefile 2010-07-19 06:53:20.685214123 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
CC?= cc
|
||||
CFLAGS+= -DBUILD="\"$(VERSION)\""
|
||||
@ -11,16 +9,16 @@ index f8f1911..5e7b6f3 100644
|
||||
LIBS+=
|
||||
|
||||
# Sun CC
|
||||
@@ -51,7 +51,7 @@ CFLAGS+= -Wno-pointer-sign
|
||||
@@ -51,7 +51,7 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
-PREFIX?= /usr/local
|
||||
+PREFIX?= /usr
|
||||
INSTALLDIR= install -d
|
||||
INSTALLBIN= install -g bin -o root -m 555
|
||||
INSTALLMAN= install -g bin -o root -m 444
|
||||
@@ -80,7 +80,7 @@ clean-all: clean clean-depend
|
||||
INSTALL?= install
|
||||
INSTALLDIR= $(INSTALL) -d
|
||||
INSTALLBIN= $(INSTALL) -m 555
|
||||
@@ -81,7 +81,7 @@
|
||||
install: all
|
||||
$(INSTALLDIR) $(DESTDIR)$(PREFIX)/bin
|
||||
$(INSTALLBIN) tmux $(DESTDIR)$(PREFIX)/bin/tmux
|
||||
@ -30,11 +28,9 @@ index f8f1911..5e7b6f3 100644
|
||||
+ $(INSTALLMAN) tmux.1 $(DESTDIR)$(PREFIX)/share/man/man1/tmux.1
|
||||
|
||||
-include .depend
|
||||
diff --git a/Makefile b/Makefile
|
||||
index f713677..c5b1ece 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -24,7 +24,7 @@ VERSION= 1.1
|
||||
--- Makefile.orig 2010-07-19 06:53:30.745213504 +0200
|
||||
+++ Makefile 2010-07-19 06:54:13.637338721 +0200
|
||||
@@ -24,7 +24,7 @@
|
||||
|
||||
CC?= cc
|
||||
CFLAGS+= -DBUILD="\"$(VERSION)\""
|
||||
@ -43,16 +39,16 @@ index f713677..c5b1ece 100644
|
||||
LIBS+=
|
||||
|
||||
.ifdef FDEBUG
|
||||
@@ -47,7 +47,7 @@ CFLAGS+= -Wno-pointer-sign
|
||||
@@ -47,7 +47,7 @@
|
||||
.endif
|
||||
.endif
|
||||
|
||||
-PREFIX?= /usr/local
|
||||
+PREFIX?= /usr
|
||||
INSTALLDIR= install -d
|
||||
INSTALLBIN= install -g bin -o root -m 555
|
||||
INSTALLMAN= install -g bin -o root -m 444
|
||||
@@ -79,5 +79,5 @@ clean-all: clean clean-depend
|
||||
INSTALL?= install
|
||||
INSTALLDIR= ${INSTALL} -d
|
||||
INSTALLBIN= ${INSTALL} -m 555
|
||||
@@ -80,5 +80,5 @@
|
||||
install: all
|
||||
${INSTALLDIR} ${DESTDIR}${PREFIX}/bin
|
||||
${INSTALLBIN} tmux ${DESTDIR}${PREFIX}/bin/
|
||||
|
@ -1,51 +1,22 @@
|
||||
diff --git a/GNUmakefile b/GNUmakefile
|
||||
index 5e7b6f3..c11120e 100644
|
||||
--- a/GNUmakefile
|
||||
+++ b/GNUmakefile
|
||||
@@ -53,7 +53,7 @@ endif
|
||||
|
||||
--- GNUmakefile.orig 2010-07-19 07:05:09.757213641 +0200
|
||||
+++ GNUmakefile 2010-07-19 07:05:46.795213926 +0200
|
||||
@@ -54,7 +54,7 @@
|
||||
PREFIX?= /usr
|
||||
INSTALLDIR= install -d
|
||||
-INSTALLBIN= install -g bin -o root -m 555
|
||||
+INSTALLBIN= install -g tmux -o root -m 2755
|
||||
INSTALLMAN= install -g bin -o root -m 444
|
||||
|
||||
SRCS= $(shell echo *.c|sed 's|osdep-[a-z0-9]*.c||g')
|
||||
diff --git a/Makefile b/Makefile
|
||||
index c5b1ece..9cb822a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -49,7 +49,7 @@ CFLAGS+= -Wno-pointer-sign
|
||||
INSTALL?= install
|
||||
INSTALLDIR= $(INSTALL) -d
|
||||
-INSTALLBIN= $(INSTALL) -m 555
|
||||
+INSTALLBIN= $(INSTALL) -g tmux -o root -m 2755
|
||||
INSTALLMAN= $(INSTALL) -m 444
|
||||
|
||||
SRCS= $(shell echo *.c|LC_ALL=C sed 's|osdep-[a-z0-9]*.c||g')
|
||||
--- Makefile.orig 2010-07-19 07:05:13.812244029 +0200
|
||||
+++ Makefile 2010-07-19 07:06:01.826338894 +0200
|
||||
@@ -50,7 +50,7 @@
|
||||
PREFIX?= /usr
|
||||
INSTALLDIR= install -d
|
||||
-INSTALLBIN= install -g bin -o root -m 555
|
||||
+INSTALLBIN= install -g tmux -o root -m 2755
|
||||
INSTALLMAN= install -g bin -o root -m 444
|
||||
INSTALL?= install
|
||||
INSTALLDIR= ${INSTALL} -d
|
||||
-INSTALLBIN= ${INSTALL} -m 555
|
||||
+INSTALLBIN= ${INSTALL} -g tmux -o root -m 2755
|
||||
INSTALLMAN= ${INSTALL} -m 444
|
||||
|
||||
SRCS!= echo *.c|sed 's|osdep-[a-z0-9]*.c||g'
|
||||
diff --git a/compat.h b/compat.h
|
||||
index 68fde0a..d63e7d3 100644
|
||||
--- a/compat.h
|
||||
+++ b/compat.h
|
||||
@@ -26,6 +26,7 @@ typedef uint64_t u_int64_t;
|
||||
#ifndef HAVE_PATHS_H
|
||||
#define _PATH_BSHELL "/bin/sh"
|
||||
#define _PATH_TMP "/tmp/"
|
||||
+#define _PATH_VARRUN "/var/run/"
|
||||
#define _PATH_DEVNULL "/dev/null"
|
||||
#define _PATH_TTY "/dev/tty"
|
||||
#define _PATH_DEV "/dev/"
|
||||
diff --git a/tmux.c b/tmux.c
|
||||
index b590ec1..8c07180 100644
|
||||
--- a/tmux.c
|
||||
+++ b/tmux.c
|
||||
@@ -264,7 +264,7 @@ makesockpath(const char *label)
|
||||
u_int uid;
|
||||
|
||||
uid = getuid();
|
||||
- xsnprintf(base, MAXPATHLEN, "%s/tmux-%d", _PATH_TMP, uid);
|
||||
+ xsnprintf(base, MAXPATHLEN, "%s/%s/%s-%d", _PATH_VARRUN, __progname, __progname, uid);
|
||||
|
||||
if (mkdir(base, S_IRWXU) != 0 && errno != EEXIST)
|
||||
return (NULL);
|
||||
SRCS!= echo *.c|LC_ALL=C sed 's|osdep-[a-z0-9]*.c||g'
|
||||
|
@ -1,7 +1,6 @@
|
||||
# using setresgid() for safely dropping utmp group membership.
|
||||
--- a/tmux.c
|
||||
+++ b/tmux.c
|
||||
@@ -236,9 +236,11 @@
|
||||
--- tmux.c.orig 2010-07-19 07:07:06.311243142 +0200
|
||||
+++ tmux.c 2010-07-19 07:08:54.969213735 +0200
|
||||
@@ -185,9 +185,10 @@
|
||||
{
|
||||
char base[MAXPATHLEN], *path;
|
||||
struct stat sb;
|
||||
@ -9,18 +8,17 @@
|
||||
+ u_int uid,gid;
|
||||
|
||||
uid = getuid();
|
||||
+ gid = getgid();
|
||||
+
|
||||
xsnprintf(base, MAXPATHLEN, "%s/%s/%s-%d", _PATH_VARRUN, __progname, __progname, uid);
|
||||
+ gid = getgid();
|
||||
xsnprintf(base, MAXPATHLEN, "%s/tmux-%d", _PATH_TMP, uid);
|
||||
|
||||
if (mkdir(base, S_IRWXU) != 0 && errno != EEXIST)
|
||||
@@ -254,6 +256,9 @@
|
||||
@@ -203,6 +204,9 @@
|
||||
errno = EACCES;
|
||||
return (NULL);
|
||||
}
|
||||
+ /* drop unnecessary privileges */
|
||||
+ if (setresgid(gid, gid, gid) != 0)
|
||||
+ return (NULL);
|
||||
+ /* drop unnecessary privileges */
|
||||
+ if (setresgid(gid, gid, gid) != 0)
|
||||
+ return (NULL);
|
||||
|
||||
xasprintf(&path, "%s/%s", base, label);
|
||||
return (path);
|
||||
|
11
tmux.spec
11
tmux.spec
@ -1,5 +1,5 @@
|
||||
Name: tmux
|
||||
Version: 1.2
|
||||
Version: 1.3
|
||||
Release: 1%{?dist}
|
||||
Summary: A terminal multiplexer
|
||||
|
||||
@ -33,9 +33,9 @@ as GNU Screen.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .location
|
||||
%patch1 -p1 -b .sockethandling
|
||||
%patch2 -p1 -b .dropprivs
|
||||
%patch0 -p0 -b .location
|
||||
%patch1 -p0 -b .sockethandling
|
||||
%patch2 -p0 -b .dropprivs
|
||||
%patch3 -p1 -b .writehard
|
||||
|
||||
%build
|
||||
@ -63,6 +63,9 @@ getent group tmux >/dev/null || groupadd -r tmux
|
||||
%attr(775,root,tmux) %{_localstatedir}/run/tmux
|
||||
|
||||
%changelog
|
||||
* Mon Jul 19 2010 Sven Lankes <sven@lank.es> 1.3-1
|
||||
- New upstream release
|
||||
|
||||
* Sun Mar 28 2010 Sven Lankes <sven@lank.es> 1.2-1
|
||||
- New upstream release
|
||||
- rediff writehard patch
|
||||
|
Loading…
Reference in New Issue
Block a user