tk/tk-confi.patch
Marcela Mašláňová 15bf93378a Now patch with soname
2007-08-09 08:21:21 +00:00

64 lines
2.1 KiB
Diff

--- tk8.4.15/unix/tcl.m4.confi 2007-05-25 18:09:54.000000000 +0200
+++ tk8.4.15/unix/tcl.m4 2007-08-09 08:00:08.000000000 +0200
@@ -1124,7 +1124,7 @@
# AIX v<=4.1 has some different flags than 4.2+
if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
- LIBOBJS="$LIBOBJS tclLoadAix.o"
+ AC_LIBOBJ([tclLoadAix])
DL_LIBS="-lld"
fi
@@ -1345,11 +1345,11 @@
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
+ SHLIB_LD='${CC} ${CFLAGS} -shared ${LDFLAGS} -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ CC_SEARCH_FLAGS=''
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
else
AC_CHECK_HEADER(dld.h, [
@@ -1381,7 +1381,7 @@
# is kind of overkill but it works.
# Disable inlining only when one of the
# files in compat/*.c is being linked in.
- if test x"${LIBOBJS}" != x ; then
+ if test x"${LIB@&t@OBJS}" != x ; then
CFLAGS="$CFLAGS -fno-inline"
fi
@@ -1395,7 +1395,7 @@
SHLIB_SUFFIX=".so"
if test "$have_dl" = yes; then
- SHLIB_LD="${CC} -shared"
+ SHLIB_LD="${CC} ${CFLAGS} -shared"
DL_OBJS=""
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
@@ -2633,7 +2633,7 @@
}], tcl_cv_strtod_buggy=ok, tcl_cv_strtod_buggy=buggy,
tcl_cv_strtod_buggy=buggy)])
if test "$tcl_cv_strtod_buggy" = buggy; then
- LIBOBJS="$LIBOBJS fixstrtod.o"
+ AC_LIBOBJ([fixstrtod])
AC_DEFINE(strtod, fixstrtod)
fi
fi
--- tk8.4.15/unix/Makefile.in.confi 2007-05-25 18:09:53.000000000 +0200
+++ tk8.4.15/unix/Makefile.in 2007-07-31 11:26:15.000000000 +0200
@@ -639,7 +639,7 @@
fi
@echo "Installing $(LIB_FILE) to $(LIB_INSTALL_DIR)/"
@@INSTALL_LIB@
- @chmod 555 $(LIB_INSTALL_DIR)/$(LIB_FILE)
+ @chmod 755 $(LIB_INSTALL_DIR)/$(LIB_FILE)
@if test "$(TK_BUILD_EXP_FILE)" != ""; then \
echo "Installing $(TK_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
$(INSTALL_DATA) $(TK_BUILD_EXP_FILE) \