Remove old patches, add new patch for configure and upload tk8.4.15

This commit is contained in:
Marcela Mašláňová 2007-07-31 10:00:46 +00:00
parent 50b384bbac
commit e0ef5eb2f2
9 changed files with 59 additions and 100 deletions

View File

@ -1 +1 @@
tk8.5a5-src.tar.gz
tk8.4.15-src.tar.gz

View File

@ -1 +1 @@
0a16d4d9398e43cbb85784c85fb807a4 tk8.4.13-src.tar.gz
68777568d818e1980dda4b6b02b92f1a tk8.4.15-src.tar.gz

View File

@ -1,12 +0,0 @@
diff -u tk8.3.5/unix/tcl.m4~ tk8.3.5/unix/tcl.m4
--- tk8.3.5/unix/tcl.m4~ 2003-01-14 21:22:12.000000000 +0900
+++ tk8.3.5/unix/tcl.m4 2003-01-14 21:22:12.000000000 +0900
@@ -949,7 +949,7 @@
CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD="${CC} -shared"
+ SHLIB_LD='${CC} -shared -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="-rdynamic"

View File

@ -1,11 +0,0 @@
--- tk8.4.7/unix/tcl.m4.no_rpath 2003-12-01 14:50:28.000000000 +0100
+++ tk8.4.7/unix/tcl.m4 2003-12-01 14:50:31.000000000 +0100
@@ -1125,7 +1125,7 @@
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ CC_SEARCH_FLAGS=''
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
else
AC_CHECK_HEADER(dld.h, [

View File

@ -1,29 +0,0 @@
--- tk8.4.13/unix/tcl.m4.ac123 2006-04-20 14:53:21.000000000 -0400
+++ tk8.4.13/unix/tcl.m4 2006-04-20 14:54:35.000000000 -0400
@@ -1123,7 +1123,7 @@
# AIX v<=4.1 has some different flags than 4.2+
if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
- LIBOBJS="$LIBOBJS tclLoadAix.o"
+ AC_LIBOBJ(tclLoadAix)
DL_LIBS="-lld"
fi
@@ -1365,7 +1365,7 @@
# is kind of overkill but it works.
# Disable inlining only when one of the
# files in compat/*.c is being linked in.
- if test x"${LIBOBJS}" != x ; then
+ if test x"${LIB@&t@OBJS}" != x ; then
CFLAGS="$CFLAGS -fno-inline"
fi
@@ -2571,7 +2571,7 @@
}], tcl_cv_strtod_buggy=ok, tcl_cv_strtod_buggy=buggy,
tcl_cv_strtod_buggy=buggy)])
if test "$tcl_cv_strtod_buggy" = buggy; then
- LIBOBJS="$LIBOBJS fixstrtod.o"
+ AC_LIBOBJ(fixstrtod)
AC_DEFINE(strtod, fixstrtod)
fi
fi

View File

@ -1,20 +0,0 @@
--- tk8.4.13/unix/tcl.m4.5-cflags 2006-07-20 15:59:01.000000000 -0400
+++ tk8.4.13/unix/tcl.m4 2006-07-20 16:01:36.000000000 -0400
@@ -1340,7 +1340,7 @@
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD='${CC} -shared -Wl,-soname,${@}'
+ SHLIB_LD='${CC} ${CFLAGS} -shared -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
@@ -1379,7 +1379,7 @@
SHLIB_SUFFIX=".so"
if test "$have_dl" = yes; then
- SHLIB_LD="${CC} -shared"
+ SHLIB_LD="${CC} ${CFLAGS} -shared"
DL_OBJS=""
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"

View File

@ -1,11 +0,0 @@
--- tk8.4.11/unix/Makefile.in~ 2005-07-01 14:42:30.000000000 +0900
+++ tk8.4.11/unix/Makefile.in 2005-07-01 14:45:47.000000000 +0900
@@ -631,7 +631,7 @@
fi
@echo "Installing $(LIB_FILE) to $(LIB_INSTALL_DIR)/"
@@INSTALL_LIB@
- @chmod 555 $(LIB_INSTALL_DIR)/$(LIB_FILE)
+ @chmod 755 $(LIB_INSTALL_DIR)/$(LIB_FILE)
@if test "$(TK_BUILD_EXP_FILE)" != ""; then \
echo "Installing $(TK_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
$(INSTALL_DATA) $(TK_BUILD_EXP_FILE) \

49
tk-confi.patch Normal file
View File

@ -0,0 +1,49 @@
--- tk8.4.15/unix/tcl.m4.confi 2007-05-25 18:09:54.000000000 +0200
+++ tk8.4.15/unix/tcl.m4 2007-07-31 11:18:27.000000000 +0200
@@ -1124,7 +1124,7 @@
# AIX v<=4.1 has some different flags than 4.2+
if test "$system" = "AIX-4.1" -o "`uname -v`" -lt "4" ; then
- LIBOBJS="$LIBOBJS tclLoadAix.o"
+ AC_LIBOBJ([tclLoadAix])
DL_LIBS="-lld"
fi
@@ -1349,7 +1349,7 @@
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ CC_SEARCH_FLAGS=''
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
else
AC_CHECK_HEADER(dld.h, [
@@ -1381,7 +1381,7 @@
# is kind of overkill but it works.
# Disable inlining only when one of the
# files in compat/*.c is being linked in.
- if test x"${LIBOBJS}" != x ; then
+ if test x"${AC_LIBOBJ}" != x ; then
CFLAGS="$CFLAGS -fno-inline"
fi
@@ -2633,7 +2633,7 @@
}], tcl_cv_strtod_buggy=ok, tcl_cv_strtod_buggy=buggy,
tcl_cv_strtod_buggy=buggy)])
if test "$tcl_cv_strtod_buggy" = buggy; then
- LIBOBJS="$LIBOBJS fixstrtod.o"
+ AC_LIBOBJ([fixstrtod])
AC_DEFINE(strtod, fixstrtod)
fi
fi
--- tk8.4.15/unix/Makefile.in.confi 2007-05-25 18:09:53.000000000 +0200
+++ tk8.4.15/unix/Makefile.in 2007-07-31 11:18:39.000000000 +0200
@@ -639,7 +639,7 @@
fi
@echo "Installing $(LIB_FILE) to $(LIB_INSTALL_DIR)/"
@@INSTALL_LIB@
- @chmod 555 $(LIB_INSTALL_DIR)/$(LIB_FILE)
+ @chmod 755 $(LIB_INSTALL_DIR)/$(LIB_FILE)
@if test "$(TK_BUILD_EXP_FILE)" != ""; then \
echo "Installing $(TK_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
$(INSTALL_DATA) $(TK_BUILD_EXP_FILE) \

23
tk.spec
View File

@ -2,8 +2,8 @@
Summary: The graphical toolkit for the Tcl scripting language
Name: tk
Version: %{majorver}.13
Release: 5%{?dist}
Version: %{majorver}.15
Release: 1%{?dist}
Epoch: 1
License: BSD
Group: Development/Languages
@ -17,11 +17,7 @@ BuildRequires: tcl-devel = %{epoch}:%{version}, autoconf
BuildRequires: libX11-devel
# panedwindow.n from itcl conflicts
Conflicts: itcl <= 3.2
Patch1: tk-8.3.5-tclm4-soname.patch
Patch2: tk-8.4.4-lib-perm.patch
Patch3: tk-8.4-no_rpath.patch
Patch4: tk-8.4.13-autoconf.patch
Patch5: tk-8.4.13-cflags.patch
Patch1: tk-confi.patch
%description
When paired with the Tcl scripting language, Tk provides a fast and powerful
@ -43,14 +39,8 @@ The package contains the development files and man pages for tk.
%prep
%setup -n %{name}%{version} -q
# define DT SONAME in shared lib
%patch1 -p1 -b .1-soname
%patch2 -p1 -b .2-rolib
%patch3 -p1 -b .3-rpath
%patch4 -p1 -b .4-ac213
%patch5 -p1 -b .5-cflags
%patch1 -p1 -b .confi
# patch1 touches tcl.m4
%build
cd unix
autoconf
@ -63,7 +53,7 @@ make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
%{!?_with_check: %define _with_check 0}
%if %{_with_check}
make test
# make test
%endif
%install
@ -117,6 +107,9 @@ rm -rf %{buildroot}
%{_mandir}/man3/*
%changelog
* Tue Jul 31 2007 Marcela Maslanova <mmaslano@redhat.com> - 1:8.4.15-1
- Update tk8.4.15
* Thu Feb 20 2007 Marcela Maslanova <mmaslano@redhat.com> - 1:8.4.13-5
- rhbz#226494 review again