Added patches

This commit is contained in:
Jaroslav Škarvada 2013-08-15 17:26:25 +02:00
parent 0b0e5d82dc
commit d3ba33b555
3 changed files with 47 additions and 0 deletions

19
tk-8.6.0-conf.patch Normal file
View File

@ -0,0 +1,19 @@
diff --git a/unix/tcl.m4 b/unix/tcl.m4
index b13fddd..cd9607f 100644
--- a/unix/tcl.m4
+++ b/unix/tcl.m4
@@ -1408,12 +1408,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
# get rid of the warnings.
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
+ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
AS_IF([test $doRpath = yes], [
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'])
+ CC_SEARCH_FLAGS=''])
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
AS_IF([test "`uname -m`" = "alpha"], [CFLAGS="$CFLAGS -mieee"])
AS_IF([test $do64bit = yes], [

15
tk-8.6.0-fix-xft.patch Normal file
View File

@ -0,0 +1,15 @@
diff --git a/unix/configure.in b/unix/configure.in
index abc8a1d..065a6c2 100755
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -557,8 +557,8 @@ if test $tk_aqua = no; then
XFT_LIBS=`xft-config --libs 2>/dev/null` || found_xft="no"
if test "$found_xft" = "no" ; then
found_xft=yes
- XFT_CFLAGS=`pkg-config --cflags xft 2>/dev/null` || found_xft="no"
- XFT_LIBS=`pkg-config --libs xft 2>/dev/null` || found_xft="no"
+ XFT_CFLAGS=`pkg-config --cflags xft freetype2 2>/dev/null` || found_xft="no"
+ XFT_LIBS=`pkg-config --libs xft freetype2 2>/dev/null` || found_xft="no"
fi
AC_MSG_RESULT([$found_xft])
dnl make sure that compiling against Xft header file doesn't bomb

13
tk8.6-make.patch Normal file
View File

@ -0,0 +1,13 @@
diff --git a/unix/Makefile.in b/unix/Makefile.in
index 1df6721..08017a4 100644
--- a/unix/Makefile.in
+++ b/unix/Makefile.in
@@ -744,7 +744,7 @@ install-binaries: $(TK_LIB_FILE) $(TK_STUB_LIB_FILE) ${WISH_EXE}
fi
@echo "Installing $(LIB_FILE) to $(DLL_INSTALL_DIR)/"
@@INSTALL_LIB@
- @chmod 555 "$(DLL_INSTALL_DIR)/$(LIB_FILE)"
+ @chmod 755 "$(DLL_INSTALL_DIR)/$(LIB_FILE)"
@if test -f "tk${MAJOR_VERSION}${MINOR_VERSION}.dll"; then \
$(INSTALL_LIBRARY) "tk${MAJOR_VERSION}${MINOR_VERSION}.dll" "$(DLL_INSTALL_DIR)";\
chmod 555 "$(DLL_INSTALL_DIR)/tk${MAJOR_VERSION}${MINOR_VERSION}.dll";\