New version
Upated patches Dropped fix-xft patch (upstreamed)
This commit is contained in:
parent
ce2b4b246d
commit
61963a50ba
@ -1,13 +1,13 @@
|
||||
diff --git a/unix/tcl.m4 b/unix/tcl.m4
|
||||
index 8a802fb..46a08c1 100644
|
||||
index 0e146e4..613a276 100644
|
||||
--- a/unix/tcl.m4
|
||||
+++ b/unix/tcl.m4
|
||||
@@ -1402,12 +1402,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
|
||||
@@ -1410,12 +1410,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
|
||||
# get rid of the warnings.
|
||||
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
|
||||
|
||||
- SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS}'
|
||||
+ SHLIB_LD='${CC} -shared ${CFLAGS} ${LDFLAGS} -Wl,-soname,${@}'
|
||||
- SHLIB_LD='${CC} ${CFLAGS} ${LDFLAGS} -shared'
|
||||
+ SHLIB_LD='${CC} ${CFLAGS} ${LDFLAGS} -shared -Wl,-soname,${@}'
|
||||
DL_OBJS="tclLoadDl.o"
|
||||
DL_LIBS="-ldl"
|
||||
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
|
@ -1,8 +1,8 @@
|
||||
diff --git a/unix/Makefile.in b/unix/Makefile.in
|
||||
index 96f1408..05270c6 100644
|
||||
index c6f8c25..a3cc8cb 100644
|
||||
--- a/unix/Makefile.in
|
||||
+++ b/unix/Makefile.in
|
||||
@@ -739,7 +739,7 @@ install-binaries: $(TK_STUB_LIB_FILE) $(TK_LIB_FILE) ${WISH_EXE}
|
||||
@@ -744,7 +744,7 @@ install-binaries: $(TK_STUB_LIB_FILE) $(TK_LIB_FILE) ${WISH_EXE}
|
||||
fi
|
||||
@echo "Installing $(LIB_FILE) to $(DLL_INSTALL_DIR)/"
|
||||
@@INSTALL_LIB@
|
@ -1,15 +0,0 @@
|
||||
diff --git a/unix/configure.in b/unix/configure.in
|
||||
index cb412af..abfd43b 100755
|
||||
--- a/unix/configure.in
|
||||
+++ b/unix/configure.in
|
||||
@@ -479,8 +479,8 @@ if test $tk_aqua = no; then
|
||||
XFT_LIBS=`xft-config --libs 2>/dev/null` || found_xft="no"
|
||||
if test "$found_xft" = "no" ; then
|
||||
found_xft=yes
|
||||
- XFT_CFLAGS=`pkg-config --cflags xft 2>/dev/null` || found_xft="no"
|
||||
- XFT_LIBS=`pkg-config --libs xft 2>/dev/null` || found_xft="no"
|
||||
+ XFT_CFLAGS=`pkg-config --cflags xft freetype2 2>/dev/null` || found_xft="no"
|
||||
+ XFT_LIBS=`pkg-config --libs xft freetype2 2>/dev/null` || found_xft="no"
|
||||
fi
|
||||
AC_MSG_RESULT([$found_xft])
|
||||
dnl make sure that compiling against Xft header file doesn't bomb
|
@ -1,18 +0,0 @@
|
||||
diff -up tk8.6.9/unix/tcl.m4.conf tk8.6.9/unix/tcl.m4
|
||||
--- tk8.6.9/unix/tcl.m4.conf 2019-11-06 16:03:44.836585545 -0500
|
||||
+++ tk8.6.9/unix/tcl.m4 2019-11-06 16:06:27.910179543 -0500
|
||||
@@ -1407,12 +1407,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
|
||||
# get rid of the warnings.
|
||||
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
|
||||
|
||||
- SHLIB_LD='${CC} ${CFLAGS} ${LDFLAGS} -shared'
|
||||
+ SHLIB_LD='${CC} ${CFLAGS} ${LDFLAGS} -shared -Wl,-soname,${@}'
|
||||
DL_OBJS="tclLoadDl.o"
|
||||
DL_LIBS="-ldl"
|
||||
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
|
||||
AS_IF([test $doRpath = yes], [
|
||||
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'])
|
||||
+ CC_SEARCH_FLAGS=''])
|
||||
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
|
||||
AS_IF([test "`uname -m`" = "alpha"], [CFLAGS="$CFLAGS -mieee"])
|
||||
AS_IF([test $do64bit = yes], [
|
22
tk.spec
22
tk.spec
@ -1,9 +1,9 @@
|
||||
%define majorver 8.6
|
||||
%define vers %{majorver}.9
|
||||
%define vers %{majorver}.10
|
||||
|
||||
Summary: The graphical toolkit for the Tcl scripting language
|
||||
Name: tk
|
||||
Version: %{vers}.1
|
||||
Version: %{vers}
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
License: TCL
|
||||
@ -18,11 +18,9 @@ BuildRequires: libXft-devel
|
||||
Conflicts: itcl <= 3.2
|
||||
Obsoletes: tile <= 0.8.2
|
||||
Provides: tile = 0.8.2
|
||||
Patch1: tk-8.6.5-make.patch
|
||||
Patch2: tk-8.6.9.1-conf.patch
|
||||
# fix implicit linkage of freetype that breaks xft detection (#677692)
|
||||
Patch3: tk-8.6.5-fix-xft.patch
|
||||
Patch4: tk-8.6.7-no-fonts-fix.patch
|
||||
Patch1: tk-8.6.10-make.patch
|
||||
Patch2: tk-8.6.10-conf.patch
|
||||
Patch3: tk-8.6.7-no-fonts-fix.patch
|
||||
|
||||
%description
|
||||
When paired with the Tcl scripting language, Tk provides a fast and powerful
|
||||
@ -45,8 +43,7 @@ The package contains the development files and man pages for tk.
|
||||
|
||||
%patch1 -p1 -b .make
|
||||
%patch2 -p1 -b .conf
|
||||
%patch3 -p1 -b .fix-xft
|
||||
%patch4 -p1 -b .no-fonts-fix
|
||||
%patch3 -p1 -b .no-fonts-fix
|
||||
|
||||
%build
|
||||
cd unix
|
||||
@ -95,7 +92,7 @@ sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" %{bu
|
||||
%{_libdir}/%{name}%{majorver}
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/mann/*
|
||||
%doc README changes license.terms
|
||||
%doc README.md changes license.terms
|
||||
|
||||
%files devel
|
||||
%{_includedir}/*
|
||||
@ -107,6 +104,11 @@ sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" %{bu
|
||||
%{_datadir}/%{name}%{majorver}/tkAppInit.c
|
||||
|
||||
%changelog
|
||||
* Tue Nov 26 2019 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.6.10-1
|
||||
- New version
|
||||
- Upated patches
|
||||
- Dropped fix-xft patch (upstreamed)
|
||||
|
||||
* Wed Nov 6 2019 Tom Callaway <spot@fedoraproject.org> - 1:8.6.9.1-1
|
||||
- update to 8.6.9.1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user