- Revert to tk-8.4.13 since tcl has been reverted

This commit is contained in:
David Cantrell 2007-02-09 22:39:26 +00:00
parent 067681d173
commit 440dfc811e
6 changed files with 69 additions and 10 deletions

View File

@ -1 +1 @@
8118677251db51faf49bb3333ed6db16 tk8.5a5-src.tar.gz
0a16d4d9398e43cbb85784c85fb807a4 tk8.4.13-src.tar.gz

View File

@ -0,0 +1,12 @@
diff -u tk8.3.5/unix/tcl.m4~ tk8.3.5/unix/tcl.m4
--- tk8.3.5/unix/tcl.m4~ 2003-01-14 21:22:12.000000000 +0900
+++ tk8.3.5/unix/tcl.m4 2003-01-14 21:22:12.000000000 +0900
@@ -949,7 +949,7 @@
CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD="${CC} -shared"
+ SHLIB_LD='${CC} -shared -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="-rdynamic"

11
tk-8.4-no_rpath.patch Normal file
View File

@ -0,0 +1,11 @@
--- tk8.4.7/unix/tcl.m4.no_rpath 2003-12-01 14:50:28.000000000 +0100
+++ tk8.4.7/unix/tcl.m4 2003-12-01 14:50:31.000000000 +0100
@@ -1125,7 +1125,7 @@
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
- CC_SEARCH_FLAGS='-Wl,-rpath,${LIB_RUNTIME_DIR}'
+ CC_SEARCH_FLAGS=''
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
else
AC_CHECK_HEADER(dld.h, [

20
tk-8.4.13-cflags.patch Normal file
View File

@ -0,0 +1,20 @@
--- tk8.4.13/unix/tcl.m4.5-cflags 2006-07-20 15:59:01.000000000 -0400
+++ tk8.4.13/unix/tcl.m4 2006-07-20 16:01:36.000000000 -0400
@@ -1340,7 +1340,7 @@
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
if test "$have_dl" = yes; then
- SHLIB_LD='${CC} -shared -Wl,-soname,${@}'
+ SHLIB_LD='${CC} ${CFLAGS} -shared -Wl,-soname,${@}'
DL_OBJS="tclLoadDl.o"
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"
@@ -1379,7 +1379,7 @@
SHLIB_SUFFIX=".so"
if test "$have_dl" = yes; then
- SHLIB_LD="${CC} -shared"
+ SHLIB_LD="${CC} ${CFLAGS} -shared"
DL_OBJS=""
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"

11
tk-8.4.4-lib-perm.patch Normal file
View File

@ -0,0 +1,11 @@
--- tk8.4.11/unix/Makefile.in~ 2005-07-01 14:42:30.000000000 +0900
+++ tk8.4.11/unix/Makefile.in 2005-07-01 14:45:47.000000000 +0900
@@ -631,7 +631,7 @@
fi
@echo "Installing $(LIB_FILE) to $(LIB_INSTALL_DIR)/"
@@INSTALL_LIB@
- @chmod 555 $(LIB_INSTALL_DIR)/$(LIB_FILE)
+ @chmod 755 $(LIB_INSTALL_DIR)/$(LIB_FILE)
@if test "$(TK_BUILD_EXP_FILE)" != ""; then \
echo "Installing $(TK_EXP_FILE) to $(LIB_INSTALL_DIR)/"; \
$(INSTALL_DATA) $(TK_BUILD_EXP_FILE) \

23
tk.spec
View File

@ -1,9 +1,11 @@
%define majorver 8.5
%define majorver 8.4
%define epoch 1
Summary: Tk graphical toolkit for the Tcl scripting language
Name: tk
Version: %{majorver}a5
Version: %{majorver}.13
Release: 1%{?dist}
Epoch: %{epoch}
License: BSD
Group: Development/Languages
URL: http://tcl.sourceforge.net/
@ -11,15 +13,15 @@ Source0: http://download.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
Requires: tcl = %{version}
Requires(post,postun): /sbin/ldconfig
BuildRequires: tcl-devel >= %{version}, autoconf
BuildRequires: tcl-devel = %{version}, autoconf
BuildRequires: libX11-devel, sed
# panedwindow.n from itcl conflicts
Obsoletes: itcl <= 3.2
Patch1: tk-8.5a5-tclm4-soname.patch
Patch2: tk-8.5a5-lib-perm.patch
Patch3: tk-8.5a5-no_rpath.patch
Patch1: tk-8.3.5-tclm4-soname.patch
Patch2: tk-8.4.4-lib-perm.patch
Patch3: tk-8.4-no_rpath.patch
Patch4: tk-8.4.13-autoconf.patch
Patch5: tk-8.5a5-cflags.patch
Patch5: tk-8.4.13-cflags.patch
%description
When paired with the Tcl scripting language, Tk provides a fast and powerful
@ -45,7 +47,7 @@ The package contains the development files and man pages for tk.
%patch1 -p1 -b .1-soname
%patch2 -p1 -b .2-rolib
%patch3 -p1 -b .3-rpath
#%patch4 -p1 -b .4-ac213
%patch4 -p1 -b .4-ac213
%patch5 -p1 -b .5-cflags
# patch1 touches tcl.m4
@ -55,7 +57,7 @@ autoconf
%build
TOPDIR=$PWD
cd unix
%configure --enable-xft
%configure
make %{?_smp_mflags} TK_LIBRARY=%{_datadir}/%{name}%{majorver}
# do not run "make test" by default since it requires an X display
@ -117,6 +119,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/mann/*
%changelog
* Fri Feb 07 2007 David Cantrell <dcantrell@redhat.com> - 1:8.4.13-1
- Revert to tk-8.4.13 since tcl has been reverted
* Thu Jan 25 2007 Marcela Maslanova <mmaslano@redhat.com> - 8.5a5-1
- update: version 8.5a5
- Resolves: rhbz#160442