New version

This commit is contained in:
Jaroslav Škarvada 2013-08-15 10:50:20 +02:00
parent 8a65de9b41
commit 33a9fdc12b
5 changed files with 32 additions and 33 deletions

View File

@ -1,7 +1,8 @@
diff -up tk8.5.0/unix/tcl.m4.conf tk8.5.0/unix/tcl.m4
--- tk8.5.0/unix/tcl.m4.conf 2007-12-20 12:32:05.000000000 +0100
+++ tk8.5.0/unix/tcl.m4 2007-12-20 12:33:11.000000000 +0100
@@ -1427,12 +1427,12 @@ dnl AC_CHECK_TOOL(AR, ar)
diff --git a/unix/tcl.m4 b/unix/tcl.m4
index 668fa2f..9d30b33 100644
--- a/unix/tcl.m4
+++ b/unix/tcl.m4
@@ -1420,12 +1420,12 @@ AC_DEFUN([SC_CONFIG_CFLAGS], [
# get rid of the warnings.
#CFLAGS_OPTIMIZE="${CFLAGS_OPTIMIZE} -D__NO_STRING_INLINES -D__NO_MATH_INLINES"
@ -16,12 +17,3 @@ diff -up tk8.5.0/unix/tcl.m4.conf tk8.5.0/unix/tcl.m4
LD_SEARCH_FLAGS=${CC_SEARCH_FLAGS}
AS_IF([test "`uname -m`" = "alpha"], [CFLAGS="$CFLAGS -mieee"])
AS_IF([test $do64bit = yes], [
@@ -1464,7 +1464,7 @@ dnl AC_CHECK_TOOL(AR, ar)
SHLIB_CFLAGS="-fPIC"
SHLIB_SUFFIX=".so"
- SHLIB_LD='${CC} -shared'
+ SHLIB_LD='${CC} ${CFLAGS} -shared'
DL_OBJS=""
DL_LIBS="-ldl"
LDFLAGS="$LDFLAGS -Wl,--export-dynamic"

View File

@ -1,6 +1,8 @@
--- tk8.5.9/unix/configure.in.old 2010-09-02 20:12:14.000000000 +0200
+++ tk8.5.9/unix/configure.in 2011-02-17 13:32:22.719116636 +0100
@@ -530,8 +530,8 @@
diff --git a/unix/configure.in b/unix/configure.in
index 85f0a1a..013fed0 100755
--- a/unix/configure.in
+++ b/unix/configure.in
@@ -478,8 +478,8 @@ if test $tk_aqua = no; then
XFT_LIBS=`xft-config --libs 2>/dev/null` || found_xft="no"
if test "$found_xft" = "no" ; then
found_xft=yes

View File

@ -1,7 +1,8 @@
diff -up tk8.5.7/generic/tkEvent.c.old tk8.5.7/generic/tkEvent.c
--- tk8.5.7/generic/tkEvent.c.old 2008-08-05 22:31:53.000000000 +0200
+++ tk8.5.7/generic/tkEvent.c 2009-02-23 12:37:23.000000000 +0100
@@ -247,16 +247,10 @@ InvokeFocusHandlers(
diff --git a/generic/tkEvent.c b/generic/tkEvent.c
index 03e7283..25bc504 100644
--- a/generic/tkEvent.c
+++ b/generic/tkEvent.c
@@ -245,16 +245,10 @@ InvokeFocusHandlers(
}
/*
@ -20,7 +21,7 @@ diff -up tk8.5.7/generic/tkEvent.c.old tk8.5.7/generic/tkEvent.c
(*winPtrPtr)->dispPtr->lastEventTime = eventPtr->xkey.time;
*winPtrPtr = TkFocusKeyEvent(*winPtrPtr, eventPtr);
if (*winPtrPtr == NULL) {
@@ -790,7 +789,7 @@ InvokeGenericHandlers(
@@ -738,7 +732,7 @@ InvokeGenericHandlers(
int done;
tsdPtr->handlersActive++;
@ -29,7 +30,7 @@ diff -up tk8.5.7/generic/tkEvent.c.old tk8.5.7/generic/tkEvent.c
tsdPtr->handlersActive--;
if (done) {
return done;
@@ -1383,7 +1382,7 @@ Tk_HandleEvent(
@@ -1346,7 +1340,7 @@ Tk_HandleEvent(
for (handlerPtr = winPtr->handlerList; handlerPtr != NULL; ) {
if ((handlerPtr->mask & mask) != 0) {
ip.nextHandler = handlerPtr->nextPtr;
@ -38,7 +39,7 @@ diff -up tk8.5.7/generic/tkEvent.c.old tk8.5.7/generic/tkEvent.c
handlerPtr = ip.nextHandler;
} else {
handlerPtr = handlerPtr->nextPtr;
@@ -1787,7 +1786,7 @@ WindowEventProc(
@@ -1743,7 +1737,7 @@ WindowEventProc(
return 0;
}
if (tsdPtr->restrictProc != NULL) {
@ -47,7 +48,7 @@ diff -up tk8.5.7/generic/tkEvent.c.old tk8.5.7/generic/tkEvent.c
if (result != TK_PROCESS_EVENT) {
if (result == TK_DEFER_EVENT) {
return 0;
@@ -2053,7 +2052,7 @@ TkFinalize(
@@ -2059,7 +2053,7 @@ TkFinalize(
firstExitPtr = exitPtr->nextPtr;
Tcl_MutexUnlock(&exitMutex);
@ -56,7 +57,7 @@ diff -up tk8.5.7/generic/tkEvent.c.old tk8.5.7/generic/tkEvent.c
ckfree((char *) exitPtr);
Tcl_MutexLock(&exitMutex);
}
@@ -2103,7 +2102,7 @@ TkFinalizeThread(
@@ -2109,7 +2103,7 @@ TkFinalizeThread(
*/
tsdPtr->firstExitPtr = exitPtr->nextPtr;

11
tk.spec
View File

@ -1,10 +1,10 @@
%define majorver 8.5
%define vers %{majorver}.13
%define vers %{majorver}.14
Summary: The graphical toolkit for the Tcl scripting language
Name: tk
Version: %{vers}
Release: 3%{?dist}
Release: 1%{?dist}
Epoch: 1
License: TCL
Group: Development/Languages
@ -22,11 +22,11 @@ Conflicts: itcl <= 3.2
Obsoletes: tile <= 0.8.2
Provides: tile = 0.8.2
Patch1: tk8.5-make.patch
Patch2: tk-8.5.10-conf.patch
Patch2: tk-8.5.14-conf.patch
# this patch isn't needed since tk8.6b1
Patch3: tk-seg_input.patch
# fix implicit linkage of freetype that breaks xft detection (#677692)
Patch4: tk-8.5.9-fix-xft.patch
Patch4: tk-8.5.14-fix-xft.patch
%description
When paired with the Tcl scripting language, Tk provides a fast and powerful
@ -119,6 +119,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/%{name}%{majorver}/tkAppInit.c
%changelog
* Thu Aug 15 2013 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.5.14-1
- New version
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.5.13-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

View File

@ -1,7 +1,8 @@
diff -up tk8.5.2/unix/Makefile.in.ble tk8.5.2/unix/Makefile.in
--- tk8.5.2/unix/Makefile.in.ble 2008-03-28 19:46:36.000000000 +0100
+++ tk8.5.2/unix/Makefile.in 2008-05-19 14:45:52.000000000 +0200
@@ -713,7 +713,7 @@ install-binaries: $(TK_LIB_FILE) $(TK_ST
diff --git a/unix/Makefile.in b/unix/Makefile.in
index 1da2d72..6e925d8 100644
--- a/unix/Makefile.in
+++ b/unix/Makefile.in
@@ -715,7 +715,7 @@ install-binaries: $(TK_LIB_FILE) $(TK_STUB_LIB_FILE) ${WISH_EXE}
fi
@echo "Installing $(LIB_FILE) to $(DLL_INSTALL_DIR)/"
@@INSTALL_LIB@