New version
Related: rhbz#1359463
This commit is contained in:
parent
dba1f8b01a
commit
2294cc9955
2
sources
2
sources
@ -1 +1 @@
|
||||
11dbbd425c3e0201f20d6a51482ce6c4 tk8.6.5-src.tar.gz
|
||||
55eb3530faf3ea484d13929727784d33 tk8.6.6rc1-src.tar.gz
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -pruN tk8.6.4.orig/unix/tkUnixRFont.c tk8.6.4/unix/tkUnixRFont.c
|
||||
--- tk8.6.4.orig/unix/tkUnixRFont.c 2015-02-27 02:13:18.000000000 +0900
|
||||
+++ tk8.6.4/unix/tkUnixRFont.c 2015-06-10 14:35:20.639365954 +0900
|
||||
@@ -259,7 +259,7 @@ InitFont(
|
||||
*/
|
||||
|
||||
set = FcFontSort(0, pattern, FcTrue, NULL, &result);
|
||||
- if (!set) {
|
||||
+ if (!set || set->nfont == 0) {
|
||||
ckfree(fontPtr);
|
||||
return NULL;
|
||||
}
|
13
tk-8.6.6-no-fonts-fix.patch
Normal file
13
tk-8.6.6-no-fonts-fix.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/unix/tkUnixRFont.c b/unix/tkUnixRFont.c
|
||||
index 36e5462..9e2caaf 100644
|
||||
--- a/unix/tkUnixRFont.c
|
||||
+++ b/unix/tkUnixRFont.c
|
||||
@@ -268,7 +268,7 @@ InitFont(
|
||||
*/
|
||||
|
||||
set = FcFontSort(0, pattern, FcTrue, NULL, &result);
|
||||
- if (!set) {
|
||||
+ if (!set || set->nfont == 0) {
|
||||
ckfree(fontPtr);
|
||||
return NULL;
|
||||
}
|
13
tk.spec
13
tk.spec
@ -1,15 +1,16 @@
|
||||
%global prerelease rc1
|
||||
%define majorver 8.6
|
||||
%define vers %{majorver}.5
|
||||
%define vers %{majorver}.6
|
||||
|
||||
Summary: The graphical toolkit for the Tcl scripting language
|
||||
Name: tk
|
||||
Version: %{vers}
|
||||
Release: 1%{?dist}
|
||||
Release: 0.1%{?prerelease:.%{prerelease}}%{?dist}
|
||||
Epoch: 1
|
||||
License: TCL
|
||||
Group: Development/Languages
|
||||
URL: http://tcl.sourceforge.net
|
||||
Source0: http://download.sourceforge.net/sourceforge/tcl/%{name}%{version}-src.tar.gz
|
||||
Source0: http://download.sourceforge.net/sourceforge/tcl/%{name}%{version}%{?prerelease}-src.tar.gz
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: tcl = %{epoch}:%{version}
|
||||
Requires(post): /sbin/ldconfig
|
||||
@ -25,7 +26,7 @@ Patch1: tk-8.6.5-make.patch
|
||||
Patch2: tk-8.6.3-conf.patch
|
||||
# fix implicit linkage of freetype that breaks xft detection (#677692)
|
||||
Patch3: tk-8.6.5-fix-xft.patch
|
||||
Patch4: tk-8.6.4-no-fonts-fix.patch
|
||||
Patch4: tk-8.6.6-no-fonts-fix.patch
|
||||
|
||||
%description
|
||||
When paired with the Tcl scripting language, Tk provides a fast and powerful
|
||||
@ -115,6 +116,10 @@ sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" %{bu
|
||||
%{_datadir}/%{name}%{majorver}/tkAppInit.c
|
||||
|
||||
%changelog
|
||||
* Mon Jul 25 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.6.6-0.1.rc1
|
||||
- New version
|
||||
Related: rhbz#1359463
|
||||
|
||||
* Tue Mar 22 2016 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.6.5-1
|
||||
- New version
|
||||
Related: rhbz#1313909
|
||||
|
Loading…
Reference in New Issue
Block a user