- Fix xft detection (#677692)

This commit is contained in:
Jaroslav Škarvada 2011-02-17 13:54:23 +01:00
parent 0bbc898939
commit 00f228eb36
2 changed files with 20 additions and 1 deletions

13
tk-8.5.9-fix-xft.patch Normal file
View File

@ -0,0 +1,13 @@
--- tk8.5.9/unix/configure.in.old 2010-09-02 20:12:14.000000000 +0200
+++ tk8.5.9/unix/configure.in 2011-02-17 13:32:22.719116636 +0100
@@ -530,8 +530,8 @@
XFT_LIBS=`xft-config --libs 2>/dev/null` || found_xft="no"
if test "$found_xft" = "no" ; then
found_xft=yes
- XFT_CFLAGS=`pkg-config --cflags xft 2>/dev/null` || found_xft="no"
- XFT_LIBS=`pkg-config --libs xft 2>/dev/null` || found_xft="no"
+ XFT_CFLAGS=`pkg-config --cflags xft freetype2 2>/dev/null` || found_xft="no"
+ XFT_LIBS=`pkg-config --libs xft freetype2 2>/dev/null` || found_xft="no"
fi
AC_MSG_RESULT([$found_xft])
dnl make sure that compiling against Xft header file doesn't bomb

View File

@ -4,7 +4,7 @@
Summary: The graphical toolkit for the Tcl scripting language
Name: tk
Version: %{vers}
Release: 2%{?dist}
Release: 3%{?dist}
Epoch: 1
License: TCL
Group: Development/Languages
@ -25,6 +25,8 @@ Patch1: tk8.5-make.patch
Patch2: tk8.5-conf.patch
# this patch isn't needed since tk8.6b1
Patch3: tk-seg_input.patch
# fix implicit linkage of freetype that breaks xft detection (#677692)
Patch4: tk-8.5.9-fix-xft.patch
%description
When paired with the Tcl scripting language, Tk provides a fast and powerful
@ -49,6 +51,7 @@ The package contains the development files and man pages for tk.
%patch1 -p1 -b .make
%patch2 -p1 -b .conf
%patch3 -p1 -b .seg
%patch4 -p1 -b .fix-xft
%build
cd unix
@ -116,6 +119,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/*
%changelog
* Thu Feb 17 2011 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.5.9-3
- Fix xft detection (#677692)
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.5.9-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild