import tix-8.4.3-33.el9

This commit is contained in:
CentOS Sources 2022-05-17 07:04:17 -04:00 committed by Stepan Oksanichenko
commit 0584ff13e1
6 changed files with 625 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/Tix8.4.3-src.tar.gz

1
.tix.metadata Normal file
View File

@ -0,0 +1 @@
285d2f19f907ebad002ee0266f56be620d44f174 SOURCES/Tix8.4.3-src.tar.gz

View File

@ -0,0 +1,11 @@
--- Tix8.4.2/Makefile.in.link 2006-11-18 04:41:06.000000000 +0100
+++ Tix8.4.2/Makefile.in 2006-11-18 04:43:13.000000000 +0100
@@ -124,7 +124,7 @@
RANLIB = @RANLIB@
RANLIB_STUB = @RANLIB_STUB@
SHLIB_CFLAGS = @SHLIB_CFLAGS@
-SHLIB_LD = @SHLIB_LD@
+SHLIB_LD = @SHLIB_LD@ $(CFLAGS) -Wl,-soname=$(PKG_LIB_FILE)
SHLIB_LD_FLAGS = @SHLIB_LD_FLAGS@
SHLIB_LD_LIBS = @SHLIB_LD_LIBS@
STLIB_LD = @STLIB_LD@

View File

@ -0,0 +1,47 @@
diff -up Tix8.4.3/generic/tixGrUtl.c.orig Tix8.4.3/generic/tixGrUtl.c
--- Tix8.4.3/generic/tixGrUtl.c.orig 2004-03-28 04:44:56.000000000 +0200
+++ Tix8.4.3/generic/tixGrUtl.c 2018-08-01 14:49:18.839262337 +0200
@@ -191,7 +191,7 @@ int Tix_GrConfigSize(interp, wPtr, argc,
if (sizePtr->charValue != newSize.charValue) {
changed = 1;
}
- if (sizePtr->pad1 != newSize.pad0) {
+ if (sizePtr->pad0 != newSize.pad0) {
changed = 1;
}
if (sizePtr->pad1 != newSize.pad1) {
diff -up Tix8.4.3/generic/tix.h.orig Tix8.4.3/generic/tix.h
--- Tix8.4.3/generic/tix.h.orig 2008-02-28 05:35:16.000000000 +0100
+++ Tix8.4.3/generic/tix.h 2018-08-01 14:45:03.306004016 +0200
@@ -39,6 +39,7 @@ extern "C" {
#endif
#ifdef HAVE_STDLIB_H
#include <stdlib.h>
+#include <ctype.h>
#endif
#ifndef CONST84
diff -up Tix8.4.3/Python/Demo/tix/samples/CmpImg.py.orig Tix8.4.3/Python/Demo/tix/samples/CmpImg.py
--- Tix8.4.3/Python/Demo/tix/samples/CmpImg.py.orig 2001-12-10 00:29:43.000000000 +0100
+++ Tix8.4.3/Python/Demo/tix/samples/CmpImg.py 2018-08-01 14:49:57.959301881 +0200
@@ -148,7 +148,7 @@ def RunSample(w):
if not w.img0:
w.img0 = Tix.Image('bitmap', data=network_bitmap)
w.img1 = Tix.Image('pixmap', data=hard_disk_pixmap)
- if not w.img0:
+ if not w.img1:
w.img1 = Tix.Image('bitmap', data=hard_disk_bitmap)
hdd = Tix.Button(w, padx=4, pady=1, width=120)
diff -up Tix8.4.3/PyTix-2.0/demos/samples/CmpImg.py.orig Tix8.4.3/PyTix-2.0/demos/samples/CmpImg.py
--- Tix8.4.3/PyTix-2.0/demos/samples/CmpImg.py.orig 2000-11-05 20:57:44.000000000 +0100
+++ Tix8.4.3/PyTix-2.0/demos/samples/CmpImg.py 2018-08-01 14:50:14.934319043 +0200
@@ -148,7 +148,7 @@ def RunSample(w):
if not w.img0:
w.img0 = Tix.Image('bitmap', data=network_bitmap)
w.img1 = Tix.Image('pixmap', data=hard_disk_pixmap)
- if not w.img0:
+ if not w.img1:
w.img1 = Tix.Image('bitmap', data=hard_disk_bitmap)
hdd = Tix.Button(w, padx=4, pady=1, width=120)

View File

@ -0,0 +1,24 @@
diff --git a/generic/tixGrSort.c b/generic/tixGrSort.c
index 7dee30f..d45f51d 100644
--- a/generic/tixGrSort.c
+++ b/generic/tixGrSort.c
@@ -425,7 +425,7 @@ SortCompareProc(first, second)
}
} else {
int oldLength;
- char *end;
+ char *end, *result;
/*
* Generate and evaluate a command to determine which string comes
@@ -447,8 +447,8 @@ SortCompareProc(first, second)
* Parse the result of the command.
*/
- order = strtol(sortInterp->result, &end, 0);
- if ((end == sortInterp->result) || (*end != 0)) {
+ order = strtol(result = Tcl_GetStringResult(sortInterp), &end, 0);
+ if ((end == result) || (*end != 0)) {
Tcl_ResetResult(sortInterp);
Tcl_AppendResult(sortInterp,
"comparison command returned non-numeric result",

541
SPECS/tix.spec Normal file
View File

@ -0,0 +1,541 @@
%{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
%{!?tcl_sitearch: %global tcl_sitearch %{_libdir}/tcl%{tcl_version}}
%{!?tcl_sitelib: %global tcl_sitelib %{_datadir}/tcl%{tcl_version}}
%global tixmajor 8.4
%global tcltkver 8.4.13
Summary: A set of extension widgets for Tk
Name: tix
Epoch: 1
Version: %{tixmajor}.3
Release: 33%{?dist}
License: TCL
URL: http://tix.sourceforge.net/
Source0: http://downloads.sourceforge.net/project/%{name}/%{name}/%{version}/Tix%{version}-src.tar.gz
# 0: Fixes BZ#81297 (soname of libraries)
Patch0: tix-8.4.2-link.patch
Patch1: tix-8.4.3-tcl86.patch
Patch2: tix-8.4.3-covscan-fixes.patch
Requires: tcl(abi) = 8.6
Requires: tcl >= %{tcltkver}, tk >= %{tcltkver}
Requires: /etc/ld.so.conf.d
BuildRequires: make
Buildrequires: tcl-devel >= %{tcltkver}, tk-devel >= %{tcltkver}
BuildRequires: libX11-devel
BuildRequires: gcc
%description
Tix, the Tk Interface eXtension, is a powerful set of user interface
components that expands the capabilities of your Tcl/Tk and Python
applications. Using Tix together with Tk will greatly enhance the
appearance and functionality of your application.
%package devel
Summary: Tk Interface eXtension development files
Requires: tix = %{epoch}:%{version}-%{release}
%description devel
Tix, the Tk Interface eXtension, is a powerful set of user interface
components that expands the capabilities of your Tcl/Tk and Python
applications. Using Tix together with Tk will greatly enhance the
appearance and functionality of your application.
This package contains the tix development files needed for building
tix applications.
%package doc
Summary: Tk Interface eXtension documentation
Requires: tix = %{epoch}:%{version}-%{release}
%description doc
Tix, the Tk Interface eXtension, is a powerful set of user interface
components that expands the capabilities of your Tcl/Tk and Python
applications. Using Tix together with Tk will greatly enhance the
appearance and functionality of your application.
This package contains the tix documentation
%prep
%setup -q -n Tix%{version}
%patch0 -p1 -b .link
%patch1 -p1 -b .tcl86
%patch2 -p1 -b .covscan-fixes
# Remove executable permission of images in html documentation
chmod ugo-x docs/html/gif/tix/*.png docs/html/gif/tix/*.gif \
docs/html/gif/tix/*/*.gif
# Fix end-of-line encoding
sed -i 's/\r//' docs/Release-8.4.0.txt
%build
%configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --libdir=%{tcl_sitearch}
%make_build all PKG_LIB_FILE=libTix.so
%install
%make_install PKG_LIB_FILE=libTix.so
# move shared lib to tcl sitearch
mv $RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so \
$RPM_BUILD_ROOT%{tcl_sitearch}
pwd
# make links
ln -sf ../libTix.so \
$RPM_BUILD_ROOT%{tcl_sitearch}/Tix%{version}/libTix.so
ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libTix.so
ln -sf tcl%{tcl_version}/Tix%{version}/libTix.so $RPM_BUILD_ROOT%{_libdir}/libtix.so
# install demo scripts
mkdir -p $RPM_BUILD_ROOT%{tcl_sitelib}/Tix%{tixmajor}
cp -a demos $RPM_BUILD_ROOT%{tcl_sitelib}/Tix%{tixmajor}
# the header and man pages were in the previous package, keeping for now...
mkdir -p $RPM_BUILD_ROOT%{_includedir}
install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
mkdir -p $RPM_BUILD_ROOT%{_mandir}/mann
cp man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
# Handle unique library path (so apps can actually find the library)
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
echo "%{tcl_sitearch}" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/tix-%{_arch}.conf
# ship docs except pdf
rm -rf docs/pdf
find docs -name .cvsignore -exec rm '{}' ';'
# these files end up in the doc directory
rm -f $RPM_BUILD_ROOT%{_libdir}/Tix%{tixmajor}/README.txt
rm -f $RPM_BUILD_ROOT%{_libdir}/Tix%{tixmajor}/license.terms
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%{tcl_sitearch}/libTix.so
%{tcl_sitearch}/Tix%{version}
%{_sysconfdir}/ld.so.conf.d/*
%doc *.txt *.html license.terms
%files devel
%{_includedir}/tix.h
%{_libdir}/libtix.so
%{_libdir}/libTix.so
%{_mandir}/mann/*.n*
%files doc
%doc docs/*
%doc %{tcl_sitelib}/Tix%{tixmajor}
%changelog
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 1:8.4.3-33
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1:8.4.3-32
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-31
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
* Thu Nov 26 2020 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.3-30
- Use make macros, patch by Tom Stellard <tstellar@redhat.com>
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-29
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-28
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-27
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-26
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
* Thu Aug 02 2018 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.3-25
- Fix issues detected by static analysis
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-24
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
* Mon Jul 02 2018 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.3-23
- Fix license
* Tue Feb 27 2018 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.3-22
- Add BuildRequires gcc
- Remove Group tag
- Fix bogus dates in %%changelog
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-21
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:8.4.3-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
* Tue May 27 2014 Dennis Gilmore <Dennis@ausil.us> - 1:8.4.3-13
- update hardcoded tcl(abi) requires
* Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 1:8.4.3-12
- Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-11
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-10
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
* Mon Sep 10 2012 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.3-9
- Fix issues found by fedora-review utility in the spec file
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Thu Jan 14 2010 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.3-5
- Fix Source0 URL, add patch comment
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:8.4.3-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Mon Feb 9 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.3-2
- Merge review
Resolves: #226493
* Mon Jul 28 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:8.4.3-1
- update to 8.4.3
- don't apply tix-8.4.2-tcl8.5.patch, no longer needed
* Wed Feb 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1:8.4.2-5
- apps can't find libTix.so without an ld.so.conf.d file. It probably makes
more sense to move this library back into %%{_libdir}, but I'll leave that to
Vitezslav to decide.
- fix tix-8.4.2-tcl8.5.patch so that it leaves the TkPutImage define to XPutImage,
otherwise, apps just stop working.
* Thu Jan 17 2008 Jesse Keating <jkeating@redhat.com> - 1:8.4.2-4
- Rebuild, fix libTix.so link paths.
* Thu Jan 10 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.2-3
- Fix for build with tcl 8.5, change the installing paths,
remove unused variable (Marcela Maslanova <mmaslano@redhat.com>)
- Fix build issues and installation path problems for tcl 8.5,
move demo programs to -doc subpackage (Wart <wart@kobold.org>)
- Fix buildroot, tix 8.4 to tcl 8.5 compatibility patch based on
patch by Greg Couch
* Tue Aug 28 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 1:8.4.2-2
- Rebuild
* Sat Nov 18 2006 Miloslav Trmac <mitr@redhat.com> - 1:8.4.2-1
- Update to tix-8.4.2
* Thu Jul 20 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-11
- Patch from Dennis Gilmore <dennis@ausil.us> for sparc64 (#199377)
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:8.4.0-10.1
- rebuild
* Wed Jun 28 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-10
- Added missing BuildRequires for autoconf (#197117)
* Mon May 15 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-9
- BuildRequires libX11-devel
* Thu Apr 20 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-8
- Rebuild against Tcl/Tk 8.4.13
* Mon Apr 03 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-7
- libTix8.4.so shared lib placement fixup (#187739)
* Mon Mar 27 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-5
- Make sure libTix8.4.so is in /usr/lib/Tix8.4
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:8.4.0-3.1
- bump again for double-long bug on ppc(64)
* Fri Feb 10 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-3
- Added missing SONAME to libTix8.4.so
* Tue Feb 07 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-2
- Better use of macros in the install and files sections
* Mon Feb 06 2006 David Cantrell <dcantrell@redhat.com> - 1:8.4.0-1
- Upgraded to tix-8.4.0
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
- rebuilt
* Thu Mar 17 2005 Jens Petersen <petersen@redhat.com> - 1:8.1.4-100
- rebuild with gcc 4
* Sun Feb 13 2005 Jens Petersen <petersen@redhat.com> - 1:8.1.4-99
- rebuilt
* Thu Sep 30 2004 Jens Petersen <petersen@redhat.com> - 1:8.1.4-98
- use mkdir -p rather than mkdirhier (Robert Scheck, 116798,124924,132623)
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
- rebuilt
* Thu Dec 11 2003 Jens Petersen <petersen@redhat.com> - 1:8.1.4-95
- new package split out from tcltk
- build with installed tcl and tk
- build without itcl for now
- add a tixwish symlink
- clean build remnants from tixConfig.sh
- move devel files to devel subpackage
- move doc files to doc subpackage
- filter out non-tix changelog entries
* Wed Oct 15 2003 Jens Petersen <petersen@redhat.com> - 8.3.5-93
- update tix url (#101721) [reported by support@internetdiscovery.com]
* Wed Sep 17 2003 Matt Wilson <msw@redhat.com> 8.3.5-91
- rebuild to fix gzipped file md5sums (#91211)
* Fri Jul 04 2003 Jens Petersen <petersen@redhat.com> - 8.3.5-90
- make sure expect and itcl are linked against buildroot not installroot libs
- add itcl3.2-tclstubs-cfg.patch so that itcl can find tclstubs in buildroot
* Fri Mar 21 2003 Jens Petersen <petersen@redhat.com> - 8.3.5-89
- install tix pkgIndex under libdir and let it use datadir for WmDefault
(#83662 and partly #45570)
* Thu Feb 6 2003 Jens Petersen <petersen@redhat.com> - 8.3.5-88
- use ucs4 wide chars since python now does (tkinter)
- remove .cvsignore files from tix docs
* Fri Jan 17 2003 Jens Petersen <petersen@redhat.com> - 8.3.5-85
- install tix library files under datadir
- fix dangling iwidgets symlink in libdir
- build all except tclx with _smp_mflags
- add some requires
* Tue Jan 14 2003 Jens Petersen <petersen@redhat.com> - 8.3.5-84
- link all libs with DT_SONAME using tcl.m4 patch (#81297)
- drop synthetic lib provides
- update tix to 8.1.4
- include tix docs (part of #72497), except the pdf files
- revert to itcl3.2 due to 3.2.1 config problems
- fix iwidget libdir symlink
- install iwidget scripts under datadir
- remove obsolete patches from srpm
- update buildrequires
- use buildroot instead of RPM_BUILD_ROOT
- install all man pages under mandir, instead of moving some from /usr/man
- introduce _genfilelist macro for clean single-sweep find filelist generation
for each package
- use perl to remove buildroot prefix from filelists
* Thu Jan 9 2003 Jeff Johnson <jbj@redhat.com> 8.3.5-82
- synthesize libtix.so.0 and libtk.so.0 soname dependencies.
* Tue Jan 7 2003 Jeff Johnson <jbj@redhat.com> 8.3.5-80
- rebuild to generate deps for4 DSO's w/o DT_SONAME correctly.
* Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 8.3.5-79
- set execute bits on library so that requires are generated.
* Tue Dec 10 2002 Jens Petersen <petersen@redhat.com> 8.3.5-78
- make lib symlinks to .so not .so.0
* Tue Dec 10 2002 Jens Petersen <petersen@redhat.com> 8.3.5-77
- fix dangling symlinks (wish, libitcl, libitk)
- generate tix datadir filelist only from datadir
* Mon Dec 9 2002 Jens Petersen <petersen@redhat.com> 8.3.5-76
- make it build on x86_64 (details below)
- add itcl_major and use it
- patch tix so it can find itcl-3.2.1 config files
- don't explicitly update config.{guess,sub} since %%configure does it for us
- added "--without check" rpmbuild option to disable running tests in future
- build and install itcl with library files under datadir
- build tix after itcl, and actually config, build and install tix itcl library
- generate filelists from datadir and not from mandir from now on
- install tix binary libraries in libdir
* Tue Dec 3 2002 Jens Petersen <petersen@redhat.com>
- update to tcl-8.3.5, tk-8.3.5, tcl-html-8.3.5
- update url for tcl, tk, tclx, itcl, tcllib
- build without all makecfg patches for now
- in particular use upstream versioned library name convention
- add backward compatible lib symlinks for now
- add unversioned symlinks for versioned bindir files
- don't apply obsolete tix dirtree patch any more (#45570)
- set tix to epoch 1, since 8.1.3 < 8.2.0b1
- build shared tix libs
- use make's -C option rather than jumping in and out of source dirs
during install
- don't need to move itcl and tcllib man pages downunder datadir
- include all tix files in manifest (#72497)
* Mon Oct 21 2002 Jens Petersen <petersen@redhat.com>
- update to tcl-8.3.4, tk-8.3.4 (#75600), tcllib-1.3, itcl-3.2.1,
tix-8.1.3 (#59098)
- drop obsolete tcl cruft, tcl refcount, tix perf patches
- drop the crud compat dir symlinks in libdir
- replace tclvers and tkvers by tcltkvers and use it
- replace tcl_major and tk_major by tcltk_major and use it
- don't explicitly provide 64bit libs on ia64 and sparc64
- drop obsolete tix perf patch (#59098)
- update tix build steps for 8.1.3
* Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
- fix config.guess and config.sub to newer versions
* Wed Aug 29 2001 Adrian Havill <havill@redhat.com>
- hard-coded the compat symlink for tix libdir. (bug 52812)
* Tue Aug 28 2001 Adrian Havill <havill@redhat.com>
- fixed itkwish/itclsh lib problem (bug 52608)
- make itcl install not need tclsh/wish during config/make (bug 52606)
* Wed Aug 8 2001 Adrian Havill <havill@redhat.com>
- added execute bit mode for itclsh and itksh compat shells
- re-enable glibc string and math inlines; recent gcc is a-ok.
- optimize at -O2 instead of -O
- rename "soname" patches related to makefile/autoconf changes
- added elf "needed" for tk, tclx, tix, itk
* Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
- added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
- fixed 64 bit RPM provides for dependencies
* Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
- fixed DirTree in Tix (bug 45570)
* Sun Jul 8 2001 Adrian Havill <havill@redhat.com>
- refresh all sources to latest stable (TODO: separate expect/expectk)
- massage out some build stuff to patches (TODO: libtoolize hacked constants)
- remove patches already rolled into the upstream
- removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
- added all necessary header files for itcl (bug 41374)
- made compile-friendly for IA64
* Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
- bzip2 sources
* Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
- build with -D_GNU_SOURCE - fixes expect on ia64
* Tue Aug 8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
- remove symlink to libtixsam.so
* Thu Aug 3 2000 Jeff Johnson <jbj@redhat.com>
- merge "best known" patches from searching, stubs were broken.
- tix needs -fwritable-strings (#14352).
- create tixwish symlink.
* Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
- make sure that tix shared libraries are installed.
- don't mess with %%{_libdir}, it's gonna be a FHS pita.
* Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
- move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940)
* Fri Jun 2 2000 Jeff Johnson <jbj@redhat.com>
- FHS packaging changes.
- revert --enable-threads, linux is not ready (yet) (#11789).
- tcl/tk: update to 8.3.1 (#10779).
- abstract major tcltk version for soname expansion etc.
* Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
- update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
- use perl to drill out pre-pended RPM_BUILD_ROOT.
- configure with --enable-threads (experimental).
* Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
- rebuild for sparc baud rates > 38400.
* Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
- handle compressed manpages
* Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
- Make changes from bug number 7602
- Apply patch from bug number 7537
- Apply fix from bug number 7157
- Add fixes from bug #7601 to the runtcl patch
* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
- fix descriptions
- man pages are compressed (whatapain)
* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
- compile on systems where SIGPWR == SIGLOST.
* Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
- update tcl/tk to 8.0.5.
- avoid "containing" in Tix (#2332).
* Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
- use /usr/bin/write in kibitz (#1320).
- use cirrus.sprl.umich.edu in weather (#1926).
* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
- upgrade tcl/tk/tclX to 8.0.4
- add itcl 3.0.1
* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
- update tcl/tk/tclX to 8.0.3, expect is updated also.
* Thu May 07 1998 Prospector System <bugs@redhat.com>
- translations modified for de, fr, tr
* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
- updated to Tix 4.1.0.006
- updated version numbers of tcl/tk to relflect includsion of p2
* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
- updated tcl/tk to patch level 2
* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
- fixed filelist for tix... replacing path to the expect binary in scripts
was leaving junk files around.
* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
- fixed src urls
* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
- removed version numbers from descriptions
* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
- updated to tcl/tk 8.0 and related versions of packages
* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
- built against glibc