40 lines
1.1 KiB
Diff
40 lines
1.1 KiB
Diff
From 6125695b80f6a43002f454786115b0a6c1730831 Mon Sep 17 00:00:00 2001
|
|
From: Jan Grulich <jgrulich@redhat.com>
|
|
Date: Mon, 17 May 2021 13:44:32 +0200
|
|
Subject: [PATCH] SELinux: Add missing compression and install policy to
|
|
correct directory
|
|
|
|
---
|
|
unix/vncserver/selinux/Makefile | 13 ++++++++-----
|
|
1 file changed, 8 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/unix/vncserver/selinux/Makefile b/unix/vncserver/selinux/Makefile
|
|
index 7497bf846..b23f20f60 100644
|
|
--- a/unix/vncserver/selinux/Makefile
|
|
+++ b/unix/vncserver/selinux/Makefile
|
|
@@ -10,15 +10,18 @@
|
|
PREFIX=/usr
|
|
DATADIR=$(PREFIX)/share
|
|
|
|
-all: vncsession.pp
|
|
+all: vncsession.pp.bz2
|
|
+
|
|
+%.pp.bz2: %.pp
|
|
+ bzip2 -9 $^
|
|
|
|
%.pp: %.te
|
|
make -f $(DATADIR)/selinux/devel/Makefile $@
|
|
|
|
clean:
|
|
- rm -f *.pp
|
|
+ rm -f *.pp *.pp.bz2
|
|
rm -rf tmp
|
|
|
|
-install: vncsession.pp
|
|
- mkdir -p $(DESTDIR)$(DATADIR)/selinux/packages
|
|
- install vncsession.pp $(DESTDIR)$(DATADIR)/selinux/packages/vncsession.pp
|
|
+install: vncsession.pp.bz2
|
|
+ mkdir -p $(DESTDIR)$(DATADIR)/selinux/packages/targeted/
|
|
+ install vncsession.pp.bz2 $(DESTDIR)$(DATADIR)/selinux/packages/targeted/vncsession.pp.bz2
|
|
|