These extensions were first added in 1.15, so the necessary server libraries were not listed in XVNC_LIBS created by xserver114.patch.
36 lines
1.8 KiB
Diff
36 lines
1.8 KiB
Diff
diff -up tigervnc-1.3.0/unix/xserver/configure.ac.jx tigervnc-1.3.0/unix/xserver/configure.ac
|
|
--- tigervnc-1.3.0/unix/xserver/configure.ac.jx 2013-11-07 11:39:49.000000000 -0500
|
|
+++ tigervnc-1.3.0/unix/xserver/configure.ac 2013-11-07 11:40:17.215043570 -0500
|
|
@@ -1028,7 +1028,6 @@ fi
|
|
if test "x$WAYLAND" = xyes; then
|
|
PKG_CHECK_MODULES(XWAYLAND, $WAYLAND_MODULES)
|
|
AC_DEFINE(XORG_WAYLAND, 1, [Support wayland mode])
|
|
- WAYLAND_SCANNER_RULES(['$(top_srcdir)/hw/xfree86/xwayland'])
|
|
fi
|
|
AM_CONDITIONAL(WAYLAND, [test "x$WAYLAND" = xyes])
|
|
|
|
@@ -1597,7 +1596,7 @@ fi
|
|
|
|
dnl Xvnc DDX
|
|
AC_SUBST([XVNC_CPPFLAGS], ["-DHAVE_DIX_CONFIG_H $XSERVER_CFLAGS"])
|
|
-AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
|
|
+AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $DRI3_LIB $PRESENT_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
|
|
AC_SUBST([XVNC_SYS_LIBS], ["$GLX_SYS_LIBS"])
|
|
|
|
dnl Xnest DDX
|
|
diff -up tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h.jx tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h
|
|
--- tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h.jx 2013-07-01 08:41:24.000000000 -0400
|
|
+++ tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h 2013-11-07 11:39:49.749992669 -0500
|
|
@@ -44,8 +44,10 @@
|
|
#define XORG 113
|
|
#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (14 * 100000) + (99 * 1000))
|
|
#define XORG 114
|
|
+#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (15 * 100000) + (99 * 1000))
|
|
+#define XORG 115
|
|
#else
|
|
-#error "X.Org newer than 1.14 is not supported"
|
|
+#error "X.Org newer than 1.15 is not supported"
|
|
#endif
|
|
|
|
#endif
|