- update to r4113
- patches merged - tigervnc11-rh586406.patch - tigervnc11-libvnc.patch - tigervnc11-rh597172.patch - tigervnc11-rh600070.patch - tigervnc11-options.patch - don't own %%{_datadir}/icons directory (#614301) - minor improvements in the .desktop file (#616340)
This commit is contained in:
parent
29463300e4
commit
dfc68624f4
@ -1,7 +1,7 @@
|
||||
diff -up tightvnc-1.5.0-20081015svn3022/unix/vncviewer/CConn.cxx.102434 tightvnc-1.5.0-20081015svn3022/unix/vncviewer/CConn.cxx
|
||||
--- tightvnc-1.5.0-20081015svn3022/unix/vncviewer/CConn.cxx.102434 2008-10-10 17:48:22.000000000 +0200
|
||||
+++ tightvnc-1.5.0-20081015svn3022/unix/vncviewer/CConn.cxx 2008-10-22 18:35:46.000000000 +0200
|
||||
@@ -37,6 +37,8 @@
|
||||
diff -up tigervnc-1.0.90-20100721svn4113/unix/vncviewer/CConn.cxx.102434 tigervnc-1.0.90-20100721svn4113/unix/vncviewer/CConn.cxx
|
||||
--- tigervnc-1.0.90-20100721svn4113/unix/vncviewer/CConn.cxx.102434 2010-07-20 17:07:44.000000000 +0200
|
||||
+++ tigervnc-1.0.90-20100721svn4113/unix/vncviewer/CConn.cxx 2010-07-21 17:02:09.900085594 +0200
|
||||
@@ -40,6 +40,8 @@
|
||||
#include "ServerDialog.h"
|
||||
#include "PasswdDialog.h"
|
||||
#include "parameters.h"
|
||||
@ -10,7 +10,7 @@ diff -up tightvnc-1.5.0-20081015svn3022/unix/vncviewer/CConn.cxx.102434 tightvnc
|
||||
|
||||
using namespace rfb;
|
||||
|
||||
@@ -209,6 +211,15 @@ void CConn::getUserPasswd(char** user, c
|
||||
@@ -214,6 +216,15 @@ void CConn::getUserPasswd(char** user, c
|
||||
return;
|
||||
}
|
||||
|
||||
@ -23,13 +23,13 @@ diff -up tightvnc-1.5.0-20081015svn3022/unix/vncviewer/CConn.cxx.102434 tightvnc
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
const char* secType = secTypeName(getCurrentCSecurity()->getType());
|
||||
const char* secType = secTypeName(csecurity->getType());
|
||||
const char* titlePrefix = _("VNC authentication");
|
||||
unsigned int titleLen = strlen(titlePrefix) + strlen(secType) + 4;
|
||||
diff -up tightvnc-1.5.0-20081015svn3022/unix/vncviewer/parameters.h.102434 tightvnc-1.5.0-20081015svn3022/unix/vncviewer/parameters.h
|
||||
--- tightvnc-1.5.0-20081015svn3022/unix/vncviewer/parameters.h.102434 2006-05-18 13:08:21.000000000 +0200
|
||||
+++ tightvnc-1.5.0-20081015svn3022/unix/vncviewer/parameters.h 2008-10-22 18:08:47.000000000 +0200
|
||||
@@ -41,6 +41,7 @@ extern rfb::BoolParameter customCompress
|
||||
diff -up tigervnc-1.0.90-20100721svn4113/unix/vncviewer/parameters.h.102434 tigervnc-1.0.90-20100721svn4113/unix/vncviewer/parameters.h
|
||||
--- tigervnc-1.0.90-20100721svn4113/unix/vncviewer/parameters.h.102434 2009-03-23 17:49:47.000000000 +0100
|
||||
+++ tigervnc-1.0.90-20100721svn4113/unix/vncviewer/parameters.h 2010-07-21 16:55:44.414314911 +0200
|
||||
@@ -42,6 +42,7 @@ extern rfb::BoolParameter customCompress
|
||||
extern rfb::IntParameter compressLevel;
|
||||
extern rfb::BoolParameter noJpeg;
|
||||
extern rfb::IntParameter qualityLevel;
|
||||
@ -37,21 +37,22 @@ diff -up tightvnc-1.5.0-20081015svn3022/unix/vncviewer/parameters.h.102434 tight
|
||||
|
||||
extern char aboutText[];
|
||||
extern char* programName;
|
||||
diff -up tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.cxx.102434 tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.cxx
|
||||
--- tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.cxx.102434 2008-09-28 07:08:48.000000000 +0200
|
||||
+++ tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.cxx 2008-10-22 18:04:00.000000000 +0200
|
||||
@@ -58,6 +58,7 @@ IntParameter wmDecorationHeight("WMDecor
|
||||
"manager decoration around a window", 24);
|
||||
diff -up tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.cxx.102434 tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.cxx
|
||||
--- tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.cxx.102434 2010-04-23 16:06:38.000000000 +0200
|
||||
+++ tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.cxx 2010-07-21 17:01:05.979161234 +0200
|
||||
@@ -59,7 +59,7 @@ IntParameter wmDecorationHeight("WMDecor
|
||||
StringParameter passwordFile("PasswordFile",
|
||||
"Password file for VNC authentication", "");
|
||||
AliasParameter passwd("passwd", "Alias for PasswordFile", &passwordFile);
|
||||
-
|
||||
+BoolParameter passwdInput("passwdInput", "Gets password from stdin", false);
|
||||
AliasParameter rfbauth("passwd", "Alias for PasswordFile", &passwordFile);
|
||||
|
||||
BoolParameter useLocalCursor("UseLocalCursor",
|
||||
diff -up tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.man.102434 tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.man
|
||||
--- tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.man.102434 2006-06-02 06:43:52.000000000 +0200
|
||||
+++ tightvnc-1.5.0-20081015svn3022/unix/vncviewer/vncviewer.man 2008-10-22 18:04:00.000000000 +0200
|
||||
@@ -115,6 +115,11 @@ the server, you can specify it here to a
|
||||
"Render the mouse cursor locally", true);
|
||||
BoolParameter dotWhenNoCursor("DotWhenNoCursor",
|
||||
diff -up tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.man.102434 tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.man
|
||||
--- tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.man.102434 2009-10-07 17:13:00.000000000 +0200
|
||||
+++ tigervnc-1.0.90-20100721svn4113/unix/vncviewer/vncviewer.man 2010-07-21 16:55:44.414314911 +0200
|
||||
@@ -119,6 +119,11 @@ the server, you can specify it here to a
|
||||
"~/.vnc/passwd".
|
||||
|
||||
.TP
|
||||
|
@ -1,8 +1,8 @@
|
||||
%define snap 20100420svn4030
|
||||
%define snap 20100721svn4113
|
||||
|
||||
Name: tigervnc
|
||||
Version: 1.0.90
|
||||
Release: 0.16.%{snap}%{?dist}
|
||||
Release: 0.17.%{snap}%{?dist}
|
||||
Summary: A TigerVNC remote display system
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -27,6 +27,7 @@ BuildRequires: libjpeg-turbo-devel
|
||||
|
||||
Requires(post): coreutils
|
||||
Requires(postun):coreutils
|
||||
Requires: hicolor-icon-theme
|
||||
|
||||
Provides: vnc = 4.1.3-2, vnc-libs = 4.1.3-2
|
||||
Obsoletes: vnc < 4.1.3-2, vnc-libs < 4.1.3-2
|
||||
@ -36,12 +37,7 @@ Obsoletes: tightvnc < 1.5.0-0.15.20090204svn3586
|
||||
Patch0: tigervnc-102434.patch
|
||||
Patch4: tigervnc-cookie.patch
|
||||
Patch8: tigervnc-viewer-reparent.patch
|
||||
Patch9: tigervnc11-rh586406.patch
|
||||
Patch10: tigervnc11-ldnow.patch
|
||||
Patch11: tigervnc11-libvnc.patch
|
||||
Patch12: tigervnc11-rh597172.patch
|
||||
Patch13: tigervnc11-rh600070.patch
|
||||
Patch14: tigervnc11-options.patch
|
||||
|
||||
%description
|
||||
Virtual Network Computing (VNC) is a remote display system which
|
||||
@ -104,19 +100,14 @@ clients to use web browser when connect to the TigerVNC server.
|
||||
%patch0 -p1 -b .102434
|
||||
%patch4 -p1 -b .cookie
|
||||
%patch8 -p1 -b .viewer-reparent
|
||||
%patch9 -p1 -b .rh586406
|
||||
%patch10 -p1 -b .ldnow
|
||||
%patch11 -p1 -b .libvnc
|
||||
%patch12 -p1 -b .rh597172
|
||||
%patch13 -p1 -b .rh600070
|
||||
%patch14 -p1 -b .options
|
||||
|
||||
cp -r /usr/share/xorg-x11-server-source/* unix/xserver
|
||||
pushd unix/xserver
|
||||
for all in `find . -type f -perm -001`; do
|
||||
chmod -x "$all"
|
||||
done
|
||||
patch -p1 -b --suffix .vnc < ../xserver18.patch
|
||||
patch -p1 -b --suffix .vnc < ../xserver19.patch
|
||||
popd
|
||||
|
||||
# Use newer gettext
|
||||
@ -129,7 +120,7 @@ export CFLAGS="$RPM_OPT_FLAGS -fno-omit-frame-pointer"
|
||||
export CXXFLAGS="$CFLAGS"
|
||||
|
||||
autoreconf -fiv
|
||||
%configure --disable-static --with-system-jpeg
|
||||
%configure --disable-static --with-system-jpeg --disable-gnutls
|
||||
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -242,7 +233,7 @@ fi
|
||||
%defattr(-,root,root,-)
|
||||
%doc LICENCE.TXT unix/README
|
||||
%{_bindir}/vncviewer
|
||||
%{_datadir}/icons/*
|
||||
%{_datadir}/icons/hicolor/*/apps/*
|
||||
%{_datadir}/applications/*
|
||||
%{_mandir}/man1/vncviewer.1*
|
||||
|
||||
@ -273,6 +264,17 @@ fi
|
||||
%{_datadir}/vnc/classes/*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.17.20100721svn4113
|
||||
- update to r4113
|
||||
- patches merged
|
||||
- tigervnc11-rh586406.patch
|
||||
- tigervnc11-libvnc.patch
|
||||
- tigervnc11-rh597172.patch
|
||||
- tigervnc11-rh600070.patch
|
||||
- tigervnc11-options.patch
|
||||
- don't own %%{_datadir}/icons directory (#614301)
|
||||
- minor improvements in the .desktop file (#616340)
|
||||
|
||||
* Fri Jul 02 2010 Adam Tkac <atkac redhat com> 1.0.90-0.16.20100420svn4030
|
||||
- build against system-wide libjpeg-turbo (#494458)
|
||||
- build no longer requires nasm
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am.ldnow tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am
|
||||
--- tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am.ldnow 2010-05-10 13:55:28.484322693 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am 2010-05-10 13:55:37.574320863 +0200
|
||||
diff -up tigervnc-1.0.90-20100721svn4113/unix/xserver/hw/vnc/Makefile.am.ldnow tigervnc-1.0.90-20100721svn4113/unix/xserver/hw/vnc/Makefile.am
|
||||
--- tigervnc-1.0.90-20100721svn4113/unix/xserver/hw/vnc/Makefile.am.ldnow 2010-05-18 15:48:02.000000000 +0200
|
||||
+++ tigervnc-1.0.90-20100721svn4113/unix/xserver/hw/vnc/Makefile.am 2010-07-21 17:05:45.242942531 +0200
|
||||
@@ -50,7 +50,7 @@ libvnc_la_CPPFLAGS = $(XVNC_CPPFLAGS) -I
|
||||
-I$(top_srcdir)/hw/xfree86/os-support/bus \
|
||||
-I$(includedir)/pixman-1 -I$(includedir)
|
||||
@ -8,5 +8,5 @@ diff -up tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am.ldnow t
|
||||
-libvnc_la_LDFLAGS = -module -avoid-version
|
||||
+libvnc_la_LDFLAGS = -module -avoid-version -Wl,-z,now
|
||||
|
||||
libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS) $(LIBVNC_LIBS)
|
||||
libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS)
|
||||
|
||||
|
@ -1,97 +0,0 @@
|
||||
diff -up tigervnc-1.0.90-20100420svn4030/unix/xserver18.patch.libvnc tigervnc-1.0.90-20100420svn4030/unix/xserver18.patch
|
||||
--- tigervnc-1.0.90-20100420svn4030/unix/xserver18.patch.libvnc 2010-05-10 13:58:16.374321581 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/unix/xserver18.patch 2010-05-10 13:58:18.764321903 +0200
|
||||
@@ -1,15 +1,15 @@
|
||||
diff -up xserver/configure.ac.vnc xserver/configure.ac
|
||||
---- xserver/configure.ac.vnc 2010-01-22 11:23:04.524629373 +0100
|
||||
-+++ xserver/configure.ac 2010-01-22 11:31:04.704638847 +0100
|
||||
-@@ -30,7 +30,6 @@ AC_INIT([xorg-server], 1.7.99.3, [https:
|
||||
- RELEASE_DATE="(unreleased)"
|
||||
+--- xserver/configure.ac.vnc 2010-05-10 13:56:38.231834045 +0200
|
||||
++++ xserver/configure.ac 2010-05-10 13:57:28.904321140 +0200
|
||||
+@@ -30,7 +30,6 @@ AC_INIT([xorg-server], 1.8.0, [https://b
|
||||
+ RELEASE_DATE="2010-04-02"
|
||||
AC_CONFIG_SRCDIR([Makefile.am])
|
||||
AM_INIT_AUTOMAKE([foreign dist-bzip2])
|
||||
-AM_MAINTAINER_MODE
|
||||
|
||||
# Require xorg-macros: XORG_DEFAULT_OPTIONS
|
||||
m4_ifndef([XORG_MACROS_VERSION],
|
||||
-@@ -63,6 +62,7 @@ dnl forcing an entire recompile.x
|
||||
+@@ -64,6 +63,7 @@ dnl forcing an entire recompile.x
|
||||
AC_CONFIG_HEADERS(include/version-config.h)
|
||||
|
||||
AC_PROG_CC
|
||||
@@ -17,18 +17,17 @@ diff -up xserver/configure.ac.vnc xserve
|
||||
AM_PROG_AS
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_LN_S
|
||||
-@@ -1486,6 +1486,10 @@ if test "x$XVFB" = xyes; then
|
||||
+@@ -1489,6 +1489,9 @@ if test "x$XVFB" = xyes; then
|
||||
AC_SUBST([XVFB_SYS_LIBS])
|
||||
fi
|
||||
|
||||
+dnl Xvnc DDX
|
||||
+AC_SUBST([XVNC_CPPFLAGS], ["-DHAVE_DIX_CONFIG_H $XEXT_INC $FB_INC $MI_INC $RENDER_INC $RANDR_INC"])
|
||||
+AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
|
||||
-+AC_SUBST([LIBVNC_LIBS], ["$XI_LIB $DIX_LIB $XKB_LIB"])
|
||||
|
||||
dnl Xnest DDX
|
||||
|
||||
-@@ -1524,6 +1528,8 @@ xorg_bus_linuxpci=no
|
||||
+@@ -1527,6 +1530,8 @@ xorg_bus_linuxpci=no
|
||||
xorg_bus_bsdpci=no
|
||||
xorg_bus_sparc=no
|
||||
|
||||
@@ -37,7 +36,7 @@ diff -up xserver/configure.ac.vnc xserve
|
||||
if test "x$XORG" = xyes; then
|
||||
XORG_DDXINCS='-I$(top_srcdir)/hw/xfree86 -I$(top_srcdir)/hw/xfree86/include -I$(top_srcdir)/hw/xfree86/common'
|
||||
XORG_OSINCS='-I$(top_srcdir)/hw/xfree86/os-support -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/os'
|
||||
-@@ -1765,7 +1771,6 @@ if test "x$XORG" = xyes; then
|
||||
+@@ -1769,7 +1774,6 @@ if test "x$XORG" = xyes; then
|
||||
AC_DEFINE(XORGSERVER, 1, [Building Xorg server])
|
||||
AC_DEFINE(XFree86Server, 1, [Building XFree86 server])
|
||||
AC_DEFINE(XFree86LOADER, 1, [Building loadable XFree86 server])
|
||||
@@ -45,7 +44,7 @@ diff -up xserver/configure.ac.vnc xserve
|
||||
AC_DEFINE(NEED_XF86_TYPES, 1, [Need XFree86 typedefs])
|
||||
AC_DEFINE(NEED_XF86_PROTOTYPES, 1, [Need XFree86 helper functions])
|
||||
AC_DEFINE(__XSERVERNAME__, "Xorg", [Name of X server])
|
||||
-@@ -2195,6 +2200,7 @@ hw/dmx/input/Makefile
|
||||
+@@ -2214,6 +2218,7 @@ hw/dmx/input/Makefile
|
||||
hw/dmx/glxProxy/Makefile
|
||||
hw/dmx/Makefile
|
||||
hw/vfb/Makefile
|
||||
@@ -54,8 +53,8 @@ diff -up xserver/configure.ac.vnc xserve
|
||||
hw/xwin/Makefile
|
||||
hw/xquartz/Makefile
|
||||
diff -up xserver/hw/Makefile.am.vnc xserver/hw/Makefile.am
|
||||
---- xserver/hw/Makefile.am.vnc 2010-01-22 11:23:04.560613962 +0100
|
||||
-+++ xserver/hw/Makefile.am 2010-01-22 11:23:04.600597430 +0100
|
||||
+--- xserver/hw/Makefile.am.vnc 2010-05-10 13:56:38.241833494 +0200
|
||||
++++ xserver/hw/Makefile.am 2010-05-10 13:56:38.314322464 +0200
|
||||
@@ -33,7 +33,8 @@ SUBDIRS = \
|
||||
$(XNEST_SUBDIRS) \
|
||||
$(DMX_SUBDIRS) \
|
||||
@@ -67,8 +66,8 @@ diff -up xserver/hw/Makefile.am.vnc xser
|
||||
DIST_SUBDIRS = dmx xfree86 vfb xnest xwin xquartz kdrive
|
||||
|
||||
diff -up xserver/mi/miinitext.c.vnc xserver/mi/miinitext.c
|
||||
---- xserver/mi/miinitext.c.vnc 2010-01-22 11:23:04.564613258 +0100
|
||||
-+++ xserver/mi/miinitext.c 2010-01-22 11:23:04.600597430 +0100
|
||||
+--- xserver/mi/miinitext.c.vnc 2010-05-10 13:56:38.284322471 +0200
|
||||
++++ xserver/mi/miinitext.c 2010-05-10 13:56:38.314322464 +0200
|
||||
@@ -274,6 +274,7 @@ extern void DamageExtensionInit(INITARGS
|
||||
extern void CompositeExtensionInit(INITARGS);
|
||||
#endif
|
||||
diff -up tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am.libvnc tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am
|
||||
--- tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am.libvnc 2010-05-10 13:57:05.884321078 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Makefile.am 2010-05-10 13:57:11.284321719 +0200
|
||||
@@ -52,7 +52,7 @@ libvnc_la_CPPFLAGS = $(XVNC_CPPFLAGS) -I
|
||||
|
||||
libvnc_la_LDFLAGS = -module -avoid-version -Wl,-z,now
|
||||
|
||||
-libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS) $(LIBVNC_LIBS)
|
||||
+libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS)
|
||||
|
||||
EXTRA_DIST = Xvnc.man
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up tigervnc-1.0.90-20100420svn4030/unix/vncserver.options tigervnc-1.0.90-20100420svn4030/unix/vncserver
|
||||
--- tigervnc-1.0.90-20100420svn4030/unix/vncserver.options 2010-06-28 15:38:22.362275199 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/unix/vncserver 2010-06-28 15:40:05.277332830 +0200
|
||||
@@ -176,7 +176,7 @@ if ((@ARGV > 0) && ($ARGV[0] =~ /^:(\d+)
|
||||
if (!&CheckDisplayNumber($displayNumber)) {
|
||||
die "A VNC server is already running as :$displayNumber\n";
|
||||
}
|
||||
-} elsif ((@ARGV > 0) && ($ARGV[0] !~ /^-/)) {
|
||||
+} elsif ((@ARGV > 0) && ($ARGV[0] !~ /^-/) && ($ARGV[0] !~ /^\+/)) {
|
||||
&Usage();
|
||||
} else {
|
||||
$displayNumber = &GetDisplayNumber();
|
@ -1,30 +0,0 @@
|
||||
diff -up tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc.rh586406 tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc
|
||||
--- tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc.rh586406 2010-04-14 11:24:06.000000000 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc 2010-05-13 12:23:14.418190525 +0200
|
||||
@@ -31,8 +31,10 @@ extern "C" {
|
||||
#define class c_class
|
||||
#include "inputstr.h"
|
||||
#include "mi.h"
|
||||
-#ifndef XKB_IN_SERVER
|
||||
-#define XKB_IN_SERVER
|
||||
+#if XORG < 18
|
||||
+ #ifndef XKB_IN_SERVER
|
||||
+ #define XKB_IN_SERVER
|
||||
+ #endif
|
||||
#endif
|
||||
#ifdef XKB
|
||||
/*
|
||||
@@ -712,7 +714,12 @@ static KeySym KeyCodetoKeySym(KeySymsPtr
|
||||
}
|
||||
|
||||
if ((per <= (col|1)) || (syms[col|1] == NoSymbol)) {
|
||||
- XConvertCase(syms[col&~1], &lsym, &usym);
|
||||
+#if XORG >= 18
|
||||
+ XkbConvertCase
|
||||
+#else
|
||||
+ XConvertCase
|
||||
+#endif
|
||||
+ (syms[col&~1], &lsym, &usym);
|
||||
if (!(col & 1))
|
||||
return lsym;
|
||||
/*
|
@ -1,12 +0,0 @@
|
||||
diff -up tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc.rh597172 tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc
|
||||
--- tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc.rh597172 2010-06-10 16:14:57.779534382 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/unix/xserver/hw/vnc/Input.cc 2010-06-10 16:16:24.317762477 +0200
|
||||
@@ -681,6 +681,8 @@ ModeSwitchFound:
|
||||
action = down ? KeyPress : KeyRelease;
|
||||
n = GetKeyboardEvents(eventq, keyboardDev, action, kc);
|
||||
enqueueEvents(keyboardDev, n);
|
||||
+
|
||||
+ FREE_MAPS;
|
||||
|
||||
/*
|
||||
* When faking a modifier we are putting a keycode (which can
|
@ -1,28 +0,0 @@
|
||||
--- tigervnc-1.0.90-20100420svn4030/common/rfb/ConnParams.cxx.rh600070 2010-06-07 17:01:56.990676103 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/common/rfb/ConnParams.cxx 2010-06-07 17:02:21.518022631 +0200
|
||||
@@ -129,7 +129,7 @@ void ConnParams::setEncodings(int nEncod
|
||||
encodings[i] <= pseudoEncodingQualityLevel9) {
|
||||
noJpeg = false;
|
||||
qualityLevel = encodings[i] - pseudoEncodingQualityLevel0;
|
||||
- } else if (encodings[i] <= encodingMax && Encoder::supported(encodings[i]))
|
||||
+ } else if (Encoder::supported(encodings[i]))
|
||||
currentEncoding_ = encodings[i];
|
||||
}
|
||||
}
|
||||
--- tigervnc-1.0.90-20100420svn4030/common/rfb/Encoder.cxx.rh600070 2010-06-07 17:00:34.249636665 +0200
|
||||
+++ tigervnc-1.0.90-20100420svn4030/common/rfb/Encoder.cxx 2010-06-07 17:02:38.286209287 +0200
|
||||
@@ -34,12 +34,12 @@ EncoderCreateFnType Encoder::createFns[e
|
||||
|
||||
bool Encoder::supported(int encoding)
|
||||
{
|
||||
- return encoding <= encodingMax && createFns[encoding];
|
||||
+ return encoding >= 0 && encoding <= encodingMax && createFns[encoding];
|
||||
}
|
||||
|
||||
Encoder* Encoder::createEncoder(int encoding, SMsgWriter* writer)
|
||||
{
|
||||
- if (encoding <= encodingMax && createFns[encoding])
|
||||
+ if (supported(encoding))
|
||||
return (*createFns[encoding])(writer);
|
||||
return 0;
|
||||
}
|
@ -1,5 +1,4 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=TigerVNC Viewer
|
||||
Name[fr]=Visionneur TigerVNC
|
||||
Comment=Connect to VNC server and display remote desktop
|
||||
@ -9,4 +8,4 @@ Icon=tigervnc
|
||||
Terminal=false
|
||||
Type=Application
|
||||
StartupWMClass=TigerVNC Viewer: Connection Details
|
||||
Categories=Network;Application;
|
||||
Categories=Network;RemoteAccess;
|
||||
|
Loading…
Reference in New Issue
Block a user