tigervnc12-xorg113-glx.patch: Re-enable GLX against xserver 1.13

This commit is contained in:
Adam Jackson 2012-10-31 12:23:33 -04:00
parent dbcb3c2e88
commit dee05e3ef6

View File

@ -31,7 +31,6 @@ diff -up tigervnc-1.2.80-20120905svn4996/unix/xserver/hw/vnc/Makefile.am.jx tige
EXTRA_DIST = Xvnc.man
diff -up tigervnc-1.2.80-20120905svn4996/unix/xserver/hw/vnc/xvnc.cc.jx tigervnc-1.2.80-20120905svn4996/unix/xserver/hw/vnc/xvnc.cc
--- tigervnc-1.2.80-20120905svn4996/unix/xserver/hw/vnc/xvnc.cc.jx 2012-09-05 09:29:19.000000000 -0400
+++ tigervnc-1.2.80-20120905svn4996/unix/xserver/hw/vnc/xvnc.cc 2012-09-28 13:39:41.178815125 -0400
@@ -87,6 +87,17 @@ extern "C" {
@ -69,13 +68,14 @@ diff -up tigervnc-1.2.80-20120905svn4996/unix/xserver/hw/vnc/xvnc.cc.jx tigervnc
void
InitOutput(ScreenInfo *screenInfo, int argc, char **argv)
{
@@ -1571,6 +1592,12 @@ InitOutput(ScreenInfo *screenInfo, int a
@@ -1571,6 +1592,13 @@ InitOutput(ScreenInfo *screenInfo, int a
int i;
int NumFormats = 0;
+#if XORG >= 113
+#ifdef GLXEXT
+ LoadExtension(&vnc_glx_ext, TRUE);
+ if (serverGeneration == 1)
+ LoadExtension(&vnc_glx_ext, TRUE);
+#endif
+#endif
+