- add server-applet subpackage which contains Java vncviewer applet
- fix Java applet; it didn't work when run from web browser - add xorg-x11-xkb-utils to server Requires
This commit is contained in:
parent
c341915463
commit
d9b8ec5f49
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: tigervnc
|
Name: tigervnc
|
||||||
Version: 1.0.90
|
Version: 1.0.90
|
||||||
Release: 0.8.%{snap}%{?dist}
|
Release: 0.9.%{snap}%{?dist}
|
||||||
Summary: A TigerVNC remote display system
|
Summary: A TigerVNC remote display system
|
||||||
|
|
||||||
Group: User Interface/Desktops
|
Group: User Interface/Desktops
|
||||||
@ -22,7 +22,7 @@ BuildRequires: libdrm-devel, libXt-devel, pixman-devel libXfont-devel
|
|||||||
BuildRequires: libxkbfile-devel, openssl-devel, libpciaccess-devel
|
BuildRequires: libxkbfile-devel, openssl-devel, libpciaccess-devel
|
||||||
BuildRequires: mesa-libGL-devel, libXinerama-devel, ImageMagick
|
BuildRequires: mesa-libGL-devel, libXinerama-devel, ImageMagick
|
||||||
BuildRequires: freetype-devel, libXdmcp-devel
|
BuildRequires: freetype-devel, libXdmcp-devel
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils, java-1.5.0-gcj-devel
|
||||||
|
|
||||||
%ifarch %ix86 x86_64
|
%ifarch %ix86 x86_64
|
||||||
BuildRequires: nasm
|
BuildRequires: nasm
|
||||||
@ -42,6 +42,8 @@ Patch4: tigervnc-cookie.patch
|
|||||||
Patch8: tigervnc-viewer-reparent.patch
|
Patch8: tigervnc-viewer-reparent.patch
|
||||||
Patch9: tigervnc11-rh522369.patch
|
Patch9: tigervnc11-rh522369.patch
|
||||||
Patch10: tigervnc11-rh551262.patch
|
Patch10: tigervnc11-rh551262.patch
|
||||||
|
Patch11: tigervnc11-r4002.patch
|
||||||
|
Patch12: tigervnc11-r4014.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Virtual Network Computing (VNC) is a remote display system which
|
Virtual Network Computing (VNC) is a remote display system which
|
||||||
@ -66,7 +68,7 @@ Requires(postun):initscripts
|
|||||||
# Check you don't reintroduce #498184 again
|
# Check you don't reintroduce #498184 again
|
||||||
Requires: xorg-x11-fonts-misc
|
Requires: xorg-x11-fonts-misc
|
||||||
Requires: xorg-x11-xauth
|
Requires: xorg-x11-xauth
|
||||||
Requires: mesa-dri-drivers, xkeyboard-config
|
Requires: mesa-dri-drivers, xkeyboard-config, xorg-x11-xkb-utils
|
||||||
|
|
||||||
%description server
|
%description server
|
||||||
The VNC system allows you to access the same desktop from a wide
|
The VNC system allows you to access the same desktop from a wide
|
||||||
@ -88,6 +90,16 @@ This package contains libvnc.so module to X server, allowing others
|
|||||||
to access the desktop on your machine.
|
to access the desktop on your machine.
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%package server-applet
|
||||||
|
Summary: Java TigerVNC viewer applet for TigerVNC server
|
||||||
|
Group: User Interface/X
|
||||||
|
Requires: tigervnc-server
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description server-applet
|
||||||
|
The Java TigerVNC viewer applet for web browsers. Install this package to allow
|
||||||
|
clients to use web browser when connect to the TigerVNC server.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}-%{snap}
|
%setup -q -n %{name}-%{version}-%{snap}
|
||||||
|
|
||||||
@ -105,6 +117,8 @@ popd
|
|||||||
%patch8 -p1 -b .viewer-reparent
|
%patch8 -p1 -b .viewer-reparent
|
||||||
%patch9 -p0 -b .rh522369
|
%patch9 -p0 -b .rh522369
|
||||||
%patch10 -p0 -b .rh551262
|
%patch10 -p0 -b .rh551262
|
||||||
|
%patch11 -p0 -b .r4002
|
||||||
|
%patch12 -p0 -b .r4014
|
||||||
|
|
||||||
# Use newer gettext
|
# Use newer gettext
|
||||||
sed -i 's/AM_GNU_GETTEXT_VERSION.*/AM_GNU_GETTEXT_VERSION([0.17])/' \
|
sed -i 's/AM_GNU_GETTEXT_VERSION.*/AM_GNU_GETTEXT_VERSION([0.17])/' \
|
||||||
@ -145,6 +159,11 @@ pushd media
|
|||||||
make
|
make
|
||||||
popd
|
popd
|
||||||
|
|
||||||
|
# Build Java applet
|
||||||
|
pushd java/src/com/tigervnc/vncviewer/
|
||||||
|
make
|
||||||
|
popd
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf $RPM_BUILD_ROOT
|
rm -rf $RPM_BUILD_ROOT
|
||||||
make install DESTDIR=$RPM_BUILD_ROOT
|
make install DESTDIR=$RPM_BUILD_ROOT
|
||||||
@ -174,6 +193,13 @@ desktop-file-install \
|
|||||||
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
|
||||||
%{SOURCE6}
|
%{SOURCE6}
|
||||||
|
|
||||||
|
# Install Java applet
|
||||||
|
pushd java/src/com/tigervnc/vncviewer/
|
||||||
|
mkdir -p $RPM_BUILD_ROOT%{_datadir}/vnc/classes
|
||||||
|
install -m755 VncViewer.jar $RPM_BUILD_ROOT%{_datadir}/vnc/classes
|
||||||
|
install -m644 index.vnc $RPM_BUILD_ROOT%{_datadir}/vnc/classes
|
||||||
|
popd
|
||||||
|
|
||||||
%find_lang %{name} %{name}.lang
|
%find_lang %{name} %{name}.lang
|
||||||
|
|
||||||
# remove unwanted files
|
# remove unwanted files
|
||||||
@ -241,7 +267,17 @@ fi
|
|||||||
%{_libdir}/xorg/modules/extensions/libvnc.so
|
%{_libdir}/xorg/modules/extensions/libvnc.so
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
%files server-applet
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%doc java/src/com/tigervnc/vncviewer/README
|
||||||
|
%{_datadir}/vnc/classes/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
|
||||||
|
- add server-applet subpackage which contains Java vncviewer applet
|
||||||
|
- fix Java applet; it didn't work when run from web browser
|
||||||
|
- add xorg-x11-xkb-utils to server Requires
|
||||||
|
|
||||||
* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
|
* Fri Mar 12 2010 Adam Tkac <atkac redhat com> 1.0.90-0.8.20100219svn3993
|
||||||
- add French translation to vncviewer.desktop (thanks to Alain Portal)
|
- add French translation to vncviewer.desktop (thanks to Alain Portal)
|
||||||
|
|
||||||
|
45
tigervnc11-r4002.patch
Normal file
45
tigervnc11-r4002.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
Index: java/src/com/tigervnc/vncviewer/MANIFEST.MF
|
||||||
|
===================================================================
|
||||||
|
--- java/src/com/tigervnc/vncviewer/MANIFEST.MF (revision 4001)
|
||||||
|
+++ java/src/com/tigervnc/vncviewer/MANIFEST.MF (revision 4002)
|
||||||
|
@@ -1,2 +1,2 @@
|
||||||
|
Manifest-Version: 1.0
|
||||||
|
-Main-Class: VncViewer
|
||||||
|
+Main-Class: com.tigervnc.vncviewer.VncViewer
|
||||||
|
Index: java/src/com/tigervnc/vncviewer/index.html
|
||||||
|
===================================================================
|
||||||
|
--- java/src/com/tigervnc/vncviewer/index.html (revision 4001)
|
||||||
|
+++ java/src/com/tigervnc/vncviewer/index.html (revision 4002)
|
||||||
|
@@ -20,7 +20,7 @@
|
||||||
|
<TITLE>
|
||||||
|
TigerVNC desktop
|
||||||
|
</TITLE>
|
||||||
|
-<APPLET CODE="VncViewer.class" ARCHIVE="VncViewer.jar"
|
||||||
|
+<APPLET CODE="com.tigervnc.vncviewer.VncViewer" ARCHIVE="VncViewer.jar"
|
||||||
|
WIDTH="800" HEIGHT="632">
|
||||||
|
<PARAM NAME="PORT" VALUE="5901">
|
||||||
|
</APPLET>
|
||||||
|
Index: java/src/com/tigervnc/vncviewer/Makefile
|
||||||
|
===================================================================
|
||||||
|
--- java/src/com/tigervnc/vncviewer/Makefile (revision 4001)
|
||||||
|
+++ java/src/com/tigervnc/vncviewer/Makefile (revision 4002)
|
||||||
|
@@ -35,7 +35,12 @@
|
||||||
|
$(JC) $(JCFLAGS) -O $(SOURCES)
|
||||||
|
|
||||||
|
$(ARCHIVE): $(CLASSES) $(MANIFEST)
|
||||||
|
- $(JAR) cfm $(ARCHIVE) $(MANIFEST) $(CLASSES)
|
||||||
|
+ cd ../../..; \
|
||||||
|
+ $(JAR) cfm com/tigervnc/vncviewer/$(ARCHIVE) \
|
||||||
|
+ com/tigervnc/vncviewer/$(MANIFEST) \
|
||||||
|
+ com/tigervnc/vncviewer/*.class \
|
||||||
|
+ com/tigervnc/decoder/*.class \
|
||||||
|
+ com/tigervnc/decoder/common/*.class
|
||||||
|
|
||||||
|
install: $(CLASSES) $(ARCHIVE)
|
||||||
|
$(CP) $(CLASSES) $(ARCHIVE) $(PAGES) $(INSTALL_DIR)
|
||||||
|
@@ -44,4 +49,4 @@
|
||||||
|
@$(ExportJavaClasses)
|
||||||
|
|
||||||
|
clean::
|
||||||
|
- $(RM) *.class *.jar
|
||||||
|
+ $(RM) *.class *.jar ../decoder/*.class ../decoder/common/*.class
|
13
tigervnc11-r4014.patch
Normal file
13
tigervnc11-r4014.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: java/src/com/tigervnc/vncviewer/index.vnc
|
||||||
|
===================================================================
|
||||||
|
--- java/src/com/tigervnc/vncviewer/index.vnc (revision 4013)
|
||||||
|
+++ java/src/com/tigervnc/vncviewer/index.vnc (revision 4014)
|
||||||
|
@@ -15,7 +15,7 @@
|
||||||
|
<TITLE>
|
||||||
|
$USER's $DESKTOP desktop ($DISPLAY)
|
||||||
|
</TITLE>
|
||||||
|
-<APPLET CODE=VncViewer.class ARCHIVE=VncViewer.jar
|
||||||
|
+<APPLET CODE=com.tigervnc.vncviewer.VncViewer ARCHIVE=VncViewer.jar
|
||||||
|
WIDTH=$APPLETWIDTH HEIGHT=$APPLETHEIGHT>
|
||||||
|
<param name=PORT value=$PORT>
|
||||||
|
$PARAMS
|
Loading…
Reference in New Issue
Block a user