Merge branch 'master' of ssh://pkgs.fedoraproject.org/tigervnc
Conflicts: tigervnc.spec xserver110.patch
This commit is contained in:
commit
d47b40fea4
@ -148,7 +148,6 @@ autoreconf -fiv
|
||||
--disable-xorg --disable-xnest --disable-xvfb --disable-dmx \
|
||||
--disable-xwin --disable-xephyr --disable-kdrive --with-pic \
|
||||
--disable-static --disable-xinerama \
|
||||
--disable-composite \
|
||||
--with-default-font-path="catalogue:%{_sysconfdir}/X11/fontpath.d,built-ins" \
|
||||
--with-fontdir=%{_datadir}/X11/fonts \
|
||||
--with-xkb-output=%{_localstatedir}/lib/xkb \
|
||||
@ -296,6 +295,18 @@ fi
|
||||
- tigervnc11-xorg111.patch
|
||||
- tigervnc11-xorg112.patch
|
||||
|
||||
* Fri Aug 10 2012 Dave Airlie <airlied@redhat.com> 1.1.0-10
|
||||
- fix build against newer X server
|
||||
|
||||
* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 1.1.0-9
|
||||
- Build with the Composite extension for feature parity with other X servers
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Dave Airlie <airlied@redhat.com> 1.1.0-7
|
||||
- fix building against X.org 1.13
|
||||
|
||||
* Wed Apr 04 2012 Adam Jackson <ajax@redhat.com> 1.1.0-6
|
||||
- RHEL exclusion for -server-module on ppc* too
|
||||
|
||||
|
145
tigervnc11-xorg113.patch
Normal file
145
tigervnc11-xorg113.patch
Normal file
@ -0,0 +1,145 @@
|
||||
diff -up xserver/hw/vnc/Makefile.am.xorg113 xserver/hw/vnc/Makefile.am
|
||||
--- xserver/hw/vnc/Makefile.am.xorg113 2012-07-19 21:42:46.297455970 -0400
|
||||
+++ xserver/hw/vnc/Makefile.am 2012-07-19 21:19:22.526005528 -0400
|
||||
@@ -62,7 +62,7 @@ EXTRA_DIST = Xvnc.man
|
||||
BUILT_SOURCES = $(nodist_Xvnc_SOURCES)
|
||||
|
||||
fb.h: $(top_srcdir)/fb/fb.h
|
||||
- cat $(top_srcdir)/fb/fb.h | sed -e 's,and,c_and,' -e 's,xor,c_xor,' > $(srcdir)/fb.h
|
||||
+ cat $(top_srcdir)/fb/fb.h | sed -e 's,and,c_and,g' -e 's,xor,c_xor,g' > $(srcdir)/fb.h
|
||||
|
||||
pixman.h: $(includedir)/pixman-1/pixman.h
|
||||
cat $(includedir)/pixman-1/pixman.h | sed 's/xor/c_xor/' > $(srcdir)/pixman.h
|
||||
diff -up xserver/hw/vnc/vncHooks.cc.xorg113 xserver/hw/vnc/vncHooks.cc
|
||||
--- xserver/hw/vnc/vncHooks.cc.xorg113 2012-07-19 21:31:37.191820942 -0400
|
||||
+++ xserver/hw/vnc/vncHooks.cc 2012-07-19 21:36:00.327531293 -0400
|
||||
@@ -116,7 +116,7 @@ static DevPrivateKeyRec vncHooksGCKeyRec
|
||||
|
||||
// screen functions
|
||||
|
||||
-static Bool vncHooksCloseScreen(int i, ScreenPtr pScreen);
|
||||
+static Bool vncHooksCloseScreen(ScreenPtr pScreen);
|
||||
static Bool vncHooksCreateGC(GCPtr pGC);
|
||||
static void vncHooksCopyWindow(WindowPtr pWin, DDXPointRec ptOldOrg,
|
||||
RegionPtr pOldRegion);
|
||||
@@ -133,7 +133,7 @@ static Bool vncHooksDisplayCursor(
|
||||
DeviceIntPtr pDev,
|
||||
#endif
|
||||
ScreenPtr pScreen, CursorPtr cursor);
|
||||
-static void vncHooksBlockHandler(int i, pointer blockData, pointer pTimeout,
|
||||
+static void vncHooksBlockHandler(ScreenPtr pScreen_, pointer pTimeout,
|
||||
pointer pReadmask);
|
||||
#ifdef RENDER
|
||||
static void vncHooksComposite(CARD8 op, PicturePtr pSrc, PicturePtr pMask,
|
||||
@@ -335,7 +335,7 @@ Bool vncHooksInit(ScreenPtr pScreen, Xse
|
||||
// CloseScreen - unwrap the screen functions and call the original CloseScreen
|
||||
// function
|
||||
|
||||
-static Bool vncHooksCloseScreen(int i, ScreenPtr pScreen_)
|
||||
+static Bool vncHooksCloseScreen(ScreenPtr pScreen_)
|
||||
{
|
||||
SCREEN_UNWRAP(pScreen_, CloseScreen);
|
||||
|
||||
@@ -366,7 +366,7 @@ static Bool vncHooksCloseScreen(int i, S
|
||||
|
||||
DBGPRINT((stderr,"vncHooksCloseScreen: unwrapped screen functions\n"));
|
||||
|
||||
- return (*pScreen->CloseScreen)(i, pScreen);
|
||||
+ return (*pScreen->CloseScreen)(pScreen);
|
||||
}
|
||||
|
||||
// CreateGC - wrap the "GC funcs"
|
||||
@@ -531,14 +531,14 @@ static Bool vncHooksDisplayCursor(
|
||||
// BlockHandler - ignore any changes during the block handler - it's likely
|
||||
// these are just drawing the cursor.
|
||||
|
||||
-static void vncHooksBlockHandler(int i, pointer blockData, pointer pTimeout,
|
||||
+static void vncHooksBlockHandler(ScreenPtr pScreen_, pointer pTimeout,
|
||||
pointer pReadmask)
|
||||
{
|
||||
- SCREEN_UNWRAP(screenInfo.screens[i], BlockHandler);
|
||||
+ SCREEN_UNWRAP(pScreen_, BlockHandler);
|
||||
|
||||
vncHooksScreen->desktop->ignoreHooks(true);
|
||||
|
||||
- (*pScreen->BlockHandler) (i, blockData, pTimeout, pReadmask);
|
||||
+ (*pScreen->BlockHandler) (pScreen, pTimeout, pReadmask);
|
||||
|
||||
vncHooksScreen->desktop->ignoreHooks(false);
|
||||
|
||||
diff -up xserver/hw/vnc/xf86vncModule.cc.xorg113 xserver/hw/vnc/xf86vncModule.cc
|
||||
--- xserver/hw/vnc/xf86vncModule.cc.xorg113 2012-07-19 21:19:27.558942606 -0400
|
||||
+++ xserver/hw/vnc/xf86vncModule.cc 2012-07-19 21:19:27.574942408 -0400
|
||||
@@ -53,8 +53,6 @@ ExtensionModule vncExt =
|
||||
{
|
||||
vncExtensionInitWithParams,
|
||||
"VNC",
|
||||
- NULL,
|
||||
- NULL,
|
||||
NULL
|
||||
};
|
||||
|
||||
diff -up xserver/hw/vnc/xorg-version.h.xorg113 xserver/hw/vnc/xorg-version.h
|
||||
--- xserver/hw/vnc/xorg-version.h.xorg113 2012-07-19 21:19:27.560942582 -0400
|
||||
+++ xserver/hw/vnc/xorg-version.h 2012-07-19 21:19:27.576942382 -0400
|
||||
@@ -40,6 +40,8 @@
|
||||
#define XORG 111
|
||||
#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (12 * 100000) + (99 * 1000))
|
||||
#define XORG 112
|
||||
+#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (13 * 100000) + (99 * 1000))
|
||||
+#define XORG 113
|
||||
#else
|
||||
#error "X.Org newer than 1.10 is not supported"
|
||||
#endif
|
||||
diff -up xserver/hw/vnc/xvnc.cc.xorg113 xserver/hw/vnc/xvnc.cc
|
||||
--- xserver/hw/vnc/xvnc.cc.xorg113 2012-07-19 21:36:33.078121854 -0400
|
||||
+++ xserver/hw/vnc/xvnc.cc 2012-07-19 21:39:49.685663920 -0400
|
||||
@@ -267,7 +267,7 @@ OsVendorInit()
|
||||
}
|
||||
|
||||
void
|
||||
-OsVendorFatalError()
|
||||
+OsVendorFatalError(const char *f, va_list args)
|
||||
{
|
||||
}
|
||||
|
||||
@@ -1135,9 +1135,9 @@ static Bool vncRandRSetConfig (ScreenPtr
|
||||
#endif
|
||||
|
||||
static Bool
|
||||
-vfbCloseScreen(int index, ScreenPtr pScreen)
|
||||
+vfbCloseScreen(ScreenPtr pScreen)
|
||||
{
|
||||
- vfbScreenInfoPtr pvfb = &vfbScreens[index];
|
||||
+ vfbScreenInfoPtr pvfb = &vfbScreens[pScreen->myNum];
|
||||
int i;
|
||||
|
||||
pScreen->CloseScreen = pvfb->closeScreen;
|
||||
@@ -1149,13 +1149,13 @@ vfbCloseScreen(int index, ScreenPtr pScr
|
||||
for (i = 0; i < MAXSCREENS; i++)
|
||||
InstalledMaps[i] = NULL;
|
||||
|
||||
- return pScreen->CloseScreen(index, pScreen);
|
||||
+ return pScreen->CloseScreen(pScreen);
|
||||
}
|
||||
|
||||
static Bool
|
||||
-vfbScreenInit(int index, ScreenPtr pScreen, int argc, char **argv)
|
||||
+vfbScreenInit(ScreenPtr pScreen, int argc, char **argv)
|
||||
{
|
||||
- vfbScreenInfoPtr pvfb = &vfbScreens[index];
|
||||
+ vfbScreenInfoPtr pvfb = &vfbScreens[pScreen->myNum];
|
||||
int dpi;
|
||||
int ret;
|
||||
void *pbits;
|
||||
@@ -1167,8 +1167,8 @@ vfbScreenInit(int index, ScreenPtr pScre
|
||||
|
||||
pbits = vfbAllocateFramebufferMemory(&pvfb->fb);
|
||||
if (!pbits) return FALSE;
|
||||
- vncFbptr[index] = pbits;
|
||||
- vncFbstride[index] = pvfb->fb.paddedWidth;
|
||||
+ vncFbptr[pScreen->myNum] = pbits;
|
||||
+ vncFbstride[pScreen->myNum] = pvfb->fb.paddedWidth;
|
||||
|
||||
miSetPixmapDepths();
|
||||
|
Loading…
Reference in New Issue
Block a user