Drop incorrect tigervnc-c99-2.patch.
This commit is contained in:
parent
2957f63ae9
commit
b9b7e9d49d
@ -1,23 +0,0 @@
|
|||||||
commit 25a03f430f47733b215eb9f0251e25ce7bdb7ada
|
|
||||||
Author: Florian Weimer <fweimer@redhat.com>
|
|
||||||
Date: Wed Nov 22 12:57:03 2023 +0100
|
|
||||||
|
|
||||||
cmake: Use correct input pointer type for iconv detection
|
|
||||||
|
|
||||||
The iconv function expects a char ** pointer argument for the input
|
|
||||||
pointer. Future C compilers will flag this as an error (as it is not
|
|
||||||
valid C), causing this probe to fail incorrectly.
|
|
||||||
|
|
||||||
diff --git a/cmake/Modules/FindIconv.cmake b/cmake/Modules/FindIconv.cmake
|
|
||||||
index cf268ea0..9cd899da 100644
|
|
||||||
--- a/cmake/Modules/FindIconv.cmake
|
|
||||||
+++ b/cmake/Modules/FindIconv.cmake
|
|
||||||
@@ -36,7 +36,7 @@ IF(ICONV_FOUND)
|
|
||||||
#include <iconv.h>
|
|
||||||
int main(){
|
|
||||||
iconv_t conv = 0;
|
|
||||||
- const char* in = 0;
|
|
||||||
+ char* in = 0;
|
|
||||||
size_t ilen = 0;
|
|
||||||
char* out = 0;
|
|
||||||
size_t olen = 0;
|
|
@ -6,7 +6,7 @@
|
|||||||
|
|
||||||
Name: tigervnc
|
Name: tigervnc
|
||||||
Version: 1.13.1
|
Version: 1.13.1
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
Summary: A TigerVNC remote display system
|
Summary: A TigerVNC remote display system
|
||||||
|
|
||||||
%global _hardened_build 1
|
%global _hardened_build 1
|
||||||
@ -32,7 +32,6 @@ Patch1: tigervnc-vncsession-restore-script-systemd-service.patch
|
|||||||
Patch100: tigervnc-xserver120.patch
|
Patch100: tigervnc-xserver120.patch
|
||||||
|
|
||||||
Patch101: tigervnc-c99-1.patch
|
Patch101: tigervnc-c99-1.patch
|
||||||
Patch102: tigervnc-c99-2.patch
|
|
||||||
|
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -200,7 +199,6 @@ sed -i -e '/add_subdirectory.*vnc/d' unix/CMakeLists.txt
|
|||||||
# Downstream patches
|
# Downstream patches
|
||||||
|
|
||||||
%patch101 -p1 -b .c99-1
|
%patch101 -p1 -b .c99-1
|
||||||
%patch102 -p1 -b .c99-2
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%ifarch sparcv9 sparc64 s390 s390x
|
%ifarch sparcv9 sparc64 s390 s390x
|
||||||
@ -385,6 +383,9 @@ fi
|
|||||||
%{_datadir}/icons/hicolor/*/apps/*
|
%{_datadir}/icons/hicolor/*/apps/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 22 2023 Florian Weimer <fweimer@redhat.com> - 1.13.1-8
|
||||||
|
- Drop incorrect tigervnc-c99-2.patch.
|
||||||
|
|
||||||
* Wed Nov 22 2023 Florian Weimer <fweimer@redhat.com> - 1.13.1-7
|
* Wed Nov 22 2023 Florian Weimer <fweimer@redhat.com> - 1.13.1-7
|
||||||
- C compatibility fixes
|
- C compatibility fixes
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user