Fix libvnc.so module loading.
Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
b9c453b224
commit
a841f6965c
@ -2,7 +2,7 @@
|
||||
|
||||
Name: tigervnc
|
||||
Version: 1.0.90
|
||||
Release: 0.30.%{snap}%{?dist}
|
||||
Release: 0.31.%{snap}%{?dist}
|
||||
Summary: A TigerVNC remote display system
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -43,6 +43,7 @@ Patch0: tigervnc-102434.patch
|
||||
Patch4: tigervnc-cookie.patch
|
||||
Patch8: tigervnc-viewer-reparent.patch
|
||||
Patch10: tigervnc11-ldnow.patch
|
||||
Patch11: tigervnc11-gethomedir.patch
|
||||
|
||||
%description
|
||||
Virtual Network Computing (VNC) is a remote display system which
|
||||
@ -128,6 +129,7 @@ This package contains license of the TigerVNC suite
|
||||
%patch4 -p1 -b .cookie
|
||||
%patch8 -p1 -b .viewer-reparent
|
||||
%patch10 -p1 -b .ldnow
|
||||
%patch11 -p1 -b .gethomedir
|
||||
|
||||
cp -r /usr/share/xorg-x11-server-source/* unix/xserver
|
||||
pushd unix/xserver
|
||||
@ -297,6 +299,9 @@ fi
|
||||
%doc LICENCE.TXT
|
||||
|
||||
%changelog
|
||||
* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.31.20110117svn4237
|
||||
- fix libvnc.so module loading
|
||||
|
||||
* Mon Jan 17 2011 Adam Tkac <atkac redhat com> 1.0.90-0.30.20110117svn4237
|
||||
- update to r4237
|
||||
- patches merged
|
||||
|
20
tigervnc11-gethomedir.patch
Normal file
20
tigervnc11-gethomedir.patch
Normal file
@ -0,0 +1,20 @@
|
||||
diff -up tigervnc-1.0.90-20110117svn4237/unix/xserver/hw/vnc/Makefile.am.gethomedir tigervnc-1.0.90-20110117svn4237/unix/xserver/hw/vnc/Makefile.am
|
||||
--- tigervnc-1.0.90-20110117svn4237/unix/xserver/hw/vnc/Makefile.am.gethomedir 2011-01-17 13:04:31.006562632 +0100
|
||||
+++ tigervnc-1.0.90-20110117svn4237/unix/xserver/hw/vnc/Makefile.am 2011-01-17 13:05:40.226028354 +0100
|
||||
@@ -5,6 +5,7 @@ RFB_LIB=$(LIB_DIR)/rfb/librfb.la
|
||||
RDR_LIB=$(LIB_DIR)/rdr/librdr.la
|
||||
NETWORK_LIB=$(LIB_DIR)/network/libnetwork.la
|
||||
XREGION_LIB=$(LIB_DIR)/Xregion/libXregion.la
|
||||
+OS_LIB=$(LIB_DIR)/os/libos.la
|
||||
COMMON_LIBS=$(NETWORK_LIB) $(RFB_LIB) $(RDR_LIB) $(XREGION_LIB)
|
||||
|
||||
noinst_LTLIBRARIES = libvnccommon.la
|
||||
@@ -52,7 +53,7 @@ libvnc_la_CPPFLAGS = $(XVNC_CPPFLAGS) -I
|
||||
|
||||
libvnc_la_LDFLAGS = -module -avoid-version -Wl,-z,now
|
||||
|
||||
-libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS)
|
||||
+libvnc_la_LIBADD = libvnccommon.la $(COMMON_LIBS) $(OS_LIB)
|
||||
|
||||
EXTRA_DIST = Xvnc.man
|
||||
|
Loading…
Reference in New Issue
Block a user