Fix build against xorg-x11-server-1.16.0 (bug #1136532).
Resolves: rhbz#1136532
This commit is contained in:
parent
c4a8e0ed87
commit
925346b265
@ -1,15 +1,15 @@
|
||||
diff -up xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased xorg-server-1.15.99.904/configure.ac
|
||||
--- xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased 2014-07-15 09:08:45.084879742 +0100
|
||||
+++ xorg-server-1.15.99.904/configure.ac 2014-07-15 09:09:25.421078698 +0100
|
||||
@@ -76,6 +76,7 @@ dnl os-strfeatures.h covers HAVE_STRFOO
|
||||
AC_CONFIG_HEADERS(include/os-strfeatures.h)
|
||||
diff -up xorg-server-1.16.0/configure.ac.vnc xorg-server-1.16.0/configure.ac
|
||||
--- xorg-server-1.16.0/configure.ac.vnc 2014-07-17 08:00:51.000000000 +0100
|
||||
+++ xorg-server-1.16.0/configure.ac 2014-09-03 10:21:49.506109235 +0100
|
||||
@@ -74,6 +74,7 @@ dnl forcing an entire recompile.x
|
||||
AC_CONFIG_HEADERS(include/version-config.h)
|
||||
|
||||
AM_PROG_AS
|
||||
+AC_PROG_CXX
|
||||
AC_PROG_LN_S
|
||||
LT_PREREQ([2.2])
|
||||
LT_INIT([disable-static win32-dll])
|
||||
@@ -1797,6 +1798,10 @@ if test "x$XVFB" = xyes; then
|
||||
@@ -1795,6 +1796,10 @@ if test "x$XVFB" = xyes; then
|
||||
AC_SUBST([XVFB_SYS_LIBS])
|
||||
fi
|
||||
|
||||
@ -20,7 +20,7 @@ diff -up xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased xorg-server-1
|
||||
|
||||
dnl Xnest DDX
|
||||
|
||||
@@ -1832,6 +1837,8 @@ if test "x$XORG" = xauto; then
|
||||
@@ -1830,6 +1835,8 @@ if test "x$XORG" = xauto; then
|
||||
fi
|
||||
AC_MSG_RESULT([$XORG])
|
||||
|
||||
@ -29,7 +29,7 @@ diff -up xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased xorg-server-1
|
||||
if test "x$XORG" = xyes; then
|
||||
XORG_DDXINCS='-I$(top_srcdir)/hw/xfree86 -I$(top_srcdir)/hw/xfree86/include -I$(top_srcdir)/hw/xfree86/common'
|
||||
XORG_OSINCS='-I$(top_srcdir)/hw/xfree86/os-support -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/os'
|
||||
@@ -2053,7 +2060,6 @@ if test "x$XORG" = xyes; then
|
||||
@@ -2051,7 +2058,6 @@ if test "x$XORG" = xyes; then
|
||||
AC_DEFINE(XORG_SERVER, 1, [Building Xorg server])
|
||||
AC_DEFINE(XORGSERVER, 1, [Building Xorg server])
|
||||
AC_DEFINE(XFree86Server, 1, [Building XFree86 server])
|
||||
@ -37,7 +37,7 @@ diff -up xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased xorg-server-1
|
||||
AC_DEFINE(NEED_XF86_TYPES, 1, [Need XFree86 typedefs])
|
||||
AC_DEFINE(NEED_XF86_PROTOTYPES, 1, [Need XFree86 helper functions])
|
||||
AC_DEFINE(__XSERVERNAME__, "Xorg", [Name of X server])
|
||||
@@ -2591,6 +2597,7 @@ hw/dmx/Makefile
|
||||
@@ -2589,6 +2595,7 @@ hw/dmx/Makefile
|
||||
hw/dmx/man/Makefile
|
||||
hw/vfb/Makefile
|
||||
hw/vfb/man/Makefile
|
||||
@ -45,9 +45,9 @@ diff -up xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased xorg-server-1
|
||||
hw/xnest/Makefile
|
||||
hw/xnest/man/Makefile
|
||||
hw/xwin/Makefile
|
||||
diff -up xorg-server-1.15.99.904/hw/Makefile.am.xserver-1.14-rebased xorg-server-1.15.99.904/hw/Makefile.am
|
||||
--- xorg-server-1.15.99.904/hw/Makefile.am.xserver-1.14-rebased 2014-07-15 09:09:25.422078703 +0100
|
||||
+++ xorg-server-1.15.99.904/hw/Makefile.am 2014-07-15 09:10:09.560296411 +0100
|
||||
diff -up xorg-server-1.16.0/hw/Makefile.am.vnc xorg-server-1.16.0/hw/Makefile.am
|
||||
--- xorg-server-1.16.0/hw/Makefile.am.vnc 2014-04-16 21:24:00.000000000 +0100
|
||||
+++ xorg-server-1.16.0/hw/Makefile.am 2014-09-03 10:21:49.507109234 +0100
|
||||
@@ -38,7 +38,8 @@ SUBDIRS = \
|
||||
$(DMX_SUBDIRS) \
|
||||
$(KDRIVE_SUBDIRS) \
|
||||
@ -58,9 +58,9 @@ diff -up xorg-server-1.15.99.904/hw/Makefile.am.xserver-1.14-rebased xorg-server
|
||||
|
||||
DIST_SUBDIRS = dmx xfree86 vfb xnest xwin xquartz kdrive xwayland
|
||||
|
||||
diff -up xorg-server-1.15.99.904/mi/miinitext.c.xserver-1.14-rebased xorg-server-1.15.99.904/mi/miinitext.c
|
||||
--- xorg-server-1.15.99.904/mi/miinitext.c.xserver-1.14-rebased 2014-04-16 21:24:00.000000000 +0100
|
||||
+++ xorg-server-1.15.99.904/mi/miinitext.c 2014-07-15 09:11:42.968757142 +0100
|
||||
diff -up xorg-server-1.16.0/mi/miinitext.c.vnc xorg-server-1.16.0/mi/miinitext.c
|
||||
--- xorg-server-1.16.0/mi/miinitext.c.vnc 2014-04-16 21:24:00.000000000 +0100
|
||||
+++ xorg-server-1.16.0/mi/miinitext.c 2014-09-03 10:21:49.508109234 +0100
|
||||
@@ -111,6 +111,10 @@ SOFTWARE.
|
||||
#include "micmap.h"
|
||||
#include "globals.h"
|
||||
@ -82,9 +82,9 @@ diff -up xorg-server-1.15.99.904/mi/miinitext.c.xserver-1.14-rebased xorg-server
|
||||
{GEExtensionInit, "Generic Event Extension", &noGEExtension},
|
||||
{ShapeExtensionInit, "SHAPE", NULL},
|
||||
#ifdef MITSHM
|
||||
diff -up xorg-server-1.15.99.904/os/WaitFor.c.xserver-1.14-rebased xorg-server-1.15.99.904/os/WaitFor.c
|
||||
--- xorg-server-1.15.99.904/os/WaitFor.c.xserver-1.14-rebased 2014-02-05 03:08:57.000000000 +0000
|
||||
+++ xorg-server-1.15.99.904/os/WaitFor.c 2014-07-15 09:12:30.496991572 +0100
|
||||
diff -up xorg-server-1.16.0/os/WaitFor.c.vnc xorg-server-1.16.0/os/WaitFor.c
|
||||
--- xorg-server-1.16.0/os/WaitFor.c.vnc 2014-02-05 03:08:57.000000000 +0000
|
||||
+++ xorg-server-1.16.0/os/WaitFor.c 2014-09-03 10:21:49.508109234 +0100
|
||||
@@ -125,6 +125,9 @@ static void DoTimer(OsTimerPtr timer, CA
|
||||
static void CheckAllTimers(void);
|
||||
static OsTimerPtr timers = NULL;
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: tigervnc
|
||||
Version: 1.3.1
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
Summary: A TigerVNC remote display system
|
||||
|
||||
%global _hardened_build 1
|
||||
@ -376,6 +376,9 @@ fi
|
||||
%{_datadir}/icons/hicolor/*/apps/*
|
||||
|
||||
%changelog
|
||||
* Wed Sep 3 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-10
|
||||
- Fix build against xorg-x11-server-1.16.0 (bug #1136532).
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user