- mark stack as non-executable in jpeg ASM code
- add xorg-x11-xauth to Requires - add support for X.Org 1.8 - drop shave sources, they are no longer needed
This commit is contained in:
parent
55063072e6
commit
6723d655fb
@ -1,2 +1 @@
|
||||
tigervnc-1.0.90-20091221svn3929.tar.bz2
|
||||
shave-1.tar.bz2
|
||||
|
1
sources
1
sources
@ -1,2 +1 @@
|
||||
012731b0df6b00345401bc33e8f8dfe3 tigervnc-1.0.90-20091221svn3929.tar.bz2
|
||||
4b7761c018efd6dc0e14c82c5bdd36fa shave-1.tar.bz2
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
Name: tigervnc
|
||||
Version: 1.0.90
|
||||
Release: 0.3.%{snap}%{?dist}
|
||||
Release: 0.4.%{snap}%{?dist}
|
||||
Summary: A TigerVNC remote display system
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -12,7 +12,7 @@ URL: http://www.tigervnc.com
|
||||
Source0: %{name}-%{version}-%{snap}.tar.bz2
|
||||
Source1: vncserver.init
|
||||
Source2: vncserver.sysconfig
|
||||
Source3: shave-1.tar.bz2
|
||||
Source4: xserver18.patch
|
||||
Source6: vncviewer.desktop
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -41,6 +41,8 @@ Obsoletes: tightvnc < 1.5.0-0.15.20090204svn3586
|
||||
Patch0: tigervnc-102434.patch
|
||||
Patch4: tigervnc-cookie.patch
|
||||
Patch8: tigervnc-viewer-reparent.patch
|
||||
Patch9: tigervnc11-noexecstack.patch
|
||||
Patch10: tigervnc11-xorg18.patch
|
||||
|
||||
%description
|
||||
Virtual Network Computing (VNC) is a remote display system which
|
||||
@ -64,6 +66,7 @@ Requires(postun):initscripts
|
||||
|
||||
# Check you don't reintroduce #498184 again
|
||||
Requires: xorg-x11-fonts-misc
|
||||
Requires: xorg-x11-xauth
|
||||
|
||||
%description server
|
||||
The VNC system allows you to access the same desktop from a wide
|
||||
@ -93,14 +96,15 @@ pushd unix/xserver
|
||||
for all in `find . -type f -perm -001`; do
|
||||
chmod -x "$all"
|
||||
done
|
||||
patch -p1 -b --suffix .vnc < ../xserver17.patch
|
||||
tar -xjf %{SOURCE3}
|
||||
patch -p1 -b --suffix .vnc < %{SOURCE4}
|
||||
popd
|
||||
|
||||
|
||||
%patch0 -p1 -b .102434
|
||||
%patch4 -p1 -b .cookie
|
||||
%patch8 -p1 -b .viewer-reparent
|
||||
%patch9 -p1 -b .noexecstack
|
||||
%patch10 -p1 -b .xorg18
|
||||
|
||||
# Use newer gettext
|
||||
sed -i 's/AM_GNU_GETTEXT_VERSION.*/AM_GNU_GETTEXT_VERSION([0.17])/' \
|
||||
@ -237,6 +241,12 @@ fi
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jan 22 2010 Adam Tkac <atkac redhat com> 1.0.90-0.4.20091221svn3929
|
||||
- mark stack as non-executable in jpeg ASM code
|
||||
- add xorg-x11-xauth to Requires
|
||||
- add support for X.Org 1.8
|
||||
- drop shave sources, they are no longer needed
|
||||
|
||||
* Thu Jan 21 2010 Adam Tkac <atkac redhat com> 1.0.90-0.3.20091221svn3929
|
||||
- drop tigervnc-xorg25909.patch, it has been merged to X.Org upstream
|
||||
|
||||
|
13
tigervnc11-noexecstack.patch
Normal file
13
tigervnc11-noexecstack.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up tigervnc-1.0.90-20091221svn3929/common/jpeg/simd/jsimdext.inc.noexecstack tigervnc-1.0.90-20091221svn3929/common/jpeg/simd/jsimdext.inc
|
||||
--- tigervnc-1.0.90-20091221svn3929/common/jpeg/simd/jsimdext.inc.noexecstack 2010-01-22 10:52:35.968632745 +0100
|
||||
+++ tigervnc-1.0.90-20091221svn3929/common/jpeg/simd/jsimdext.inc 2010-01-22 10:56:50.877629306 +0100
|
||||
@@ -53,6 +53,9 @@
|
||||
; * *BSD family Unix using elf format
|
||||
; * Unix System V, including Solaris x86, UnixWare and SCO Unix
|
||||
|
||||
+; mark stack as non-executable
|
||||
+section .note.GNU-stack noalloc noexec nowrite progbits
|
||||
+
|
||||
; -- segment definition --
|
||||
;
|
||||
%ifdef __x86_64__
|
15
tigervnc11-xorg18.patch
Normal file
15
tigervnc11-xorg18.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -up tigervnc-1.0.90-20091221svn3929/unix/xserver/hw/vnc/xorg-version.h.xorg-1.8 tigervnc-1.0.90-20091221svn3929/unix/xserver/hw/vnc/xorg-version.h
|
||||
--- tigervnc-1.0.90-20091221svn3929/unix/xserver/hw/vnc/xorg-version.h.xorg-1.8 2010-01-22 11:37:16.017647844 +0100
|
||||
+++ tigervnc-1.0.90-20091221svn3929/unix/xserver/hw/vnc/xorg-version.h 2010-01-22 11:38:06.220640025 +0100
|
||||
@@ -30,8 +30,10 @@
|
||||
#define XORG 16
|
||||
#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (7 * 100000) + (99 * 1000))
|
||||
#define XORG 17
|
||||
+#elif XORG_VERSION_CURRENT < ((1 * 10000000) + (8 * 100000) + (99 * 1000))
|
||||
+#define XORG 18
|
||||
#else
|
||||
-#error "X.Org newer than 1.7 is not supported"
|
||||
+#error "X.Org newer than 1.8 is not supported"
|
||||
#endif
|
||||
|
||||
#endif
|
87
xserver18.patch
Normal file
87
xserver18.patch
Normal file
@ -0,0 +1,87 @@
|
||||
diff -up xserver/configure.ac.vnc xserver/configure.ac
|
||||
--- xserver/configure.ac.vnc 2010-01-22 11:23:04.524629373 +0100
|
||||
+++ xserver/configure.ac 2010-01-22 11:31:04.704638847 +0100
|
||||
@@ -30,7 +30,6 @@ AC_INIT([xorg-server], 1.7.99.3, [https:
|
||||
RELEASE_DATE="(unreleased)"
|
||||
AC_CONFIG_SRCDIR([Makefile.am])
|
||||
AM_INIT_AUTOMAKE([foreign dist-bzip2])
|
||||
-AM_MAINTAINER_MODE
|
||||
|
||||
# Require xorg-macros: XORG_DEFAULT_OPTIONS
|
||||
m4_ifndef([XORG_MACROS_VERSION],
|
||||
@@ -63,6 +62,7 @@ dnl forcing an entire recompile.x
|
||||
AC_CONFIG_HEADERS(include/version-config.h)
|
||||
|
||||
AC_PROG_CC
|
||||
+AC_PROG_CXX
|
||||
AM_PROG_AS
|
||||
AC_PROG_INSTALL
|
||||
AC_PROG_LN_S
|
||||
@@ -1486,6 +1486,10 @@ if test "x$XVFB" = xyes; then
|
||||
AC_SUBST([XVFB_SYS_LIBS])
|
||||
fi
|
||||
|
||||
+dnl Xvnc DDX
|
||||
+AC_SUBST([XVNC_CPPFLAGS], ["-DHAVE_DIX_CONFIG_H $XEXT_INC $FB_INC $MI_INC $RENDER_INC $RANDR_INC"])
|
||||
+AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
|
||||
+AC_SUBST([LIBVNC_LIBS], ["$XI_LIB $DIX_LIB $XKB_LIB"])
|
||||
|
||||
dnl Xnest DDX
|
||||
|
||||
@@ -1524,6 +1528,8 @@ xorg_bus_linuxpci=no
|
||||
xorg_bus_bsdpci=no
|
||||
xorg_bus_sparc=no
|
||||
|
||||
+AC_DEFINE_UNQUOTED(XORG_VERSION_CURRENT, [$VENDOR_RELEASE], [Current Xorg version])
|
||||
+
|
||||
if test "x$XORG" = xyes; then
|
||||
XORG_DDXINCS='-I$(top_srcdir)/hw/xfree86 -I$(top_srcdir)/hw/xfree86/include -I$(top_srcdir)/hw/xfree86/common'
|
||||
XORG_OSINCS='-I$(top_srcdir)/hw/xfree86/os-support -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/os'
|
||||
@@ -1765,7 +1771,6 @@ if test "x$XORG" = xyes; then
|
||||
AC_DEFINE(XORGSERVER, 1, [Building Xorg server])
|
||||
AC_DEFINE(XFree86Server, 1, [Building XFree86 server])
|
||||
AC_DEFINE(XFree86LOADER, 1, [Building loadable XFree86 server])
|
||||
- AC_DEFINE_UNQUOTED(XORG_VERSION_CURRENT, [$VENDOR_RELEASE], [Current Xorg version])
|
||||
AC_DEFINE(NEED_XF86_TYPES, 1, [Need XFree86 typedefs])
|
||||
AC_DEFINE(NEED_XF86_PROTOTYPES, 1, [Need XFree86 helper functions])
|
||||
AC_DEFINE(__XSERVERNAME__, "Xorg", [Name of X server])
|
||||
@@ -2195,6 +2200,7 @@ hw/dmx/input/Makefile
|
||||
hw/dmx/glxProxy/Makefile
|
||||
hw/dmx/Makefile
|
||||
hw/vfb/Makefile
|
||||
+hw/vnc/Makefile
|
||||
hw/xnest/Makefile
|
||||
hw/xwin/Makefile
|
||||
hw/xquartz/Makefile
|
||||
diff -up xserver/hw/Makefile.am.vnc xserver/hw/Makefile.am
|
||||
--- xserver/hw/Makefile.am.vnc 2010-01-22 11:23:04.560613962 +0100
|
||||
+++ xserver/hw/Makefile.am 2010-01-22 11:23:04.600597430 +0100
|
||||
@@ -33,7 +33,8 @@ SUBDIRS = \
|
||||
$(XNEST_SUBDIRS) \
|
||||
$(DMX_SUBDIRS) \
|
||||
$(KDRIVE_SUBDIRS) \
|
||||
- $(XQUARTZ_SUBDIRS)
|
||||
+ $(XQUARTZ_SUBDIRS) \
|
||||
+ vnc
|
||||
|
||||
DIST_SUBDIRS = dmx xfree86 vfb xnest xwin xquartz kdrive
|
||||
|
||||
diff -up xserver/mi/miinitext.c.vnc xserver/mi/miinitext.c
|
||||
--- xserver/mi/miinitext.c.vnc 2010-01-22 11:23:04.564613258 +0100
|
||||
+++ xserver/mi/miinitext.c 2010-01-22 11:23:04.600597430 +0100
|
||||
@@ -274,6 +274,7 @@ extern void DamageExtensionInit(INITARGS
|
||||
extern void CompositeExtensionInit(INITARGS);
|
||||
#endif
|
||||
extern void GEExtensionInit(INITARGS);
|
||||
+extern void vncExtensionInit(INITARGS);
|
||||
|
||||
/* The following is only a small first step towards run-time
|
||||
* configurable extensions.
|
||||
@@ -454,6 +455,7 @@ InitExtensions(int argc, char *argv[])
|
||||
#ifdef XF86BIGFONT
|
||||
if (!noXFree86BigfontExtension) XFree86BigfontExtensionInit();
|
||||
#endif
|
||||
+ vncExtensionInit();
|
||||
#if !defined(NO_HW_ONLY_EXTS)
|
||||
#if defined(XF86VIDMODE)
|
||||
if (!noXFree86VidModeExtension) XFree86VidModeExtensionInit();
|
Loading…
Reference in New Issue
Block a user