Update to 1.1.0
patches merged - tigervnc11-glx.patch - tigervnc11-CVE-2011-1775.patch - 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch Signed-off-by: Adam Tkac <atkac@redhat.com>
This commit is contained in:
parent
9956c17c57
commit
3edf1ea726
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@ tigervnc-1.0.90-20100721svn4113.tar.bz2
|
|||||||
/tigervnc-1.0.90-20101208svn4225.tar.bz2
|
/tigervnc-1.0.90-20101208svn4225.tar.bz2
|
||||||
/tigervnc-1.0.90-20110117svn4237.tar.bz2
|
/tigervnc-1.0.90-20110117svn4237.tar.bz2
|
||||||
/tigervnc-1.0.90.tar.gz
|
/tigervnc-1.0.90.tar.gz
|
||||||
|
/tigervnc-1.1.0.tar.gz
|
||||||
|
@ -1,54 +0,0 @@
|
|||||||
From b08e7198dc0141b8074d8fdff681019d86655a38 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Adam Tkac <atkac@redhat.com>
|
|
||||||
Date: Tue, 12 Apr 2011 16:49:43 +0200
|
|
||||||
Subject: [PATCH] Use memmove instead of memcpy in fbblt.c when memory regions
|
|
||||||
overlap.
|
|
||||||
|
|
||||||
Signed-off-by: Adam Tkac <atkac@redhat.com>
|
|
||||||
---
|
|
||||||
fb/fb.h | 4 ++++
|
|
||||||
fb/fbblt.c | 4 ++--
|
|
||||||
2 files changed, 6 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/fb/fb.h b/fb/fb.h
|
|
||||||
index eaa21ad..f68fe3b 100644
|
|
||||||
--- a/fb/fb.h
|
|
||||||
+++ b/fb/fb.h
|
|
||||||
@@ -66,6 +66,9 @@
|
|
||||||
} \
|
|
||||||
} while(0)
|
|
||||||
|
|
||||||
+/* XXX: Is this enough? */
|
|
||||||
+#define MEMMOVE_WRAPPED MEMCPY_WRAPPED
|
|
||||||
+
|
|
||||||
#else
|
|
||||||
|
|
||||||
#define FBPREFIX(x) fb##x
|
|
||||||
@@ -73,6 +76,7 @@
|
|
||||||
#define READ(ptr) (*(ptr))
|
|
||||||
#define MEMCPY_WRAPPED(dst, src, size) memcpy((dst), (src), (size))
|
|
||||||
#define MEMSET_WRAPPED(dst, val, size) memset((dst), (val), (size))
|
|
||||||
+#define MEMMOVE_WRAPPED(dst, src, size) memmove((dst), (src), (size))
|
|
||||||
|
|
||||||
#endif
|
|
||||||
|
|
||||||
diff --git a/fb/fbblt.c b/fb/fbblt.c
|
|
||||||
index a040298..e16c660 100644
|
|
||||||
--- a/fb/fbblt.c
|
|
||||||
+++ b/fb/fbblt.c
|
|
||||||
@@ -88,10 +88,10 @@ fbBlt (FbBits *srcLine,
|
|
||||||
|
|
||||||
if (!upsidedown)
|
|
||||||
for (i = 0; i < height; i++)
|
|
||||||
- MEMCPY_WRAPPED(dst + i * dstStride, src + i * srcStride, width);
|
|
||||||
+ MEMMOVE_WRAPPED(dst + i * dstStride, src + i * srcStride, width);
|
|
||||||
else
|
|
||||||
for (i = height - 1; i >= 0; i--)
|
|
||||||
- MEMCPY_WRAPPED(dst + i * dstStride, src + i * srcStride, width);
|
|
||||||
+ MEMMOVE_WRAPPED(dst + i * dstStride, src + i * srcStride, width);
|
|
||||||
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
--
|
|
||||||
1.7.4.4
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
90db4d34543e20f053e2ac93745af7e3 tigervnc-1.0.90.tar.gz
|
1a5598b4a2ac530fb51411438959e11e tigervnc-1.1.0.tar.gz
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
Name: tigervnc
|
Name: tigervnc
|
||||||
Version: 1.0.90
|
Version: 1.1.0
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A TigerVNC remote display system
|
Summary: A TigerVNC remote display system
|
||||||
|
|
||||||
Group: User Interface/Desktops
|
Group: User Interface/Desktops
|
||||||
@ -45,10 +45,7 @@ Patch4: tigervnc-cookie.patch
|
|||||||
Patch8: tigervnc-viewer-reparent.patch
|
Patch8: tigervnc-viewer-reparent.patch
|
||||||
Patch10: tigervnc11-ldnow.patch
|
Patch10: tigervnc11-ldnow.patch
|
||||||
Patch11: tigervnc11-gethomedir.patch
|
Patch11: tigervnc11-gethomedir.patch
|
||||||
Patch12: tigervnc11-glx.patch
|
|
||||||
Patch13: tigervnc11-rh692048.patch
|
Patch13: tigervnc11-rh692048.patch
|
||||||
Patch14: 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
|
|
||||||
Patch15: tigervnc11-CVE-2011-1775.patch
|
|
||||||
Patch16: tigervnc11-xorg111.patch
|
Patch16: tigervnc11-xorg111.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -136,7 +133,6 @@ This package contains license of the TigerVNC suite
|
|||||||
%patch8 -p1 -b .viewer-reparent
|
%patch8 -p1 -b .viewer-reparent
|
||||||
%patch10 -p1 -b .ldnow
|
%patch10 -p1 -b .ldnow
|
||||||
%patch11 -p1 -b .gethomedir
|
%patch11 -p1 -b .gethomedir
|
||||||
%patch12 -p1 -b .glx
|
|
||||||
%patch13 -p1 -b .rh692048
|
%patch13 -p1 -b .rh692048
|
||||||
|
|
||||||
cp -r /usr/share/xorg-x11-server-source/* unix/xserver
|
cp -r /usr/share/xorg-x11-server-source/* unix/xserver
|
||||||
@ -145,10 +141,8 @@ for all in `find . -type f -perm -001`; do
|
|||||||
chmod -x "$all"
|
chmod -x "$all"
|
||||||
done
|
done
|
||||||
patch -p1 -b --suffix .vnc < %{SOURCE7}
|
patch -p1 -b --suffix .vnc < %{SOURCE7}
|
||||||
%patch14 -p1 -b .memcpy
|
|
||||||
popd
|
popd
|
||||||
|
|
||||||
%patch15 -p0 -b .CVE-2011-1775
|
|
||||||
%patch16 -p1 -b .xorg111
|
%patch16 -p1 -b .xorg111
|
||||||
|
|
||||||
# Use newer gettext
|
# Use newer gettext
|
||||||
@ -318,6 +312,13 @@ fi
|
|||||||
%doc LICENCE.TXT
|
%doc LICENCE.TXT
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 12 2011 Adam Tkac <atkac redhat com> - 1.1.0-1
|
||||||
|
- update to 1.1.0
|
||||||
|
- patches merged
|
||||||
|
- tigervnc11-glx.patch
|
||||||
|
- tigervnc11-CVE-2011-1775.patch
|
||||||
|
- 0001-Use-memmove-instead-of-memcpy-in-fbblt.c-when-memory.patch
|
||||||
|
|
||||||
* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
|
* Thu Jul 28 2011 Adam Tkac <atkac redhat com> - 1.0.90-6
|
||||||
- add systemd service file and remove legacy SysV initscript (#717227)
|
- add systemd service file and remove legacy SysV initscript (#717227)
|
||||||
|
|
||||||
|
@ -1,22 +0,0 @@
|
|||||||
Index: common/rfb/CSecurityTLS.cxx
|
|
||||||
===================================================================
|
|
||||||
--- common/rfb/CSecurityTLS.cxx (revision 4399)
|
|
||||||
+++ common/rfb/CSecurityTLS.cxx (revision 4400)
|
|
||||||
@@ -171,8 +171,15 @@
|
|
||||||
if (!is->checkNoWait(1))
|
|
||||||
return false;
|
|
||||||
|
|
||||||
- if (is->readU8() == 0)
|
|
||||||
- return true;
|
|
||||||
+ if (is->readU8() == 0) {
|
|
||||||
+ rdr::U32 result = is->readU32();
|
|
||||||
+ CharArray reason;
|
|
||||||
+ if (result == secResultFailed || result == secResultTooMany)
|
|
||||||
+ reason.buf = is->readString();
|
|
||||||
+ else
|
|
||||||
+ reason.buf = strDup("Authentication failure (protocol error)");
|
|
||||||
+ throw AuthFailureException(reason.buf);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
if (gnutls_init(&session, GNUTLS_CLIENT) != GNUTLS_E_SUCCESS)
|
|
||||||
throw AuthFailureException("gnutls_init failed");
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -up tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am.glx tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am
|
|
||||||
--- tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am.glx 2011-03-22 10:32:08.555474741 +0100
|
|
||||||
+++ tigervnc-1.0.90/unix/xserver/hw/vnc/Makefile.am 2011-03-22 10:34:09.331283632 +0100
|
|
||||||
@@ -35,7 +35,7 @@ Xvnc_CPPFLAGS = $(XVNC_CPPFLAGS) -DNO_HW
|
|
||||||
-I$(top_srcdir)/include -I$(includedir)/pixman-1 -I$(includedir)
|
|
||||||
|
|
||||||
Xvnc_LDADD = $(XVNC_LIBS) libvnccommon.la $(COMMON_LIBS) \
|
|
||||||
- $(XSERVER_LIBS) $(XSERVER_SYS_LIBS) -lX11
|
|
||||||
+ $(XSERVER_LIBS) $(XSERVER_SYS_LIBS) $(XVNC_SYS_LIBS) -lX11
|
|
||||||
|
|
||||||
Xvnc_LDFLAGS = $(LD_EXPORT_SYMBOLS_FLAG)
|
|
||||||
|
|
Loading…
Reference in New Issue
Block a user