Enable DRI3 and Present extensions
These extensions were first added in 1.15, so the necessary server libraries were not listed in XVNC_LIBS created by xserver114.patch.
This commit is contained in:
parent
40f8c1568b
commit
2986fbccb2
@ -9,6 +9,15 @@ diff -up tigervnc-1.3.0/unix/xserver/configure.ac.jx tigervnc-1.3.0/unix/xserver
|
|||||||
fi
|
fi
|
||||||
AM_CONDITIONAL(WAYLAND, [test "x$WAYLAND" = xyes])
|
AM_CONDITIONAL(WAYLAND, [test "x$WAYLAND" = xyes])
|
||||||
|
|
||||||
|
@@ -1597,7 +1596,7 @@ fi
|
||||||
|
|
||||||
|
dnl Xvnc DDX
|
||||||
|
AC_SUBST([XVNC_CPPFLAGS], ["-DHAVE_DIX_CONFIG_H $XSERVER_CFLAGS"])
|
||||||
|
-AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
|
||||||
|
+AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $DRI3_LIB $PRESENT_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
|
||||||
|
AC_SUBST([XVNC_SYS_LIBS], ["$GLX_SYS_LIBS"])
|
||||||
|
|
||||||
|
dnl Xnest DDX
|
||||||
diff -up tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h.jx tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h
|
diff -up tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h.jx tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h
|
||||||
--- tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h.jx 2013-07-01 08:41:24.000000000 -0400
|
--- tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h.jx 2013-07-01 08:41:24.000000000 -0400
|
||||||
+++ tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h 2013-11-07 11:39:49.749992669 -0500
|
+++ tigervnc-1.3.0/unix/xserver/hw/vnc/xorg-version.h 2013-11-07 11:39:49.749992669 -0500
|
||||||
|
@ -204,7 +204,6 @@ export CXXFLAGS="$CFLAGS"
|
|||||||
%{cmake} .
|
%{cmake} .
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
# XXX revisit --disable-present
|
|
||||||
pushd unix/xserver
|
pushd unix/xserver
|
||||||
autoreconf -fiv
|
autoreconf -fiv
|
||||||
%configure \
|
%configure \
|
||||||
@ -215,9 +214,8 @@ autoreconf -fiv
|
|||||||
--with-fontdir=%{_datadir}/X11/fonts \
|
--with-fontdir=%{_datadir}/X11/fonts \
|
||||||
--with-xkb-output=%{_localstatedir}/lib/xkb \
|
--with-xkb-output=%{_localstatedir}/lib/xkb \
|
||||||
--enable-install-libxf86config \
|
--enable-install-libxf86config \
|
||||||
--enable-glx --disable-dri --enable-dri2 --disable-dri3 \
|
--enable-glx --disable-dri --enable-dri2 --enable-dri3 \
|
||||||
--disable-wayland \
|
--disable-wayland \
|
||||||
--disable-present \
|
|
||||||
--disable-unit-tests \
|
--disable-unit-tests \
|
||||||
--disable-config-dbus \
|
--disable-config-dbus \
|
||||||
--disable-config-hal \
|
--disable-config-hal \
|
||||||
|
Loading…
Reference in New Issue
Block a user