- update to r4030 snapshot

- patches merged to upstream
- tigervnc11-rh522369.patch
- tigervnc11-rh551262.patch
- tigervnc11-r4002.patch
- tigervnc11-r4014.patch
This commit is contained in:
Adam Tkac 2010-05-13 10:38:02 +00:00
parent d9b8ec5f49
commit 219d234519
7 changed files with 12 additions and 164 deletions

View File

@ -1 +1 @@
tigervnc-1.0.90-20100219svn3993.tar.bz2
tigervnc-1.0.90-20100420svn4030.tar.bz2

View File

@ -1 +1 @@
59c93612e4e8ec18ca19ed8fd31613bf tigervnc-1.0.90-20100219svn3993.tar.bz2
501a3cf6a57eec35a584a7b99cb0a4e2 tigervnc-1.0.90-20100420svn4030.tar.bz2

View File

@ -1,8 +1,8 @@
%define snap 20100219svn3993
%define snap 20100420svn4030
Name: tigervnc
Version: 1.0.90
Release: 0.9.%{snap}%{?dist}
Release: 0.10.%{snap}%{?dist}
Summary: A TigerVNC remote display system
Group: User Interface/Desktops
@ -40,10 +40,6 @@ Obsoletes: tightvnc < 1.5.0-0.15.20090204svn3586
Patch0: tigervnc-102434.patch
Patch4: tigervnc-cookie.patch
Patch8: tigervnc-viewer-reparent.patch
Patch9: tigervnc11-rh522369.patch
Patch10: tigervnc11-rh551262.patch
Patch11: tigervnc11-r4002.patch
Patch12: tigervnc11-r4014.patch
%description
Virtual Network Computing (VNC) is a remote display system which
@ -115,10 +111,6 @@ popd
%patch0 -p1 -b .102434
%patch4 -p1 -b .cookie
%patch8 -p1 -b .viewer-reparent
%patch9 -p0 -b .rh522369
%patch10 -p0 -b .rh551262
%patch11 -p0 -b .r4002
%patch12 -p0 -b .r4014
# Use newer gettext
sed -i 's/AM_GNU_GETTEXT_VERSION.*/AM_GNU_GETTEXT_VERSION([0.17])/' \
@ -273,6 +265,14 @@ fi
%{_datadir}/vnc/classes/*
%changelog
* Thu May 13 2010 Adam Tkac <atkac redhat com> 1.0.90-0.10.20100420svn4030
- update to r4030 snapshot
- patches merged to upstream
- tigervnc11-rh522369.patch
- tigervnc11-rh551262.patch
- tigervnc11-r4002.patch
- tigervnc11-r4014.patch
* Thu Apr 08 2010 Adam Tkac <atkac redhat com> 1.0.90-0.9.20100219svn3993
- add server-applet subpackage which contains Java vncviewer applet
- fix Java applet; it didn't work when run from web browser

View File

@ -1,45 +0,0 @@
Index: java/src/com/tigervnc/vncviewer/MANIFEST.MF
===================================================================
--- java/src/com/tigervnc/vncviewer/MANIFEST.MF (revision 4001)
+++ java/src/com/tigervnc/vncviewer/MANIFEST.MF (revision 4002)
@@ -1,2 +1,2 @@
Manifest-Version: 1.0
-Main-Class: VncViewer
+Main-Class: com.tigervnc.vncviewer.VncViewer
Index: java/src/com/tigervnc/vncviewer/index.html
===================================================================
--- java/src/com/tigervnc/vncviewer/index.html (revision 4001)
+++ java/src/com/tigervnc/vncviewer/index.html (revision 4002)
@@ -20,7 +20,7 @@
<TITLE>
TigerVNC desktop
</TITLE>
-<APPLET CODE="VncViewer.class" ARCHIVE="VncViewer.jar"
+<APPLET CODE="com.tigervnc.vncviewer.VncViewer" ARCHIVE="VncViewer.jar"
WIDTH="800" HEIGHT="632">
<PARAM NAME="PORT" VALUE="5901">
</APPLET>
Index: java/src/com/tigervnc/vncviewer/Makefile
===================================================================
--- java/src/com/tigervnc/vncviewer/Makefile (revision 4001)
+++ java/src/com/tigervnc/vncviewer/Makefile (revision 4002)
@@ -35,7 +35,12 @@
$(JC) $(JCFLAGS) -O $(SOURCES)
$(ARCHIVE): $(CLASSES) $(MANIFEST)
- $(JAR) cfm $(ARCHIVE) $(MANIFEST) $(CLASSES)
+ cd ../../..; \
+ $(JAR) cfm com/tigervnc/vncviewer/$(ARCHIVE) \
+ com/tigervnc/vncviewer/$(MANIFEST) \
+ com/tigervnc/vncviewer/*.class \
+ com/tigervnc/decoder/*.class \
+ com/tigervnc/decoder/common/*.class
install: $(CLASSES) $(ARCHIVE)
$(CP) $(CLASSES) $(ARCHIVE) $(PAGES) $(INSTALL_DIR)
@@ -44,4 +49,4 @@
@$(ExportJavaClasses)
clean::
- $(RM) *.class *.jar
+ $(RM) *.class *.jar ../decoder/*.class ../decoder/common/*.class

View File

@ -1,13 +0,0 @@
Index: java/src/com/tigervnc/vncviewer/index.vnc
===================================================================
--- java/src/com/tigervnc/vncviewer/index.vnc (revision 4013)
+++ java/src/com/tigervnc/vncviewer/index.vnc (revision 4014)
@@ -15,7 +15,7 @@
<TITLE>
$USER's $DESKTOP desktop ($DISPLAY)
</TITLE>
-<APPLET CODE=VncViewer.class ARCHIVE=VncViewer.jar
+<APPLET CODE=com.tigervnc.vncviewer.VncViewer ARCHIVE=VncViewer.jar
WIDTH=$APPLETWIDTH HEIGHT=$APPLETHEIGHT>
<param name=PORT value=$PORT>
$PARAMS

View File

@ -1,80 +0,0 @@
Index: unix/vncviewer/CConn.cxx
===================================================================
--- unix/vncviewer/CConn.cxx (revision 4003)
+++ unix/vncviewer/CConn.cxx (revision 4004)
@@ -33,6 +33,7 @@
#include <rfb/Password.h>
#include <rfb/screenTypes.h>
#include <network/TcpSocket.h>
+#include <cassert>
#include "TXViewport.h"
#include "DesktopWindow.h"
@@ -62,7 +63,7 @@
encodingChange(false), sameMachine(false), fullScreen(::fullScreen),
ctrlDown(false), altDown(false),
menuKeysym(0), menu(dpy, this), options(dpy, this), about(dpy), info(dpy),
- reverseConnection(reverse), firstUpdate(true)
+ reverseConnection(reverse), firstUpdate(true), pendingUpdate(false)
{
CharArray menuKeyStr(menuKey.getData());
menuKeysym = XStringToKeysym(menuKeyStr.buf);
@@ -306,8 +307,11 @@
// one. We cannot do this if we're in the middle of a format change
// though.
void CConn::framebufferUpdateStart() {
- if (!formatChange)
+ if (!formatChange) {
+ pendingUpdate = true;
requestNewUpdate();
+ } else
+ pendingUpdate = false;
}
// framebufferUpdateEnd() is called at the end of an update.
@@ -367,7 +371,7 @@
// A format change prevented us from sending this before the update,
// so make sure to send it now.
- if (formatChange)
+ if (formatChange && !pendingUpdate)
requestNewUpdate();
// Compute new settings based on updated bandwidth values
@@ -536,8 +540,11 @@
break;
case ID_REFRESH:
menu.unmap();
- writer()->writeFramebufferUpdateRequest(Rect(0, 0, cp.width, cp.height),
- false);
+ if (!formatChange) {
+ writer()->writeFramebufferUpdateRequest(Rect(0, 0, cp.width, cp.height),
+ false);
+ pendingUpdate = true;
+ }
break;
case ID_F8:
menu.unmap();
@@ -840,6 +847,10 @@
void CConn::requestNewUpdate()
{
if (formatChange) {
+
+ /* Catch incorrect requestNewUpdate calls */
+ assert(pendingUpdate == false);
+
if (fullColour) {
desktop->setPF(fullColourPF);
} else {
Index: unix/vncviewer/CConn.h
===================================================================
--- unix/vncviewer/CConn.h (revision 4003)
+++ unix/vncviewer/CConn.h (revision 4004)
@@ -132,6 +132,7 @@
InfoDialog info;
bool reverseConnection;
bool firstUpdate;
+ bool pendingUpdate;
};
#endif

View File

@ -1,14 +0,0 @@
Index: unix/tx/TXImage.cxx
===================================================================
--- unix/tx/TXImage.cxx (revision 4002)
+++ unix/tx/TXImage.cxx (revision 4003)
@@ -164,7 +164,8 @@
void TXImage::updateColourMap()
{
- tig->setColourMapEntries(0, 0, 0);
+ if (tig != 0)
+ tig->setColourMapEntries(0, 0, 0);
}
void TXImage::lookup(int index, int* r, int* g, int* b)