Fixed viewer crash when cursor has not been set (bug #1038701).
Resolves: rhbz#1038701
(cherry picked from commit 8ef823f6ee
)
Conflicts:
tigervnc.spec
This commit is contained in:
parent
e304238de7
commit
205a287f62
12
tigervnc-cursor.patch
Normal file
12
tigervnc-cursor.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up tigervnc-1.3.0/vncviewer/Viewport.cxx.cursor tigervnc-1.3.0/vncviewer/Viewport.cxx
|
||||
--- tigervnc-1.3.0/vncviewer/Viewport.cxx.cursor 2013-12-17 13:28:23.170400013 +0000
|
||||
+++ tigervnc-1.3.0/vncviewer/Viewport.cxx 2013-12-17 13:29:46.095784064 +0000
|
||||
@@ -931,7 +931,7 @@ void Viewport::popupContextMenu()
|
||||
|
||||
// Back to our proper mouse pointer.
|
||||
#ifdef HAVE_FLTK_CURSOR
|
||||
- if (Fl::belowmouse() == this)
|
||||
+ if (Fl::belowmouse() == this && cursor)
|
||||
window()->cursor(cursor, cursorHotspot.x, cursorHotspot.y);
|
||||
#endif
|
||||
|
@ -47,6 +47,7 @@ Patch7: tigervnc-manpages.patch
|
||||
Patch8: tigervnc-getmaster.patch
|
||||
Patch9: tigervnc-shebang.patch
|
||||
Patch12: tigervnc-zrle-crash.patch
|
||||
Patch13: tigervnc-cursor.patch
|
||||
|
||||
%description
|
||||
Virtual Network Computing (VNC) is a remote display system which
|
||||
@ -172,6 +173,9 @@ popd
|
||||
# Avoid invalid read when ZRLE connection closed (upstream bug #133).
|
||||
%patch12 -p1 -b .zrle-crash
|
||||
|
||||
# Fixed viewer crash when cursor has not been set (bug #1038701).
|
||||
%patch13 -p1 -b .cursor
|
||||
|
||||
%build
|
||||
%ifarch sparcv9 sparc64 s390 s390x
|
||||
export CFLAGS="$RPM_OPT_FLAGS -fPIC"
|
||||
@ -341,6 +345,7 @@ fi
|
||||
|
||||
%changelog
|
||||
* Thu Dec 12 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-8
|
||||
- Fixed viewer crash when cursor has not been set (bug #1038701).
|
||||
- Avoid invalid read when ZRLE connection closed (upstream bug #133).
|
||||
|
||||
* Tue Sep 24 2013 Tim Waugh <twaugh@redhat.com> 1.3.0-7
|
||||
|
Loading…
Reference in New Issue
Block a user