Build fixes.
- No longer need ppc64le patch as it's now in xorg-x11-server. - Rebased xserver114.patch again.
This commit is contained in:
parent
ceedd41a4b
commit
16645cca41
@ -1,32 +0,0 @@
|
||||
From cf3b41ab32a894c19de50a2759a38c90cc2c8351 Mon Sep 17 00:00:00 2001
|
||||
From: Gustavo Luiz Duarte <gustavold@linux.vnet.ibm.com>
|
||||
Date: Wed, 19 Mar 2014 13:51:18 -0500
|
||||
Subject: [PATCH] Add support for ppc64le architecture.
|
||||
|
||||
---
|
||||
unix/xserver/include/servermd.h | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/unix/xserver/include/servermd.h b/unix/xserver/include/servermd.h
|
||||
index 11f6c10..17951da 100644
|
||||
--- a/unix/xserver/include/servermd.h
|
||||
+++ b/unix/xserver/include/servermd.h
|
||||
@@ -114,9 +114,15 @@ SOFTWARE.
|
||||
|
||||
#if defined(__powerpc__) || defined(__ppc__) || defined(__ppc64__)
|
||||
|
||||
+#if defined(__BIG_ENDIAN__)
|
||||
#define IMAGE_BYTE_ORDER MSBFirst
|
||||
#define BITMAP_BIT_ORDER MSBFirst
|
||||
#define GLYPHPADBYTES 4
|
||||
+#else
|
||||
+#define IMAGE_BYTE_ORDER LSBFirst
|
||||
+#define BITMAP_BIT_ORDER LSBFirst
|
||||
+#define GLYPHPADBYTES 4
|
||||
+#endif
|
||||
|
||||
#endif /* PowerPC */
|
||||
|
||||
--
|
||||
1.9.0
|
||||
|
@ -1,28 +1,15 @@
|
||||
From 28f093e6987bd7eb631714933ae3cf1ede250380 Mon Sep 17 00:00:00 2001
|
||||
From: Hans de Goede <hdegoede@redhat.com>
|
||||
Date: Mon, 28 Apr 2014 15:54:54 +0200
|
||||
Subject: [PATCH] tigervnc xserver 1.14 patch
|
||||
|
||||
---
|
||||
configure.ac | 9 ++++++++-
|
||||
hw/Makefile.am | 3 ++-
|
||||
mi/miinitext.c | 7 +++++++
|
||||
os/WaitFor.c | 19 ++++++++++++++++++-
|
||||
4 files changed, 35 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 0c8b516..722dbc3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -74,6 +74,7 @@ dnl forcing an entire recompile.x
|
||||
AC_CONFIG_HEADERS(include/version-config.h)
|
||||
diff -up xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased xorg-server-1.15.99.904/configure.ac
|
||||
--- xorg-server-1.15.99.904/configure.ac.xserver-1.14-rebased 2014-07-15 09:08:45.084879742 +0100
|
||||
+++ xorg-server-1.15.99.904/configure.ac 2014-07-15 09:09:25.421078698 +0100
|
||||
@@ -76,6 +76,7 @@ dnl os-strfeatures.h covers HAVE_STRFOO
|
||||
AC_CONFIG_HEADERS(include/os-strfeatures.h)
|
||||
|
||||
AM_PROG_AS
|
||||
+AC_PROG_CXX
|
||||
AC_PROG_LN_S
|
||||
LT_PREREQ([2.2])
|
||||
LT_INIT([disable-static win32-dll])
|
||||
@@ -1794,6 +1795,10 @@ if test "x$XVFB" = xyes; then
|
||||
@@ -1797,6 +1798,10 @@ if test "x$XVFB" = xyes; then
|
||||
AC_SUBST([XVFB_SYS_LIBS])
|
||||
fi
|
||||
|
||||
@ -33,7 +20,7 @@ index 0c8b516..722dbc3 100644
|
||||
|
||||
dnl Xnest DDX
|
||||
|
||||
@@ -1829,6 +1834,8 @@ if test "x$XORG" = xauto; then
|
||||
@@ -1832,6 +1837,8 @@ if test "x$XORG" = xauto; then
|
||||
fi
|
||||
AC_MSG_RESULT([$XORG])
|
||||
|
||||
@ -42,7 +29,7 @@ index 0c8b516..722dbc3 100644
|
||||
if test "x$XORG" = xyes; then
|
||||
XORG_DDXINCS='-I$(top_srcdir)/hw/xfree86 -I$(top_srcdir)/hw/xfree86/include -I$(top_srcdir)/hw/xfree86/common'
|
||||
XORG_OSINCS='-I$(top_srcdir)/hw/xfree86/os-support -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/os'
|
||||
@@ -2050,7 +2057,6 @@ if test "x$XORG" = xyes; then
|
||||
@@ -2053,7 +2060,6 @@ if test "x$XORG" = xyes; then
|
||||
AC_DEFINE(XORG_SERVER, 1, [Building Xorg server])
|
||||
AC_DEFINE(XORGSERVER, 1, [Building Xorg server])
|
||||
AC_DEFINE(XFree86Server, 1, [Building XFree86 server])
|
||||
@ -50,7 +37,7 @@ index 0c8b516..722dbc3 100644
|
||||
AC_DEFINE(NEED_XF86_TYPES, 1, [Need XFree86 typedefs])
|
||||
AC_DEFINE(NEED_XF86_PROTOTYPES, 1, [Need XFree86 helper functions])
|
||||
AC_DEFINE(__XSERVERNAME__, "Xorg", [Name of X server])
|
||||
@@ -2584,6 +2590,7 @@ hw/dmx/Makefile
|
||||
@@ -2591,6 +2597,7 @@ hw/dmx/Makefile
|
||||
hw/dmx/man/Makefile
|
||||
hw/vfb/Makefile
|
||||
hw/vfb/man/Makefile
|
||||
@ -58,10 +45,9 @@ index 0c8b516..722dbc3 100644
|
||||
hw/xnest/Makefile
|
||||
hw/xnest/man/Makefile
|
||||
hw/xwin/Makefile
|
||||
diff --git a/hw/Makefile.am b/hw/Makefile.am
|
||||
index 19895dc..b42fa6e 100644
|
||||
--- a/hw/Makefile.am
|
||||
+++ b/hw/Makefile.am
|
||||
diff -up xorg-server-1.15.99.904/hw/Makefile.am.xserver-1.14-rebased xorg-server-1.15.99.904/hw/Makefile.am
|
||||
--- xorg-server-1.15.99.904/hw/Makefile.am.xserver-1.14-rebased 2014-07-15 09:09:25.422078703 +0100
|
||||
+++ xorg-server-1.15.99.904/hw/Makefile.am 2014-07-15 09:10:09.560296411 +0100
|
||||
@@ -38,7 +38,8 @@ SUBDIRS = \
|
||||
$(DMX_SUBDIRS) \
|
||||
$(KDRIVE_SUBDIRS) \
|
||||
@ -72,10 +58,9 @@ index 19895dc..b42fa6e 100644
|
||||
|
||||
DIST_SUBDIRS = dmx xfree86 vfb xnest xwin xquartz kdrive xwayland
|
||||
|
||||
diff --git a/mi/miinitext.c b/mi/miinitext.c
|
||||
index 1d90516..ace7dbf 100644
|
||||
--- a/mi/miinitext.c
|
||||
+++ b/mi/miinitext.c
|
||||
diff -up xorg-server-1.15.99.904/mi/miinitext.c.xserver-1.14-rebased xorg-server-1.15.99.904/mi/miinitext.c
|
||||
--- xorg-server-1.15.99.904/mi/miinitext.c.xserver-1.14-rebased 2014-04-16 21:24:00.000000000 +0100
|
||||
+++ xorg-server-1.15.99.904/mi/miinitext.c 2014-07-15 09:11:42.968757142 +0100
|
||||
@@ -111,6 +111,10 @@ SOFTWARE.
|
||||
#include "micmap.h"
|
||||
#include "globals.h"
|
||||
@ -87,7 +72,7 @@ index 1d90516..ace7dbf 100644
|
||||
/* The following is only a small first step towards run-time
|
||||
* configurable extensions.
|
||||
*/
|
||||
@@ -235,6 +239,9 @@ EnableDisableExtensionError(const char *name, Bool enable)
|
||||
@@ -235,6 +239,9 @@ EnableDisableExtensionError(const char *
|
||||
|
||||
/* List of built-in (statically linked) extensions */
|
||||
static const ExtensionModule staticExtensions[] = {
|
||||
@ -97,11 +82,10 @@ index 1d90516..ace7dbf 100644
|
||||
{GEExtensionInit, "Generic Event Extension", &noGEExtension},
|
||||
{ShapeExtensionInit, "SHAPE", NULL},
|
||||
#ifdef MITSHM
|
||||
diff --git a/os/WaitFor.c b/os/WaitFor.c
|
||||
index 3eb15b9..9235f20 100644
|
||||
--- a/os/WaitFor.c
|
||||
+++ b/os/WaitFor.c
|
||||
@@ -125,6 +125,9 @@ static void DoTimer(OsTimerPtr timer, CARD32 now, OsTimerPtr *prev);
|
||||
diff -up xorg-server-1.15.99.904/os/WaitFor.c.xserver-1.14-rebased xorg-server-1.15.99.904/os/WaitFor.c
|
||||
--- xorg-server-1.15.99.904/os/WaitFor.c.xserver-1.14-rebased 2014-02-05 03:08:57.000000000 +0000
|
||||
+++ xorg-server-1.15.99.904/os/WaitFor.c 2014-07-15 09:12:30.496991572 +0100
|
||||
@@ -125,6 +125,9 @@ static void DoTimer(OsTimerPtr timer, CA
|
||||
static void CheckAllTimers(void);
|
||||
static OsTimerPtr timers = NULL;
|
||||
|
||||
@ -129,28 +113,3 @@ index 3eb15b9..9235f20 100644
|
||||
BlockHandler((void *) &wt, (void *) &LastSelectMask);
|
||||
if (NewOutputPending)
|
||||
FlushAllOutput();
|
||||
@@ -223,10 +230,20 @@ WaitForSomething(int *pClientsReady)
|
||||
i = Select(MaxClients, &LastSelectMask, &clientsWritable, NULL, wt);
|
||||
}
|
||||
else {
|
||||
- i = Select(MaxClients, &LastSelectMask, NULL, NULL, wt);
|
||||
+ if (AnyClientsWriteBlocked)
|
||||
+ XFD_ORSET(&socketsWritable, &ClientsWriteBlocked, &socketsWritable);
|
||||
+
|
||||
+ if (XFD_ANYSET(&socketsWritable)) {
|
||||
+ i = Select (MaxClients, &LastSelectMask, &socketsWritable, NULL, wt);
|
||||
+ if (AnyClientsWriteBlocked)
|
||||
+ XFD_ANDSET(&clientsWritable, &socketsWritable, &ClientsWriteBlocked);
|
||||
+ } else {
|
||||
+ i = Select (MaxClients, &LastSelectMask, NULL, NULL, wt);
|
||||
+ }
|
||||
}
|
||||
selecterr = GetErrno();
|
||||
WakeupHandler(i, (void *) &LastSelectMask);
|
||||
+ vncWriteWakeupHandler(i, &socketsWritable);
|
||||
if (i <= 0) { /* An error or timeout occurred */
|
||||
if (dispatchException)
|
||||
return 0;
|
||||
--
|
||||
1.9.0
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: tigervnc
|
||||
Version: 1.3.1
|
||||
Release: 7%{?dist}
|
||||
Release: 8%{?dist}
|
||||
Summary: A TigerVNC remote display system
|
||||
|
||||
%global _hardened_build 1
|
||||
@ -56,12 +56,11 @@ Patch11: tigervnc-format-security.patch
|
||||
Patch12: tigervnc-zrle-crash.patch
|
||||
Patch13: tigervnc-cursor.patch
|
||||
Patch14: tigervnc-xstartup.patch
|
||||
Patch15: tigervnc-ppc64le.patch
|
||||
Patch16: tigervnc-1.3.1-xserver-1.16.patch
|
||||
Patch17: tigervnc-pointersync.patch
|
||||
Patch15: tigervnc-1.3.1-xserver-1.16.patch
|
||||
Patch16: tigervnc-pointersync.patch
|
||||
|
||||
# This is tigervnc-%{version}/unix/xserver114.patch rebased on the latest xorg
|
||||
Patch100: 0001-tigervnc-xserver-1.14-patch.patch
|
||||
Patch100: tigervnc-xserver-1.14-rebased.patch
|
||||
|
||||
%description
|
||||
Virtual Network Computing (VNC) is a remote display system which
|
||||
@ -198,13 +197,10 @@ popd
|
||||
# Clearer xstartup file (bug #923655).
|
||||
%patch14 -p1 -b .xstartup
|
||||
|
||||
# Add ppc64le support (bug #1078495).
|
||||
%patch15 -p1 -b .ppc64le
|
||||
|
||||
%patch16 -p1 -b .116
|
||||
%patch15 -p1 -b .116
|
||||
|
||||
# Keep pointer in sync when using module (upstream bug #152).
|
||||
%patch17 -p1 -b .pointersync
|
||||
%patch16 -p1 -b .pointersync
|
||||
|
||||
%build
|
||||
%ifarch sparcv9 sparc64 s390 s390x
|
||||
@ -376,6 +372,10 @@ fi
|
||||
%{_datadir}/icons/hicolor/*/apps/*
|
||||
|
||||
%changelog
|
||||
* Tue Jul 15 2014 Tim Waugh <twaugh@redhat.com> - 1.3.1-8
|
||||
- No longer need ppc64le patch as it's now in xorg-x11-server.
|
||||
- Rebased xserver114.patch again.
|
||||
|
||||
* Fri Jun 20 2014 Hans de Goede <hdegoede@redhat.com> - 1.3.1-7
|
||||
- xserver 1.15.99.903 ABI rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user