diff --git a/.gitignore b/.gitignore
index c6ab7c5..eb723f7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,5 @@
SOURCES/cbindgen-vendor.tar.xz
SOURCES/nspr-4.34.0-3.el8_1.src.rpm
SOURCES/nss-3.79.0-11.el8_1.src.rpm
-SOURCES/thunderbird-102.11.0.processed-source.tar.xz
-SOURCES/thunderbird-langpacks-102.11.0-20230504.tar.xz
-SOURCES/thunderbird-symbolic.svg
+SOURCES/thunderbird-102.13.0.b2.processed-source.tar.xz
+SOURCES/thunderbird-langpacks-102.13.0-20230707.tar.xz
diff --git a/.thunderbird.metadata b/.thunderbird.metadata
index 053d4fe..338a925 100644
--- a/.thunderbird.metadata
+++ b/.thunderbird.metadata
@@ -1,6 +1,5 @@
2a430d6252dbea45482ba316a6e9fa605c15e747 SOURCES/cbindgen-vendor.tar.xz
af58b3c87a8b5491dde63b07efaeb3d7f1ec56c1 SOURCES/nspr-4.34.0-3.el8_1.src.rpm
a9dd43799ab2ccbc248cfbba1cc5639c1ab18769 SOURCES/nss-3.79.0-11.el8_1.src.rpm
-7ffefde4550bd8ad0557ec011e9bd921d145ae3d SOURCES/thunderbird-102.11.0.processed-source.tar.xz
-c030353a3e2d3e1d060d44b7e316c89672742ee6 SOURCES/thunderbird-langpacks-102.11.0-20230504.tar.xz
-42e80b86948cdba0f69af5b15a69bc6a1274d938 SOURCES/thunderbird-symbolic.svg
+7d2ee2fbb3f527e7062e32a1f13b06177c8a3cf3 SOURCES/thunderbird-102.13.0.b2.processed-source.tar.xz
+cdf9e5ddff298c2b5690456a66c3868a44a382b3 SOURCES/thunderbird-langpacks-102.13.0-20230707.tar.xz
diff --git a/SOURCES/thunderbird-mozconfig b/SOURCES/thunderbird-mozconfig
index 7445114..c8e9d53 100644
--- a/SOURCES/thunderbird-mozconfig
+++ b/SOURCES/thunderbird-mozconfig
@@ -17,6 +17,7 @@ ac_add_options --with-system-jpeg
ac_add_options --enable-js-shell
ac_add_options --with-unsigned-addon-scopes=app,system
ac_add_options --without-sysroot
+ac_add_options --update-channel=release
# investigate this one:
ac_add_options --without-wasm-sandboxed-libraries
ac_add_options --with-mozilla-api-keyfile=../mozilla-api-key
diff --git a/SOURCES/thunderbird-symbolic.svg b/SOURCES/thunderbird-symbolic.svg
new file mode 100644
index 0000000..9387527
--- /dev/null
+++ b/SOURCES/thunderbird-symbolic.svg
@@ -0,0 +1,76 @@
+
+
+
+
diff --git a/SPECS/thunderbird.spec b/SPECS/thunderbird.spec
index d8b6040..c36532a 100644
--- a/SPECS/thunderbird.spec
+++ b/SPECS/thunderbird.spec
@@ -8,7 +8,7 @@
%endif
%{lua:
-function dist_to_rhel_minor(str, start)
+function dist_to_rhel8_minor(str, start)
match = string.match(str, ".module%+el8.%d+")
if match then
return string.sub(match, 13)
@@ -24,7 +24,25 @@ function dist_to_rhel_minor(str, start)
return -1
end}
-%global rhel_minor_version %{lua:print(dist_to_rhel_minor(rpm.expand("%dist")))}
+%{lua:
+function dist_to_rhel9_minor(str, start)
+ match = string.match(str, ".module%+el9.%d+")
+ if match then
+ return string.sub(match, 13)
+ end
+ match = string.match(str, ".el9_%d+")
+ if match then
+ return string.sub(match, 6)
+ end
+ match = string.match(str, ".el9")
+ if match then
+ return 3
+ end
+ return -1
+end}
+
+%global rhel8_minor_version %{lua:print(dist_to_rhel8_minor(rpm.expand("%dist")))}
+%global rhel9_minor_version %{lua:print(dist_to_rhel9_minor(rpm.expand("%dist")))}
# Produce debug (non-optimized) package build. Suitable for debugging only
# as the build is *very* slow.
@@ -37,12 +55,12 @@ end}
# librnp with openssl support, not available in RHEL7 because it requires openssl >= 1.1.1e,
# nor in rhel-8.1.0 or rhel-8.2.0
%global use_openssl_for_librnp 1
-%if 0%{?rhel} == 7 || (0%{?rhel} == 8 && %{rhel_minor_version} < 4)
+%if 0%{?rhel} == 7 || (0%{?rhel} == 8 && %{rhel8_minor_version} < 4)
%global use_openssl_for_librnp 0
%endif
%if 0%{?rhel} == 8
- %if %{rhel_minor_version} <= 4
+ %if %{rhel8_minor_version} <= 4
%global bundle_nss 1
%global system_nss 1
%endif
@@ -165,8 +183,8 @@ end}
Summary: Mozilla Thunderbird mail/newsgroup client
Name: thunderbird
-Version: 102.11.0
-Release: 1%{?dist}.alma.plus
+Version: 102.13.0
+Release: 2%{?dist}.alma.alma.plus
URL: http://www.mozilla.org/projects/thunderbird/
License: MPLv1.1 or GPLv2+ or LGPLv2+
@@ -174,13 +192,13 @@ License: MPLv1.1 or GPLv2+ or LGPLv2+
# If set to .b2 or .b3 ... the processed source file needs to be renamed before upload, e.g.
# thunderbird-102.8.0.b2.processed-source.tar.xz
# When unset use processed source file name as is.
-#%%global buildnum .b2
+%global buildnum .b2
%if 0%{?rhel} == 9
ExcludeArch: %{ix86}
%endif
%if 0%{?rhel} == 8
- %if %{rhel_minor_version} == 1
+ %if %{rhel8_minor_version} == 1
ExcludeArch: %{ix86} aarch64 s390x
%else
ExcludeArch: %{ix86}
@@ -193,7 +211,7 @@ ExcludeArch: aarch64 s390 ppc
#Source0: https://archive.mozilla.org/pub/thunderbird/releases/%{version}%{?pre_version}/source/thunderbird-%{version}%{?pre_version}.processed-source.tar.xz
Source0: thunderbird-%{version}%{?pre_version}%{?buildnum}.processed-source.tar.xz
%if %{build_langpacks}
-Source1: thunderbird-langpacks-%{version}-20230504.tar.xz
+Source1: thunderbird-langpacks-%{version}-20230707.tar.xz
%endif
Source2: cbindgen-vendor.tar.xz
Source3: process-official-tarball
@@ -458,7 +476,7 @@ BuildRequires: pciutils-libs
Obsoletes: mozilla <= 37:1.7.13
Provides: webclient
-%if 0%{?rhel} == 8 && %{rhel_minor_version} < 6
+%if 0%{?rhel} == 8 && %{rhel8_minor_version} < 6
%ifarch aarch64
BuildRequires: gcc-toolset-12-annobin-plugin-gcc
%endif
@@ -560,7 +578,8 @@ based on RNP.
%prep
echo "Build environment"
echo "dist %{?dist}"
-echo "RHEL 8 minor version: %{?rhel_minor_version}"
+echo "RHEL 8 minor version: %{?rhel8_minor_version}"
+echo "RHEL 9 minor version: %{?rhel9_minor_version}"
echo "use_bundled_ffi %{?use_bundled_ffi}"
echo "bundle_nss %{?bundle_nss}"
echo "system_nss %{?system_nss}"
@@ -591,7 +610,8 @@ echo "use_rustts %{?use_rustts}"
%patch77 -p1 -b .mozilla-1775202
%patch73 -p1 -b .build-ascii-decode-fail-rhel7
-%if 0%{?rhel} == 7
+%if 0%{?rhel} == 7 || (0%{?rhel} == 8 && %{rhel8_minor_version} >= 9)
+# Also c8s/rhel-8.9.0 has only node 10.24.0, this is build-only.
%patch78 -p1 -b .build-rhel7-lower-node-min-version
%endif
@@ -729,7 +749,7 @@ echo "ac_add_options --with-librnp-backend=openssl" >> .mozconfig
%endif
# AV1 requires newer nasm that was rebased in 8.4
-%if 0%{?rhel} == 7 || (0%{?rhel} == 8 && %{rhel_minor_version} < 4)
+%if 0%{?rhel} == 7 || (0%{?rhel} == 8 && %{rhel8_minor_version} < 4)
echo "ac_add_options --disable-av1" >> .mozconfig
%endif
@@ -821,7 +841,7 @@ function install_rpms_to_current_dir() {
%endif
set +e
-%if 0%{?rhel} == 8 && %{rhel_minor_version} < 6
+%if 0%{?rhel} == 8 && %{rhel8_minor_version} < 6
%ifarch aarch64
source scl_source enable gcc-toolset-12
%endif
@@ -1255,11 +1275,19 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#===============================================================================
%changelog
-* Thu May 18 2023 Eduard Abdullin - 102.11.0-1.alma.plus
+* Fri Jul 14 2023 Eduard Abdullin - 102.13.0-2.alma.alma.plus
- Enable openpgp
-* Thu May 18 2023 Eduard Abdullin - 102.11.0-1.alma
+* Fri Jul 14 2023 Eduard Abdullin - 102.13.0-2.alma
- Debrand for AlmaLinux
+* Fri Jul 07 2023 Eike Rathke - 102.13.0-2
+- Update to 102.13.0 build2
+* Wed Jul 05 2023 Eike Rathke - 102.13.0-1
+- Update to 102.13.0 build1
+
+* Mon Jun 05 2023 Eike Rathke - 102.12.0-1
+- Update to 102.12.0 build1
+
* Thu May 04 2023 Eike Rathke - 102.11.0-1
- Update to 102.11.0 build1
* Tue Apr 11 2023 Eike Rathke - 102.10.0-2