5edf9f427d
Add several fixes from upstream
38 lines
1.2 KiB
Diff
38 lines
1.2 KiB
Diff
From 90169f80a70efd4d5b6101e87666cd355dbd786f Mon Sep 17 00:00:00 2001
|
|
From: Srinivas Pandruvada <srinivas.pandruvada@linux.intel.com>
|
|
Date: Fri, 2 Jun 2017 08:04:57 -0700
|
|
Subject: [PATCH] Removed compile flags
|
|
|
|
Removed -fpermissive and -fopenmp.
|
|
---
|
|
Android.mk | 2 +-
|
|
Makefile.am | 2 --
|
|
2 files changed, 1 insertion(+), 3 deletions(-)
|
|
|
|
diff --git a/Android.mk b/Android.mk
|
|
index 092053d..8ef9cf3 100644
|
|
--- a/Android.mk
|
|
+++ b/Android.mk
|
|
@@ -43,7 +43,7 @@ LOCAL_C_INCLUDES += $(LOCAL_PATH) $(thermald_src_path) \
|
|
system/core/include/
|
|
|
|
LOCAL_MODULE_TAGS := optional
|
|
-LOCAL_CFLAGS := -fpermissive -DTDRUNDIR='"/data/thermal-daemon"' -DTDCONFDIR='"/system/etc/thermal-daemon"'
|
|
+LOCAL_CFLAGS := -DTDRUNDIR='"/data/thermal-daemon"' -DTDCONFDIR='"/system/etc/thermal-daemon"'
|
|
LOCAL_STATIC_LIBRARIES := libxml2
|
|
LOCAL_SHARED_LIBRARIES := liblog libcutils libdl libc++ libicuuc libicui18n libbinder libutils
|
|
LOCAL_PRELINK_MODULE := false
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index 1ac26ed..ee96893 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -11,8 +11,6 @@ AM_CXXFLAGS = ${DBUS_CFLAGS}\
|
|
-DTDRUNDIR=\"$(tdrundir)\" \
|
|
-DTDCONFDIR=\"$(tdconfdir)\" \
|
|
-I src \
|
|
- -fpermissive \
|
|
- -fopenmp \
|
|
-Wreorder \
|
|
-Wsign-compare \
|
|
-Wreturn-type \
|