Update to texinfo-7.1
Signed-off-by: Vitezslav Crhonek <vcrhonek@redhat.com>
This commit is contained in:
parent
498fe42b82
commit
56707e49b6
4
.gitignore
vendored
4
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
/texinfo-7.0.3.tar.xz
|
||||
/texinfo-7.0.3.tar.xz.sig
|
||||
/texinfo-7.1.tar.xz
|
||||
/texinfo-7.1.tar.xz.sig
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (texinfo-7.0.3.tar.xz) = 7d14f7458f2b7d0ee0b740e00a5fc2a9d61d33811aa5905d649875ec518dcb4f01be46fb0c46748f7dfe36950597a852f1473ab0648d5add225bc8f35528a8ff
|
||||
SHA512 (texinfo-7.0.3.tar.xz.sig) = 7d8d674d6903e146a19a99b5ee178fdc2cb6c93931f31439a3fe650c664cf308841937243b18b81f463b6fb264fdaf8134fdc81e023da46919bf93ae58ed5550
|
||||
SHA512 (texinfo-7.1.tar.xz) = ceab03e8422d800b08c7b44e8263b0a1f35bb7758d83a81136df6f3304a14daecda98a12a282afb85406d2ca2f665b2295e10b6f4064156ea1285d80d5d355db
|
||||
SHA512 (texinfo-7.1.tar.xz.sig) = 2e2f19a783e57f425afa11871e5cdaceacb79a7bc7389eaf2c3b0e0aba0b08e8afdbdf9e939e75c773f262eb22c351b0fc745604eac76d58f484196733da5130
|
||||
|
@ -1,44 +0,0 @@
|
||||
diff -up texinfo-6.1/install-info/install-info.c.orig texinfo-6.1/install-info/install-info.c
|
||||
--- texinfo-6.1/install-info/install-info.c.orig 2016-06-22 09:49:38.766013018 +0200
|
||||
+++ texinfo-6.1/install-info/install-info.c 2016-06-22 14:11:58.673780736 +0200
|
||||
@@ -973,18 +973,23 @@ output_dirfile (char *dirfile, int dir_n
|
||||
int n_entries_added = 0;
|
||||
int i;
|
||||
FILE *output;
|
||||
+ char *dirfile_tmp = NULL;
|
||||
+
|
||||
+ asprintf (&dirfile_tmp, "%s.tmp", dirfile);
|
||||
+ if (!dirfile_tmp)
|
||||
+ xalloc_die ();
|
||||
|
||||
if (compression_program)
|
||||
{
|
||||
- char *command = concat (compression_program, ">", dirfile);
|
||||
+ char *command = concat (compression_program, ">", dirfile_tmp);
|
||||
output = popen (command, "w");
|
||||
}
|
||||
else
|
||||
- output = fopen (dirfile, "w");
|
||||
+ output = fopen (dirfile_tmp, "w");
|
||||
|
||||
if (!output)
|
||||
{
|
||||
- perror (dirfile);
|
||||
+ perror (dirfile_tmp);
|
||||
exit (EXIT_FAILURE);
|
||||
}
|
||||
|
||||
@@ -1095,6 +1100,13 @@ output_dirfile (char *dirfile, int dir_n
|
||||
pclose (output);
|
||||
else
|
||||
fclose (output);
|
||||
+
|
||||
+ if (rename (dirfile_tmp, dirfile) < 0)
|
||||
+ {
|
||||
+ perror (dirfile_tmp);
|
||||
+ exit (EXIT_FAILURE);
|
||||
+ }
|
||||
+ free (dirfile_tmp);
|
||||
}
|
||||
|
||||
/* Read through the input LINES, to find the section names and the
|
@ -1,7 +1,7 @@
|
||||
diff -up texinfo-6.7.90/info/infomap.c.orig texinfo-6.7.90/info/infomap.c
|
||||
--- texinfo-6.7.90/info/infomap.c.orig 2019-12-01 12:26:46.000000000 +0100
|
||||
+++ texinfo-6.7.90/info/infomap.c 2021-02-24 12:56:06.865568572 +0100
|
||||
@@ -589,6 +589,7 @@ fetch_user_maps (char *init_file)
|
||||
diff -up texinfo-7.0.92/info/infomap.c.orig texinfo-7.0.92/info/infomap.c
|
||||
--- texinfo-7.0.92/info/infomap.c.orig 2023-09-14 13:19:30.417330487 +0200
|
||||
+++ texinfo-7.0.92/info/infomap.c 2023-09-14 13:19:55.870353408 +0200
|
||||
@@ -590,6 +590,7 @@ fetch_user_maps (char *init_file)
|
||||
compile (inf, filename, &sup_info, &sup_ea);
|
||||
|
||||
free (filename);
|
||||
@ -9,9 +9,9 @@ diff -up texinfo-6.7.90/info/infomap.c.orig texinfo-6.7.90/info/infomap.c
|
||||
return 1;
|
||||
}
|
||||
|
||||
diff -up texinfo-6.7.90/info/variables.c.orig texinfo-6.7.90/info/variables.c
|
||||
--- texinfo-6.7.90/info/variables.c.orig 2021-02-24 13:00:21.056060523 +0100
|
||||
+++ texinfo-6.7.90/info/variables.c 2021-02-24 13:36:27.089318922 +0100
|
||||
diff -up texinfo-7.0.92/info/variables.c.orig texinfo-7.0.92/info/variables.c
|
||||
--- texinfo-7.0.92/info/variables.c.orig 2023-09-14 13:20:14.464370153 +0200
|
||||
+++ texinfo-7.0.92/info/variables.c 2023-09-14 13:21:00.343411464 +0200
|
||||
@@ -359,6 +359,7 @@ read_variable_name (char *prompt, WINDOW
|
||||
{
|
||||
char *line;
|
||||
@ -31,15 +31,4 @@ diff -up texinfo-6.7.90/info/variables.c.orig texinfo-6.7.90/info/variables.c
|
||||
}
|
||||
|
||||
/* Make an array of REFERENCE which actually contains the names of the
|
||||
diff -up texinfo-6.7.90/install-info/install-info.c.orig texinfo-6.7.90/install-info/install-info.c
|
||||
--- texinfo-6.7.90/install-info/install-info.c.orig 2021-02-24 13:36:42.839472560 +0100
|
||||
+++ texinfo-6.7.90/install-info/install-info.c 2021-02-24 13:41:36.219280631 +0100
|
||||
@@ -1717,6 +1728,8 @@ reformat_new_entries (struct spec_entry
|
||||
|
||||
format_entry (name, name_len, desc, desc_len, calign, align,
|
||||
maxwidth, &entry->text, &entry->text_len);
|
||||
+ free (desc);
|
||||
+ free (name);
|
||||
}
|
||||
}
|
||||
|
||||
diff -up texinfo-7.0.92/install-info/install-info.c.orig texinfo-7.0.92/install-info/install-info.c
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -up texinfo-7.0.2/tp/Texinfo/ParserNonXS.pm.orig texinfo-7.0.2/tp/Texinfo/ParserNonXS.pm
|
||||
--- texinfo-7.0.2/tp/Texinfo/ParserNonXS.pm.orig 2023-01-22 11:42:42.000000000 +0100
|
||||
+++ texinfo-7.0.2/tp/Texinfo/ParserNonXS.pm 2023-02-22 12:22:13.711852621 +0100
|
||||
@@ -4357,6 +4357,7 @@ sub _process_remaining_on_line($$$$)
|
||||
and ($current->{'parent'}->{'type'} eq 'menu_comment'
|
||||
or $current->{'parent'}->{'type'} eq 'menu_entry_description')
|
||||
and $asterisk
|
||||
+ and $current->{'contents'}
|
||||
and @{$current->{'contents'}}
|
||||
and $current->{'contents'}->[-1]->{'type'}
|
||||
and $current->{'contents'}->[-1]->{'type'} eq 'empty_line'
|
24
texinfo.spec
24
texinfo.spec
@ -2,23 +2,19 @@
|
||||
|
||||
Summary: Tools needed to create Texinfo format documentation files
|
||||
Name: texinfo
|
||||
Version: 7.0.3
|
||||
Release: 3%{?dist}
|
||||
Version: 7.1
|
||||
Release: 1%{?dist}
|
||||
License: GPL-3.0-or-later
|
||||
Url: http://www.gnu.org/software/texinfo/
|
||||
Source0: ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.xz
|
||||
Source1: ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.xz.sig
|
||||
Source2: fix-info-dir
|
||||
# Patch0: rhbz#1348671, because of OSTree
|
||||
Patch0: texinfo-6.1-install-info-use-create-tmp-then-rename-pattern.patch
|
||||
# Patch1: we need to fix template fix-info-dir generates
|
||||
Patch1: info-6.5-sync-fix-info-dir.patch
|
||||
# Patch2: rhbz#1592433, bug in fix-info-dir --delete
|
||||
Patch2: texinfo-6.5-fix-info-dir.patch
|
||||
# Patch3: fixes issues detected by static analysis
|
||||
Patch3: texinfo-6.5-covscan-fixes.patch
|
||||
# Patch4: fixes possible use of an undefined value as an ARRAY reference in ParserNonXS.pm
|
||||
Patch4: texinfo-7.0.2-undef-val-array-ref.patch
|
||||
# Patch0: we need to fix template fix-info-dir generates
|
||||
Patch0: info-6.5-sync-fix-info-dir.patch
|
||||
# Patch1: rhbz#1592433, bug in fix-info-dir --delete
|
||||
Patch1: texinfo-6.5-fix-info-dir.patch
|
||||
# Patch2: fixes issues detected by static analysis
|
||||
Patch2: texinfo-6.5-covscan-fixes.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -152,6 +148,10 @@ export ALL_TESTS=yes
|
||||
%{_mandir}/man1/pdftexi2dvi.1*
|
||||
|
||||
%changelog
|
||||
* Tue Oct 24 2023 Vitezslav Crhonek <vcrhonek@redhat.com> - 7.1-1
|
||||
- Update to texinfo-7.1
|
||||
Resolves: #2244846
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user