fix direntry
This commit is contained in:
parent
c2deaf896b
commit
0679bb249b
23
texinfo-4.11-direntry.patch
Normal file
23
texinfo-4.11-direntry.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
--- texinfo-4.11/makeinfo/cmds.c_old 2007-07-15 19:36:19.000000000 +0200
|
||||||
|
+++ texinfo-4.11/makeinfo/cmds.c 2007-12-10 15:11:04.000000000 +0100
|
||||||
|
@@ -1637,11 +1637,16 @@
|
||||||
|
|
||||||
|
if (!no_headers && !html)
|
||||||
|
{
|
||||||
|
+ /* use add_* instead of insert_* because otherwise the
|
||||||
|
+ file header ("This is ...") will end up inside the
|
||||||
|
+ dir section markers. */
|
||||||
|
kill_self_indent (-1); /* make sure there's no indentation */
|
||||||
|
- insert_string ("INFO-DIR-SECTION ");
|
||||||
|
- insert_string (line);
|
||||||
|
- insert ('\n');
|
||||||
|
- }
|
||||||
|
+ cm_noindent (); /* make sure again */
|
||||||
|
+ add_word ("INFO-DIR-SECTION ");
|
||||||
|
+ add_word (line);
|
||||||
|
+ add_char ('\n');
|
||||||
|
+
|
||||||
|
+ }
|
||||||
|
|
||||||
|
free (line);
|
||||||
|
}
|
15
texinfo.spec
15
texinfo.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Tools needed to create Texinfo format documentation files
|
Summary: Tools needed to create Texinfo format documentation files
|
||||||
Name: texinfo
|
Name: texinfo
|
||||||
Version: 4.11
|
Version: 4.11
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: GPLv3
|
License: GPLv3
|
||||||
Group: Applications/Publishing
|
Group: Applications/Publishing
|
||||||
Url: http://www.gnu.org/software/texinfo/
|
Url: http://www.gnu.org/software/texinfo/
|
||||||
@ -10,9 +10,10 @@ Source1: info-dir
|
|||||||
Source2: texi2pdf.man
|
Source2: texi2pdf.man
|
||||||
Patch0: texinfo-4.11-zlib.patch
|
Patch0: texinfo-4.11-zlib.patch
|
||||||
Patch1: texinfo-4.11-res_win_segfault.patch
|
Patch1: texinfo-4.11-res_win_segfault.patch
|
||||||
|
Patch2: texinfo-4.11-direntry.patch
|
||||||
Requires(post): /sbin/install-info
|
Requires(post): /sbin/install-info
|
||||||
Requires(preun): /sbin/install-info
|
Requires(preun): /sbin/install-info
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: zlib-devel, ncurses-devel
|
BuildRequires: zlib-devel, ncurses-devel
|
||||||
|
|
||||||
# Redefine this so "dir" in the info directory isn't compressed
|
# Redefine this so "dir" in the info directory isn't compressed
|
||||||
@ -61,6 +62,7 @@ for printing using TeX.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .zlib
|
%patch0 -p1 -b .zlib
|
||||||
%patch1 -p1 -b .res_win_segfault
|
%patch1 -p1 -b .res_win_segfault
|
||||||
|
%patch2 -p1 -b .direntry
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -139,13 +141,18 @@ fi
|
|||||||
%{_mandir}/man1/texi2pdf.1*
|
%{_mandir}/man1/texi2pdf.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 10 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 4.11-4
|
||||||
|
- Don't insert description ("This is...") into the direntry section
|
||||||
|
of some generated files
|
||||||
|
Resolves: #394191
|
||||||
|
|
||||||
* Tue Nov 13 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 4.11-3
|
* Tue Nov 13 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 4.11-3
|
||||||
- Fix info crashes when resizing window
|
- Fix info crashes when resizing window
|
||||||
- Resolves: #243971
|
Resolves: #243971
|
||||||
|
|
||||||
* Wed Nov 7 2007 Stepan Kasal <skasal@redhat.com> - 4.11-2
|
* Wed Nov 7 2007 Stepan Kasal <skasal@redhat.com> - 4.11-2
|
||||||
- fix a typo in texinfo-tex summary
|
- fix a typo in texinfo-tex summary
|
||||||
- Resolves: #239216
|
Resolves: #239216
|
||||||
|
|
||||||
* Wed Sep 19 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 4.11-1
|
* Wed Sep 19 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 4.11-1
|
||||||
- Rebase to upstream texinfo-4.11 (update zlib.patch, drop
|
- Rebase to upstream texinfo-4.11 (update zlib.patch, drop
|
||||||
|
Loading…
Reference in New Issue
Block a user