Update to texinfo-4.12, Remove description ('This is...') from
/usr/share/info/dir in info post install section
This commit is contained in:
parent
45b0d87911
commit
04154794e3
@ -2,3 +2,5 @@ texinfo-4.7.tar.bz2
|
||||
texinfo-4.8.tar.bz2
|
||||
texinfo-4.9.tar.bz2
|
||||
texinfo-4.11.tar.bz2
|
||||
texinfo-4.12.tar.gz
|
||||
texinfo-4.12.tar.gz.sig
|
||||
|
3
sources
3
sources
@ -1 +1,2 @@
|
||||
c6bf13df4fbeff8ce874aacd6a51e814 texinfo-4.11.tar.bz2
|
||||
e9216fb657e1555a289a14a74dac8f4f texinfo-4.12.tar.gz
|
||||
fe17b722bc9f157ed5e9c88e9be3732d texinfo-4.12.tar.gz.sig
|
||||
|
@ -1,23 +0,0 @@
|
||||
--- texinfo-4.11/makeinfo/cmds.c_old 2007-07-15 19:36:19.000000000 +0200
|
||||
+++ texinfo-4.11/makeinfo/cmds.c 2007-12-10 15:11:04.000000000 +0100
|
||||
@@ -1637,11 +1637,16 @@
|
||||
|
||||
if (!no_headers && !html)
|
||||
{
|
||||
+ /* use add_* instead of insert_* because otherwise the
|
||||
+ file header ("This is ...") will end up inside the
|
||||
+ dir section markers. */
|
||||
kill_self_indent (-1); /* make sure there's no indentation */
|
||||
- insert_string ("INFO-DIR-SECTION ");
|
||||
- insert_string (line);
|
||||
- insert ('\n');
|
||||
- }
|
||||
+ cm_noindent (); /* make sure again */
|
||||
+ add_word ("INFO-DIR-SECTION ");
|
||||
+ add_word (line);
|
||||
+ add_char ('\n');
|
||||
+
|
||||
+ }
|
||||
|
||||
free (line);
|
||||
}
|
@ -1,58 +0,0 @@
|
||||
--- texinfo-4.11/info/window.c_old 2007-07-01 23:20:31.000000000 +0200
|
||||
+++ texinfo-4.11/info/window.c 2007-11-13 10:52:44.000000000 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
/* window.c -- windows in Info.
|
||||
- $Id: window.c,v 1.7 2007/07/01 21:20:31 karl Exp $
|
||||
+ $Id: window.c,v 1.8 2007/10/19 18:43:20 karl Exp $
|
||||
|
||||
Copyright (C) 1993, 1997, 1998, 2001, 2002, 2003, 2004, 2007
|
||||
Free Software Foundation, Inc.
|
||||
@@ -249,9 +249,22 @@
|
||||
break;
|
||||
}
|
||||
else
|
||||
- win= win->next;
|
||||
+ win = win->next;
|
||||
}
|
||||
}
|
||||
+
|
||||
+ /* One more loop. If any heights or widths have become negative,
|
||||
+ set them to zero. This can apparently happen with resizing down to
|
||||
+ very small sizes. Sadly, it is not apparent to me where in the
|
||||
+ above calculations it goes wrong. */
|
||||
+ for (win = windows; win; win = win->next)
|
||||
+ {
|
||||
+ if (win->height < 0)
|
||||
+ win->height = 0;
|
||||
+
|
||||
+ if (win->width < 0)
|
||||
+ win->width = 0;
|
||||
+ }
|
||||
}
|
||||
|
||||
/* Make a new window showing NODE, and return that window structure.
|
||||
--- texinfo-4.11/info/display.c_old 2007-07-01 23:20:29.000000000 +0200
|
||||
+++ texinfo-4.11/info/display.c 2007-11-13 10:53:58.000000000 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
/* display.c -- How to display Info windows.
|
||||
- $Id: display.c,v 1.11 2007/07/01 21:20:29 karl Exp $
|
||||
+ $Id: display.c,v 1.12 2007/10/19 18:43:20 karl Exp $
|
||||
|
||||
Copyright (C) 1993, 1997, 2003, 2004, 2006, 2007
|
||||
Free Software Foundation, Inc.
|
||||
@@ -136,8 +136,13 @@
|
||||
if (display_inhibited)
|
||||
display_was_interrupted_p = 1;
|
||||
|
||||
- /* If the window has no height, or display is inhibited, quit now. */
|
||||
- if (!win->height || display_inhibited)
|
||||
+ /* If the window has no height, or display is inhibited, quit now.
|
||||
+ Strictly speaking, it should only be necessary to test if the
|
||||
+ values are equal to zero, since window_new_screen_size should
|
||||
+ ensure that the window height/width never becomes negative, but
|
||||
+ since historically this has often been the culprit for crashes, do
|
||||
+ our best to be doubly safe. */
|
||||
+ if (win->height <= 0 || win->width <= 0 || display_inhibited)
|
||||
return;
|
||||
|
||||
/* If the window's first row doesn't appear in the_screen, then it
|
@ -1,6 +1,7 @@
|
||||
--- texinfo-4.11/util/Makefile.in_old 2007-09-10 02:37:45.000000000 +0200
|
||||
+++ texinfo-4.11/util/Makefile.in 2007-09-19 10:29:06.000000000 +0200
|
||||
@@ -110,7 +110,7 @@
|
||||
diff -up texinfo-4.12/install-info/Makefile.in_old texinfo-4.12/install-info/Makefile.in
|
||||
--- texinfo-4.12/install-info/Makefile.in_old 2008-05-13 13:33:55.000000000 +0200
|
||||
+++ texinfo-4.12/install-info/Makefile.in 2008-05-13 13:52:35.000000000 +0200
|
||||
@@ -114,7 +114,7 @@ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
|
||||
PROGRAMS = $(bin_PROGRAMS)
|
||||
am_ginstall_info_OBJECTS = install-info.$(OBJEXT)
|
||||
ginstall_info_OBJECTS = $(am_ginstall_info_OBJECTS)
|
||||
@ -9,17 +10,18 @@
|
||||
am__DEPENDENCIES_1 =
|
||||
ginstall_info_DEPENDENCIES = ../lib/libtxi.a \
|
||||
$(top_builddir)/gnulib/lib/libgnu.a $(am__DEPENDENCIES_1)
|
||||
--- texinfo-4.11/util/install-info.c_old 2007-07-01 23:20:33.000000000 +0200
|
||||
+++ texinfo-4.11/util/install-info.c 2007-09-19 10:40:02.000000000 +0200
|
||||
@@ -20,6 +20,7 @@
|
||||
#include "system.h"
|
||||
diff -up texinfo-4.12/install-info/install-info.c_old texinfo-4.12/install-info/install-info.c
|
||||
--- texinfo-4.12/install-info/install-info.c_old 2008-05-13 13:52:44.000000000 +0200
|
||||
+++ texinfo-4.12/install-info/install-info.c 2008-05-14 10:30:53.000000000 +0200
|
||||
@@ -21,6 +21,7 @@
|
||||
#include <getopt.h>
|
||||
#include <regex.h>
|
||||
#include <argz.h>
|
||||
+#include <zlib.h>
|
||||
|
||||
static char *progname = "install-info";
|
||||
#define TAB_WIDTH 8
|
||||
|
||||
@@ -559,7 +560,7 @@
|
||||
@@ -638,7 +639,7 @@ The first time you invoke Info you start
|
||||
COMPRESSION_PROGRAM. The compression program is determined by the
|
||||
magic number, not the filename. */
|
||||
|
||||
@ -28,16 +30,16 @@
|
||||
open_possibly_compressed_file (char *filename,
|
||||
void (*create_callback) (char *),
|
||||
char **opened_filename, char **compression_program, int *is_pipe)
|
||||
@@ -567,7 +568,7 @@
|
||||
@@ -646,7 +647,7 @@ open_possibly_compressed_file (char *fil
|
||||
char *local_opened_filename, *local_compression_program;
|
||||
int nread;
|
||||
char data[4];
|
||||
char data[13];
|
||||
- FILE *f;
|
||||
+ gzFile *f;
|
||||
|
||||
/* We let them pass NULL if they don't want this info, but it's easier
|
||||
to always determine it. */
|
||||
@@ -575,16 +576,16 @@
|
||||
@@ -654,22 +655,22 @@ open_possibly_compressed_file (char *fil
|
||||
opened_filename = &local_opened_filename;
|
||||
|
||||
*opened_filename = filename;
|
||||
@ -53,11 +55,18 @@
|
||||
free (*opened_filename);
|
||||
*opened_filename = concat (filename, ".bz2", "");
|
||||
- f = fopen (*opened_filename, FOPEN_RBIN);
|
||||
+ f = gzopen (*opened_filename, FOPEN_RBIN);
|
||||
}
|
||||
if (!f)
|
||||
{
|
||||
free (*opened_filename);
|
||||
*opened_filename = concat (filename, ".lzma", "");
|
||||
- f = fopen (*opened_filename, FOPEN_RBIN);
|
||||
+ f = gzopen (*opened_filename, FOPEN_RBIN);
|
||||
}
|
||||
|
||||
#ifdef __MSDOS__
|
||||
@@ -592,13 +593,13 @@
|
||||
@@ -677,13 +678,13 @@ open_possibly_compressed_file (char *fil
|
||||
{
|
||||
free (*opened_filename);
|
||||
*opened_filename = concat (filename, ".igz", "");
|
||||
@ -73,7 +82,7 @@
|
||||
}
|
||||
#endif
|
||||
if (!f)
|
||||
@@ -610,7 +611,7 @@
|
||||
@@ -695,7 +696,7 @@ open_possibly_compressed_file (char *fil
|
||||
/* And try opening it again. */
|
||||
free (*opened_filename);
|
||||
*opened_filename = filename;
|
||||
@ -82,7 +91,7 @@
|
||||
if (!f)
|
||||
pfatal_with_name (filename);
|
||||
}
|
||||
@@ -621,12 +622,12 @@
|
||||
@@ -706,12 +707,12 @@ open_possibly_compressed_file (char *fil
|
||||
|
||||
/* Read first few bytes of file rather than relying on the filename.
|
||||
If the file is shorter than this it can't be usable anyway. */
|
||||
@ -98,7 +107,7 @@
|
||||
fatal (_("%s: empty file"), *opened_filename, 0);
|
||||
pfatal_with_name (*opened_filename);
|
||||
}
|
||||
@@ -659,20 +660,22 @@
|
||||
@@ -758,20 +759,22 @@ open_possibly_compressed_file (char *fil
|
||||
|
||||
if (*compression_program)
|
||||
{ /* It's compressed, so fclose the file and then open a pipe. */
|
||||
@ -126,7 +135,7 @@
|
||||
/* Since this is a text file, and we opened it in binary mode,
|
||||
switch back to text mode. */
|
||||
f = freopen (*opened_filename, "r", f);
|
||||
@@ -697,7 +700,7 @@
|
||||
@@ -796,7 +799,7 @@ readfile (char *filename, int *sizep,
|
||||
char **compression_program)
|
||||
{
|
||||
char *real_name;
|
||||
@ -135,7 +144,7 @@
|
||||
int pipe_p;
|
||||
int filled = 0;
|
||||
int data_size = 8192;
|
||||
@@ -711,7 +714,12 @@
|
||||
@@ -810,7 +813,12 @@ readfile (char *filename, int *sizep,
|
||||
|
||||
for (;;)
|
||||
{
|
||||
@ -149,7 +158,7 @@
|
||||
if (nread < 0)
|
||||
pfatal_with_name (real_name);
|
||||
if (nread == 0)
|
||||
@@ -733,7 +741,7 @@
|
||||
@@ -832,7 +840,7 @@ readfile (char *filename, int *sizep,
|
||||
if (pipe_p)
|
||||
pclose (f);
|
||||
else
|
20
texinfo.spec
20
texinfo.spec
@ -2,17 +2,15 @@
|
||||
|
||||
Summary: Tools needed to create Texinfo format documentation files
|
||||
Name: texinfo
|
||||
Version: 4.11
|
||||
Release: 5%{?dist}
|
||||
Version: 4.12
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Publishing
|
||||
Url: http://www.gnu.org/software/texinfo/
|
||||
Source0: ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.bz2
|
||||
Source0: ftp://ftp.gnu.org/gnu/texinfo/texinfo-%{version}.tar.gz
|
||||
Source1: info-dir
|
||||
Source2: texi2pdf.man
|
||||
Patch0: texinfo-4.11-zlib.patch
|
||||
Patch1: texinfo-4.11-res_win_segfault.patch
|
||||
Patch2: texinfo-4.11-direntry.patch
|
||||
Patch0: texinfo-4.12-zlib.patch
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -55,8 +53,6 @@ for printing using TeX.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .zlib
|
||||
%patch1 -p1 -b .res_win_segfault
|
||||
%patch2 -p1 -b .direntry
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -95,6 +91,7 @@ fi
|
||||
|
||||
%post -n info
|
||||
/sbin/install-info %{_infodir}/info-stnd.info %{_infodir}/dir || :
|
||||
sed -i 's/^This is.*produced by makeinfo.*from/d/' /usr/share/info/dir
|
||||
|
||||
%preun -n info
|
||||
if [ $1 = 0 ]; then
|
||||
@ -142,8 +139,15 @@ fi
|
||||
%{_mandir}/man1/texindex.1*
|
||||
%{_mandir}/man1/texi2dvi.1*
|
||||
%{_mandir}/man1/texi2pdf.1*
|
||||
%{_mandir}/man1/pdftexi2dvi.1*
|
||||
|
||||
%changelog
|
||||
* Wed May 14 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 4.12-1
|
||||
- Update to texinfo-4.12
|
||||
- Remove description ("This is...") from /usr/share/info/dir in info
|
||||
post install section
|
||||
Resolves: #433535
|
||||
|
||||
* Mon Feb 4 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 4.11-5
|
||||
- Merge Review
|
||||
Resolves: #226488
|
||||
|
Loading…
Reference in New Issue
Block a user