diff --git a/pom.xml b/pom.xml
new file mode 100644
index 0000000..940931e
--- /dev/null
+++ b/pom.xml
@@ -0,0 +1,240 @@
+
+
+
+
+
+ 4.0.0
+ org.testng
+ testng
+ jar
+ TestNG
+ 6.11
+ TestNG is a testing framework.
+ http://testng.org
+
+
+
+ Apache License, Version 2.0
+ http://apache.org/licenses/LICENSE-2.0
+ repo
+
+
+
+
+ scm:git:git@github.com:cbeust/testng.git
+ scm:git:git@github.com:cbeust/testng.git
+ git@github.com:cbeust/testng.git
+
+
+
+
+ Cedric Beust
+
+
+
+
+ org.sonatype.oss
+ oss-parent
+ 3
+
+
+
+
+ bintray
+ https://api.bintray.com/maven/cbeust/maven/testng
+
+
+
+
+
+ com.beust
+ jcommander
+ 1.64
+
+
+ org.yaml
+ snakeyaml
+ 1.17
+
+
+ junit
+ junit
+ 4.12
+ true
+
+
+ org.apache.ant
+ ant
+ 1.9.7
+ true
+
+
+ org.apache-extras.beanshell
+ bsh
+ 2.0b6
+ true
+
+
+ com.google.inject
+ guice
+ 4.1.0
+ provided
+
+
+
+
+
+
+ src/main/resources
+
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-javadoc-plugin
+ 2.10.3
+
+ false
+ *internal
+
+
+
+ attach-javadocs
+
+ jar
+
+
+
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-source-plugin
+ 2.1.1
+
+
+ attach-sources
+
+ jar
+
+
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-compiler-plugin
+ 3.1
+
+
+ 1.7
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-resources-plugin
+ 2.4.3
+
+ UTF-8
+
+
+
+ process-sources
+
+
+
+
+
+
+ org.apache.felix
+ maven-bundle-plugin
+ 2.1.0
+
+
+ bundle-manifest
+ process-classes
+
+ manifest
+
+
+
+ <_versionpolicy>$(@)
+
+ bsh.*;version="[2.0.0,3.0.0)";resolution:=optional,
+ com.beust.jcommander.*;version="[1.7.0,3.0.0)";resolution:=optional,
+ com.google.inject.*;version="[1.2,1.3)";resolution:=optional,
+ junit.framework;version="[3.8.1, 5.0.0)";resolution:=optional,
+ org.junit.*;resolution:=optional,
+ org.apache.tools.ant.*;version="[1.7.0, 2.0.0)";resolution:=optional,
+ org.yaml.*;version="[1.6,2.0)";resolution:=optional,
+ !com.beust.testng,
+ !org.testng.*,
+ !com.sun.*,
+ *
+
+
+
+
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-jar-plugin
+ 2.3.1
+
+
+ ${project.build.outputDirectory}/META-INF/MANIFEST.MF
+
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-surefire-plugin
+ 2.19
+
+
+ src/test/resources/testng.xml
+
+
+
+ listener
+ test.invokedmethodlistener.MyListener
+
+
+
+ ${project.build.testOutputDirectory}
+
+
+
+
+
+
+ org.apache.maven.plugins
+ maven-gpg-plugin
+ 1.4
+
+
+ sign-artifacts
+ verify
+
+ sign
+
+
+
+
+
+
+
+
+
diff --git a/testng.spec b/testng.spec
index 0327cc0..8ea8f7d 100644
--- a/testng.spec
+++ b/testng.spec
@@ -1,24 +1,27 @@
%bcond_without groovy
Name: testng
-Version: 6.9.12
-Release: 5%{?dist}
+Version: 6.11
+Release: 1%{?dist}
Summary: Java-based testing framework
License: ASL 2.0
URL: http://testng.org/
Source0: https://github.com/cbeust/testng/archive/%{version}.tar.gz
+
+# Allows building with maven instead of gradle
+Source1: pom.xml
+
Patch0: 0001-Avoid-accidental-javascript-in-javadoc.patch
BuildArch: noarch
BuildRequires: maven-local
BuildRequires: mvn(com.beust:jcommander)
-BuildRequires: mvn(com.google.inject:guice::no_aop:)
+BuildRequires: mvn(com.google.inject:guice)
BuildRequires: mvn(junit:junit)
BuildRequires: mvn(org.apache.ant:ant)
+BuildRequires: mvn(org.apache-extras.beanshell:bsh)
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
-BuildRequires: mvn(org.beanshell:bsh)
-BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
BuildRequires: mvn(org.sonatype.oss:oss-parent:pom:)
BuildRequires: mvn(org.yaml:snakeyaml)
%if %{with groovy}
@@ -45,6 +48,8 @@ This package contains the API documentation for %{name}.
%patch0 -p1
+cp %{SOURCE1} .
+
# remove any bundled libs, but not test resources
find ! -path "*/test/*" -name *.jar -print -delete
find -name *.class -delete
@@ -58,21 +63,18 @@ find -name *.class -delete
%if %{with groovy}
%pom_add_plugin "org.codehaus.gmavenplus:gmavenplus-plugin" pom.xml \
"addTestSourcestestGenerateStubstestCompileremoveTestStubs"
+%pom_add_dep "org.assertj:assertj-core::test"
%pom_add_dep "org.spockframework:spock-core::test"
%pom_add_dep "org.codehaus.groovy:groovy-all::test"
+
+# remove failing test
+sed -i -e '/parallelDataProviderSample/,+12d' ./src/test/java/test/dataprovider/DataProviderTest.java
%endif
-# avoid SNAPSHOT in version number
-sed -i -e '//s/-SNAPSHOT//' pom.xml
-
-# plugins not in Fedora
-%pom_remove_plugin com.coderplus.maven.plugins:copy-rename-maven-plugin
-sed -i -e 's/VersionTemplateJava/Version.java/' pom.xml
-mv ./src/main/resources/org/testng/internal/VersionTemplateJava ./src/main/resources/org/testng/internal/Version.java
+sed -i -e 's/DEV-SNAPSHOT/%{version}/' src/main/java/org/testng/internal/Version.java
cp -p ./src/main/java/*.dtd.html ./src/main/resources/.
-
%mvn_file : %{name}
# jdk15 classifier is used by some other packages
%mvn_alias : :::jdk15:
@@ -95,6 +97,11 @@ cp -p ./src/main/java/*.dtd.html ./src/main/resources/.
%license LICENSE.txt
%changelog
+* Tue Jul 04 2017 Mat Booth - 6.11-1
+- Update to latest upstream release
+- Continue building with maven for now, instead of moving to gradle due to
+ rhbz#1467724
+
* Wed May 31 2017 Michael Simacek - 6.9.12-5
- Avoid accidental javascript in comment