Import testng
This commit is contained in:
parent
86a426f8d9
commit
5f0a9bc641
@ -0,0 +1 @@
|
||||
testng-5.11.zip
|
39
0001-Disable-DTDDoc-target.patch
Normal file
39
0001-Disable-DTDDoc-target.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 770133c22ac56be30115f33a904e8d590e0c0cda Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Fri, 27 Nov 2009 14:46:16 +0100
|
||||
Subject: [PATCH 2/4] Disable DTDDoc target
|
||||
|
||||
We do not ship DTDDoc yet.
|
||||
---
|
||||
build.xml | 8 ++++----
|
||||
1 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 832b36b..71af78b 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -371,17 +371,17 @@
|
||||
<copy file="${jdk15.testng.jar}" tofile="${jdk15.jar}" />
|
||||
</target>
|
||||
|
||||
- <taskdef name="DTDDoc" classname="DTDDoc.DTDDocTask"
|
||||
- classpath="lib/DTDDoc.jar"/>
|
||||
+ <!--taskdef name="DTDDoc" classname="DTDDoc.DTDDocTask"
|
||||
+ classpath="lib/DTDDoc.jar"/-->
|
||||
|
||||
<target name="dtd">
|
||||
- <DTDDoc showHiddenTags="false"
|
||||
+ <!--DTDDoc showHiddenTags="false"
|
||||
showFixmeTags="false"
|
||||
sourceDir="src/main"
|
||||
destDir="dtd"
|
||||
docTitle="TestNG DTD">
|
||||
<include name="testng-1.0.dtd"/>
|
||||
- </DTDDoc>
|
||||
+ </DTDDoc-->
|
||||
</target>
|
||||
|
||||
<target name="ftp">
|
||||
--
|
||||
1.6.5.2
|
||||
|
44
0001-Do-not-bundle-prebuilt-jar-s.patch
Normal file
44
0001-Do-not-bundle-prebuilt-jar-s.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 4bc2dd4f10a7cca628af7c9c8aac6fe3b3d5ad27 Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Fri, 27 Nov 2009 14:46:15 +0100
|
||||
Subject: [PATCH 1/4] Do not bundle prebuilt jar-s
|
||||
|
||||
---
|
||||
build.xml | 12 ++++++------
|
||||
1 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 683100d..832b36b 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -243,21 +243,21 @@
|
||||
</target>
|
||||
|
||||
<target name="extract-beanshell-jar">
|
||||
- <unjar src="3rdparty/${beanshell.jar}"
|
||||
+ <!--unjar src="3rdparty/${beanshell.jar}"
|
||||
dest="${build.3rdparty.dir}"
|
||||
- overwrite="true" />
|
||||
+ overwrite="true" /-->
|
||||
</target>
|
||||
|
||||
<target name="extract-qdox-jar">
|
||||
- <unjar src="3rdparty/${qdox.jar}"
|
||||
+ <!--unjar src="3rdparty/${qdox.jar}"
|
||||
dest="${build.3rdparty.dir}"
|
||||
- overwrite="true" />
|
||||
+ overwrite="true" /-->
|
||||
</target>
|
||||
|
||||
<target name="extract-concurrent-jar">
|
||||
- <unjar src="3rdparty/${concurrent.jar}"
|
||||
+ <!--unjar src="3rdparty/${concurrent.jar}"
|
||||
dest="${build.3rdparty.dir}"
|
||||
- overwrite="true" />
|
||||
+ overwrite="true" /-->
|
||||
</target>
|
||||
|
||||
<target name="dist-15" depends="compile-15, dist-15-bsh">
|
||||
--
|
||||
1.6.5.2
|
||||
|
43
0001-Port-to-QDoc-1.9.patch
Normal file
43
0001-Port-to-QDoc-1.9.patch
Normal file
@ -0,0 +1,43 @@
|
||||
From 02af5468f942e91ddbbbafab7256124b1e72b013 Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Fri, 27 Nov 2009 14:46:16 +0100
|
||||
Subject: [PATCH 3/4] Port to QDoc 1.9
|
||||
|
||||
---
|
||||
.../testng/internal/AnnotationTestConverter.java | 6 +++---
|
||||
1 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/main/org/testng/internal/AnnotationTestConverter.java b/src/main/org/testng/internal/AnnotationTestConverter.java
|
||||
index 539592b..d024e9f 100644
|
||||
--- a/src/main/org/testng/internal/AnnotationTestConverter.java
|
||||
+++ b/src/main/org/testng/internal/AnnotationTestConverter.java
|
||||
@@ -115,7 +115,7 @@ public class AnnotationTestConverter {
|
||||
Class<IAnnotation> annotationClass= m_annotationMap.get(tag.getName());
|
||||
if(annotationClass == null) {
|
||||
ppp("Found unknown testng annotation " + tag.getName() + " in file "
|
||||
- + tag.getContext().getSource().getFile().getAbsolutePath() + " at line "
|
||||
+ + tag.getContext().getParent().getParentSource().getFile().getAbsolutePath() + " at line "
|
||||
+ tag.getLineNumber());
|
||||
|
||||
// preserve the information - but it looks like an invalid tag
|
||||
@@ -128,7 +128,7 @@ public class AnnotationTestConverter {
|
||||
}
|
||||
catch(Exception e) {
|
||||
ppp("Found unknown testng parameter " + key + " in annotation " + tag.getName() + " in file "
|
||||
- + tag.getContext().getSource().getFile().getAbsolutePath() + " at line "
|
||||
+ + tag.getContext().getParent().getParentSource().getFile().getAbsolutePath() + " at line "
|
||||
+ tag.getLineNumber());
|
||||
|
||||
// preserve the information - but it looks like an invalid parameter
|
||||
@@ -279,7 +279,7 @@ public class AnnotationTestConverter {
|
||||
|
||||
if(finalLines.size() > lineCount) {
|
||||
ppp("Writing file " + file.getAbsolutePath());
|
||||
- writeFile(file, source.getPackage(), finalLines);
|
||||
+ writeFile(file, source.getPackage().getName(), finalLines);
|
||||
converted++;
|
||||
}
|
||||
}
|
||||
--
|
||||
1.6.5.2
|
||||
|
58
testng-5.11.pom
Normal file
58
testng-5.11.pom
Normal file
@ -0,0 +1,58 @@
|
||||
<project xmlns="http://maven.apache.org/POM/4.0.0"
|
||||
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
|
||||
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||
<!--
|
||||
This POM cannot be used to build TestNG; it should only be used as part of a Maven
|
||||
repository upload bundle.
|
||||
|
||||
See the guide to creating a bundle here:
|
||||
http://maven.apache.org/guides/mini/guide-central-repository-upload.html
|
||||
-->
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>org.testng</groupId>
|
||||
<artifactId>testng</artifactId>
|
||||
<name>TestNG</name>
|
||||
<version>5.11</version>
|
||||
<description>TestNG is a testing framework inspired from JUnit and NUnit but introducing some new functionalities that make it more powerful and easier to use.</description>
|
||||
<url>http://testng.org</url>
|
||||
|
||||
<licenses>
|
||||
<license>
|
||||
<name>Apache License, Version 2.0</name>
|
||||
<url>http://apache.org/licenses/LICENSE-2.0</url>
|
||||
</license>
|
||||
</licenses>
|
||||
|
||||
<scm>
|
||||
<connection>scm:svn:http://testng.googlecode.com/svn/trunk/</connection>
|
||||
<developerConnection>scm:svn:http://testng.googlecode.com/svn/trunk/</developerConnection>
|
||||
<url>http://testng.googlecode.com/svn/trunk</url>
|
||||
</scm>
|
||||
|
||||
<dependencies>
|
||||
<dependency>
|
||||
<groupId>ant</groupId>
|
||||
<artifactId>ant</artifactId>
|
||||
<version>1.6.5</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>junit</groupId>
|
||||
<artifactId>junit</artifactId>
|
||||
<version>3.8.1</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>qdox</groupId>
|
||||
<artifactId>qdox</artifactId>
|
||||
<version>1.6.1</version>
|
||||
<scope>provided</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.beanshell</groupId>
|
||||
<artifactId>bsh</artifactId>
|
||||
<version>2.0b4</version>
|
||||
<scope>provided</scope>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
|
||||
</project>
|
123
testng.spec
Normal file
123
testng.spec
Normal file
@ -0,0 +1,123 @@
|
||||
Name: testng
|
||||
Version: 5.11
|
||||
Release: 2%{?dist}
|
||||
Summary: Java-based testing framework
|
||||
|
||||
Group: Development/Tools
|
||||
License: ASL 2.0
|
||||
URL: http://testng.org/
|
||||
Source0: http://testng.org/%{name}-%{version}.zip
|
||||
Source1: http://repo2.maven.org/maven2/org/testng/testng/%{version}/testng-%{version}.pom
|
||||
Patch0: 0001-Do-not-bundle-prebuilt-jar-s.patch
|
||||
Patch1: 0001-Disable-DTDDoc-target.patch
|
||||
Patch2: 0001-Port-to-QDoc-1.9.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
BuildRequires: ant
|
||||
BuildRequires: unzip
|
||||
BuildRequires: jpackage-utils
|
||||
BuildRequires: java-devel-openjdk
|
||||
BuildRequires: bsh
|
||||
BuildRequires: qdox
|
||||
BuildRequires: backport-util-concurrent
|
||||
BuildRequires: junit
|
||||
Requires: jpackage-utils
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
TestNG is a testing framework inspired from JUnit and NUnit but introducing
|
||||
some new functionality, including flexible test configuration, and
|
||||
distributed test running. It is designed to cover unit tests as well as
|
||||
functional, end-to-end, integration, etc.
|
||||
|
||||
|
||||
%package javadoc
|
||||
Summary: API Documentation for %{name}
|
||||
Group: Development/Tools
|
||||
Requires: jpackage-utils
|
||||
|
||||
%description javadoc
|
||||
JavaDoc documentation for %{name}
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .nobundle
|
||||
%patch1 -p1 -b .dtddoc
|
||||
%patch2 -p1 -b .qdoc19
|
||||
|
||||
|
||||
%build
|
||||
find -name '*.jar' -delete
|
||||
CLASSPATH=$(build-classpath bsh qdox backport-util-concurrent junit) \
|
||||
ant dist-15 javadocs
|
||||
|
||||
# Convert CP/M line encoding to UNIX one
|
||||
sed 's/\r//' <README >README.unix
|
||||
touch -r README README.unix
|
||||
mv README.unix README
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
# Code
|
||||
install -d $RPM_BUILD_ROOT%{_javadir}
|
||||
install -pm644 %{name}-%{version}-jdk15.jar \
|
||||
$RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
|
||||
ln -s %{name}-%{version}.jar \
|
||||
$RPM_BUILD_ROOT%{_javadir}/%{name}.jar
|
||||
|
||||
# API documentation
|
||||
install -d $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
cp -a javadocs/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
|
||||
# Maven stuff
|
||||
install -d -m 755 $RPM_BUILD_ROOT%{_datadir}/maven2/poms
|
||||
install -pm 644 %{SOURCE1} \
|
||||
$RPM_BUILD_ROOT/%{_datadir}/maven2/poms/JPP-%{name}.pom
|
||||
%add_to_maven_depmap org.%{name} %{name} %{version} JPP %{name}
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadir}/*
|
||||
%{_sysconfdir}/maven/fragments
|
||||
%{_datadir}/maven2
|
||||
%doc CHANGES.txt README LICENSE.txt
|
||||
|
||||
|
||||
%files javadoc
|
||||
%defattr(-,root,root,-)
|
||||
%{_javadocdir}/*
|
||||
|
||||
|
||||
%post
|
||||
%update_maven_depmap
|
||||
|
||||
|
||||
%postun
|
||||
%update_maven_depmap
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Dec 21 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.11-2
|
||||
- Add POM
|
||||
|
||||
* Sun Dec 20 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.11-1
|
||||
- Bump to 5.11
|
||||
- Add maven depmap fragments
|
||||
- Fix line encoding of README
|
||||
|
||||
* Wed Dec 09 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.10-2
|
||||
- Add javadoc
|
||||
- Don't ship jdk14 jar
|
||||
|
||||
* Fri Nov 27 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.10-1
|
||||
- Initial packaging
|
Loading…
Reference in New Issue
Block a user