RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/testng#895c543ab436fc66c0672ac5a95e5819398eef2d
This commit is contained in:
parent
cff5896925
commit
5d73831f17
21
.gitignore
vendored
21
.gitignore
vendored
@ -0,0 +1,21 @@
|
||||
/noarch/
|
||||
/.build-*.log
|
||||
/*.src.rpm
|
||||
/testng-6.0.1.tar.xz
|
||||
/testng-6.8.tar.gz
|
||||
/testng-6.8.5.tar.gz
|
||||
/testng-6.8.7.tar.gz
|
||||
/testng-6.8.8.tar.gz
|
||||
/testng-6.8.14.tar.gz
|
||||
/testng-6.8.17.tar.gz
|
||||
/testng-6.8.21.tar.gz
|
||||
/testng-6.9.5.tar.gz
|
||||
/6.9.8.tar.gz
|
||||
/6.9.9.tar.gz
|
||||
/6.9.10.tar.gz
|
||||
/6.9.11.tar.gz
|
||||
/6.9.12.tar.gz
|
||||
/6.11.tar.gz
|
||||
/6.12.tar.gz
|
||||
/6.14.3.tar.gz
|
||||
/testng-6.14.3.tar.gz
|
25
0001-Avoid-accidental-javascript-in-javadoc.patch
Normal file
25
0001-Avoid-accidental-javascript-in-javadoc.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From bce3019741aeb785658b23095ae408a6c2d8ca35 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Wed, 31 May 2017 13:44:36 +0200
|
||||
Subject: [PATCH 1/2] Avoid accidental javascript in javadoc
|
||||
|
||||
---
|
||||
src/main/java/org/testng/xml/TestNGContentHandler.java | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/main/java/org/testng/xml/TestNGContentHandler.java b/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
index 450678f..11543e3 100644
|
||||
--- a/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
+++ b/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
@@ -245,7 +245,7 @@ public class TestNGContentHandler extends DefaultHandler {
|
||||
}
|
||||
|
||||
/**
|
||||
- * Parse <script>
|
||||
+ * Parse <script>
|
||||
*/
|
||||
private void xmlScript(boolean start, Attributes attributes) {
|
||||
if (start) {
|
||||
--
|
||||
2.17.1
|
||||
|
39
0002-Replace-bundled-jquery-with-CDN-link.patch
Normal file
39
0002-Replace-bundled-jquery-with-CDN-link.patch
Normal file
@ -0,0 +1,39 @@
|
||||
From 9155677e2d5acdd2379c38041189da52c7f04946 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Wed, 18 Jul 2018 15:57:49 +0200
|
||||
Subject: [PATCH 2/2] Replace bundled jquery with CDN link
|
||||
|
||||
---
|
||||
src/main/java/org/testng/reporters/jq/Main.java | 2 +-
|
||||
src/main/resources/org/testng/header | 2 +-
|
||||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/main/java/org/testng/reporters/jq/Main.java b/src/main/java/org/testng/reporters/jq/Main.java
|
||||
index cb83ff9..b691674 100644
|
||||
--- a/src/main/java/org/testng/reporters/jq/Main.java
|
||||
+++ b/src/main/java/org/testng/reporters/jq/Main.java
|
||||
@@ -19,7 +19,7 @@ import java.util.List;
|
||||
public class Main implements IReporter {
|
||||
private static final String TESTNG_RESOURCE_PREFIX = "/org/testng/";
|
||||
private static final String[] RESOURCES = new String[] {
|
||||
- "jquery-1.7.1.min.js", "testng-reports.css", "testng-reports.js",
|
||||
+ "testng-reports.css", "testng-reports.js",
|
||||
"passed.png", "failed.png", "skipped.png", "navigator-bullet.png",
|
||||
"bullet_point.png", "collapseall.gif"
|
||||
};
|
||||
diff --git a/src/main/resources/org/testng/header b/src/main/resources/org/testng/header
|
||||
index 47f897b..a302d47 100644
|
||||
--- a/src/main/resources/org/testng/header
|
||||
+++ b/src/main/resources/org/testng/header
|
||||
@@ -6,7 +6,7 @@
|
||||
<title>TestNG reports</title>
|
||||
|
||||
<link type="text/css" href="testng-reports.css" rel="stylesheet" />
|
||||
- <script type="text/javascript" src="jquery-1.7.1.min.js"></script>
|
||||
+ <script type="text/javascript" src="https://code.jquery.com/jquery-1.7.1.min.js"></script>
|
||||
<script type="text/javascript" src="testng-reports.js"></script>
|
||||
<script type="text/javascript" src="https://www.google.com/jsapi"></script>
|
||||
<script type='text/javascript'>
|
||||
--
|
||||
2.17.1
|
||||
|
21
generate-tarball.sh
Executable file
21
generate-tarball.sh
Executable file
@ -0,0 +1,21 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
|
||||
name=testng
|
||||
version="$(sed -n 's/Version:\s*//p' *.spec)"
|
||||
|
||||
# RETRIEVE
|
||||
wget "https://github.com/cbeust/testng/archive/${version}.tar.gz" -O "${name}-${version}.orig.tar.gz"
|
||||
|
||||
rm -rf tarball-tmp
|
||||
mkdir tarball-tmp
|
||||
cd tarball-tmp
|
||||
tar xf "../${name}-${version}.orig.tar.gz"
|
||||
|
||||
# CLEAN TARBALL
|
||||
rm -r */gradle* */kobalt*
|
||||
rm */src/main/resources/org/testng/jquery-*.js
|
||||
|
||||
tar cf "../${name}-${version}.tar.gz" *
|
||||
cd ..
|
||||
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"
|
241
pom.xml
Normal file
241
pom.xml
Normal file
@ -0,0 +1,241 @@
|
||||
|
||||
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||
|
||||
<!-- Refer to the file ./build-with-maven for instruction on how to use this pom.xml -->
|
||||
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>org.testng</groupId>
|
||||
<artifactId>testng</artifactId>
|
||||
<packaging>jar</packaging>
|
||||
<name>TestNG</name>
|
||||
<version>6.14.3</version>
|
||||
<description>TestNG is a testing framework.</description>
|
||||
<url>http://testng.org</url>
|
||||
|
||||
<licenses>
|
||||
<license>
|
||||
<name>Apache License, Version 2.0</name>
|
||||
<url>http://apache.org/licenses/LICENSE-2.0</url>
|
||||
<distribution>repo</distribution>
|
||||
</license>
|
||||
</licenses>
|
||||
|
||||
<scm>
|
||||
<connection>scm:git:git@github.com:cbeust/testng.git</connection>
|
||||
<developerConnection>scm:git:git@github.com:cbeust/testng.git</developerConnection>
|
||||
<url>git@github.com:cbeust/testng.git</url>
|
||||
</scm>
|
||||
|
||||
<developers>
|
||||
<developer>
|
||||
<name>Cedric Beust</name>
|
||||
</developer>
|
||||
</developers>
|
||||
|
||||
<distributionManagement>
|
||||
<repository>
|
||||
<id>bintray</id>
|
||||
<url>https://api.bintray.com/maven/cbeust/maven/testng</url>
|
||||
</repository>
|
||||
</distributionManagement>
|
||||
|
||||
<dependencies>
|
||||
<dependency>
|
||||
<groupId>com.beust</groupId>
|
||||
<artifactId>jcommander</artifactId>
|
||||
<version>1.64</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.yaml</groupId>
|
||||
<artifactId>snakeyaml</artifactId>
|
||||
<version>1.17</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>junit</groupId>
|
||||
<artifactId>junit</artifactId>
|
||||
<version>4.12</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.apache.ant</groupId>
|
||||
<artifactId>ant</artifactId>
|
||||
<version>1.9.7</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.apache-extras.beanshell</groupId>
|
||||
<artifactId>bsh</artifactId>
|
||||
<version>2.0b6</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>com.google.inject</groupId>
|
||||
<artifactId>guice</artifactId>
|
||||
<version>4.1.0</version>
|
||||
<scope>provided</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>com.google.code.findbugs</groupId>
|
||||
<artifactId>jsr305</artifactId>
|
||||
<version>3.0.1</version>
|
||||
<scope>provided</scope>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
|
||||
<build>
|
||||
<resources>
|
||||
<resource>
|
||||
<directory>src/main/resources</directory>
|
||||
</resource>
|
||||
</resources>
|
||||
<plugins>
|
||||
|
||||
<!-- Generating Javadoc -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-javadoc-plugin</artifactId>
|
||||
<version>2.10.3</version>
|
||||
<configuration>
|
||||
<failOnError>false</failOnError>
|
||||
<excludePackageNames>*internal</excludePackageNames>
|
||||
</configuration>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>attach-javadocs</id>
|
||||
<goals>
|
||||
<goal>jar</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- Bundle sources -->
|
||||
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-source-plugin</artifactId>
|
||||
<version>2.1.1</version>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>attach-sources</id>
|
||||
<goals>
|
||||
<goal>jar</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- Compilation -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-compiler-plugin</artifactId>
|
||||
<version>3.1</version>
|
||||
<configuration>
|
||||
<source>1.7</source>
|
||||
<target>1.7</target>
|
||||
</configuration>
|
||||
</plugin>
|
||||
|
||||
<!-- Resource handling -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-resources-plugin</artifactId>
|
||||
<version>2.4.3</version>
|
||||
<configuration>
|
||||
<encoding>UTF-8</encoding>
|
||||
</configuration>
|
||||
<executions>
|
||||
<execution>
|
||||
<phase>process-sources</phase>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- OSGi manifest creation -->
|
||||
<plugin>
|
||||
<groupId>org.apache.felix</groupId>
|
||||
<artifactId>maven-bundle-plugin</artifactId>
|
||||
<version>2.1.0</version>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>bundle-manifest</id>
|
||||
<phase>process-classes</phase>
|
||||
<goals>
|
||||
<goal>manifest</goal>
|
||||
</goals>
|
||||
<configuration>
|
||||
<instructions>
|
||||
<_versionpolicy>$(@)</_versionpolicy>
|
||||
<Export-Package>com.beust.testng,org.testng*</Export-Package>
|
||||
<Import-Package>
|
||||
com.beust.jcommander.*;version="[1.7.0,3.0.0)",
|
||||
bsh.*;version="[2.0.0,3.0.0)";resolution:=optional,
|
||||
com.google.inject.*;version="[1.2,1.3)";resolution:=optional,
|
||||
junit.framework;version="[3.8.1, 5.0.0)";resolution:=optional,
|
||||
org.junit.*;resolution:=optional,
|
||||
org.apache.tools.ant.*;version="[1.7.0, 2.0.0)";resolution:=optional,
|
||||
org.yaml.*;version="[1.6,2.0)";resolution:=optional,
|
||||
!com.beust.testng,
|
||||
!org.testng.*,
|
||||
!com.sun.*,
|
||||
*
|
||||
</Import-Package>
|
||||
</instructions>
|
||||
</configuration>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- Add OSGi manifest in JAR -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-jar-plugin</artifactId>
|
||||
<version>2.3.1</version>
|
||||
<configuration>
|
||||
<archive>
|
||||
<manifestFile>${project.build.outputDirectory}/META-INF/MANIFEST.MF</manifestFile>
|
||||
</archive>
|
||||
</configuration>
|
||||
</plugin>
|
||||
|
||||
<!-- Tests -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-surefire-plugin</artifactId>
|
||||
<version>2.19</version>
|
||||
<configuration>
|
||||
<suiteXmlFiles>
|
||||
<suiteXmlFile>src/test/resources/testng.xml</suiteXmlFile>
|
||||
</suiteXmlFiles>
|
||||
<properties>
|
||||
<property>
|
||||
<name>listener</name>
|
||||
<value>test.invokedmethodlistener.MyListener</value>
|
||||
</property>
|
||||
</properties>
|
||||
<systemPropertyVariables>
|
||||
<test.resources.dir>${project.build.testOutputDirectory}</test.resources.dir>
|
||||
</systemPropertyVariables>
|
||||
</configuration>
|
||||
</plugin>
|
||||
|
||||
<!-- Signing with gpg -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-gpg-plugin</artifactId>
|
||||
<version>1.4</version>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>sign-artifacts</id>
|
||||
<phase>verify</phase>
|
||||
<goals>
|
||||
<goal>sign</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
</plugins>
|
||||
|
||||
</build>
|
||||
</project>
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (testng-6.14.3.tar.gz) = cec176c1c886b4f8f54021910af4637004854e88f928496acd67b9bc1ea2c78bc86451f37b98269aa56d8ec88b2c0fb75fa5c3cf7ea72e19192f910dd8242cfa
|
283
testng.spec
Normal file
283
testng.spec
Normal file
@ -0,0 +1,283 @@
|
||||
%bcond_with groovy
|
||||
%bcond_without snakeyaml
|
||||
|
||||
Name: testng
|
||||
Version: 6.14.3
|
||||
Release: 13%{?dist}
|
||||
Summary: Java-based testing framework
|
||||
License: ASL 2.0
|
||||
URL: http://testng.org/
|
||||
# ./generate-tarball.sh
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
|
||||
# Allows building with maven instead of gradle
|
||||
Source1: pom.xml
|
||||
|
||||
# Remove bundled binaries to make sure we don't ship anything forbidden
|
||||
Source2: generate-tarball.sh
|
||||
|
||||
Patch0: 0001-Avoid-accidental-javascript-in-javadoc.patch
|
||||
Patch1: 0002-Replace-bundled-jquery-with-CDN-link.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(com.beust:jcommander)
|
||||
BuildRequires: mvn(com.google.inject:guice)
|
||||
BuildRequires: mvn(com.google.code.findbugs:jsr305)
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(org.apache.ant:ant)
|
||||
BuildRequires: mvn(org.apache-extras.beanshell:bsh)
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
%if %{with groovy}
|
||||
BuildRequires: mvn(org.assertj:assertj-core) >= 3.8.0
|
||||
BuildRequires: mvn(org.codehaus.gmavenplus:gmavenplus-plugin)
|
||||
BuildRequires: mvn(org.codehaus.groovy:groovy-all)
|
||||
BuildRequires: mvn(org.spockframework:spock-core)
|
||||
%endif
|
||||
%if %{with snakeyaml}
|
||||
BuildRequires: mvn(org.yaml:snakeyaml)
|
||||
%endif
|
||||
|
||||
%description
|
||||
TestNG is a testing framework inspired from JUnit and NUnit but introducing
|
||||
some new functionality, including flexible test configuration, and
|
||||
distributed test running. It is designed to cover unit tests as well as
|
||||
functional, end-to-end, integration, etc.
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
|
||||
%description javadoc
|
||||
This package contains the API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
cp %{SOURCE1} .
|
||||
|
||||
# remove any bundled libs, but not test resources
|
||||
find ! -path "*/test/*" -name *.jar -print -delete
|
||||
find -name *.class -delete
|
||||
|
||||
# these are unnecessary
|
||||
%pom_remove_plugin :maven-gpg-plugin
|
||||
%pom_remove_plugin :maven-source-plugin
|
||||
%pom_remove_plugin :maven-javadoc-plugin
|
||||
|
||||
%if %{without snakeyaml}
|
||||
%pom_remove_dep org.yaml:snakeyaml
|
||||
rm src/main/java/org/testng/internal/Yaml*.java
|
||||
rm src/main/java/org/testng/Converter.java
|
||||
%endif
|
||||
|
||||
# missing test deps
|
||||
%if %{with groovy}
|
||||
%pom_add_plugin "org.codehaus.gmavenplus:gmavenplus-plugin" pom.xml \
|
||||
"<executions><execution><goals><goal>addTestSources</goal><goal>testGenerateStubs</goal><goal>testCompile</goal><goal>removeTestStubs</goal></goals></execution></executions>"
|
||||
%pom_add_dep "org.assertj:assertj-core::test"
|
||||
%pom_add_dep "org.spockframework:spock-core::test"
|
||||
%pom_add_dep "org.codehaus.groovy:groovy-all::test"
|
||||
|
||||
# java.lang.NoClassDefFoundError: net/sf/cglib/proxy/CallbackFilter when executing tests
|
||||
%pom_add_dep "net.sf.cglib:cglib::test"
|
||||
%endif
|
||||
|
||||
sed -i -e 's/DEV-SNAPSHOT/%{version}/' src/main/java/org/testng/internal/Version.java
|
||||
|
||||
cp -p ./src/main/java/*.dtd.html ./src/main/resources/.
|
||||
|
||||
%mvn_file : %{name}
|
||||
# jdk15 classifier is used by some other packages
|
||||
%mvn_alias : :::jdk15:
|
||||
|
||||
%build
|
||||
%if %{with groovy} && %{with snakeyaml}
|
||||
# A couple of parallelisation tests are *sometimes* failing, so let's ignore failures
|
||||
# because they do complete successfully most of the time
|
||||
%mvn_build -- -Dmaven.test.failure.ignore=true
|
||||
%else
|
||||
%mvn_build -f
|
||||
%endif
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles
|
||||
%doc CHANGES.txt README.md
|
||||
%license LICENSE.txt
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.14.3-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 6.14.3-12
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Wed Feb 19 2020 Fabio Valentini <decathorpe@gmail.com> - 6.14.3-11
|
||||
- Drop unnecessary dependency on parent POM.
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.14.3-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.14.3-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Tue Jul 23 2019 Fabio Valentini <decathorpe@gmail.com> - 6.14.3-8
|
||||
- Disable groovy support by default.
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.14.3-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Dec 13 2018 Mat Booth <mat.booth@redhat.com> - 6.14.3-6
|
||||
- Fix test suite execution
|
||||
|
||||
* Wed Jul 18 2018 Michael Simacek <msimacek@redhat.com> - 6.14.3-5
|
||||
- Clean tarball from binaries
|
||||
- Replace bundled jquery with CDN link
|
||||
|
||||
* Tue Jul 17 2018 Mikolaj Izdebski <mizdebsk@redhat.com> - 6.14.3-4
|
||||
- Allow conditionally building without snakeyaml
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.14.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Tue Mar 20 2018 Alexander Kurtakov <akurtako@redhat.com> 6.14.3-2
|
||||
- Bump maven pom version.
|
||||
|
||||
* Tue Mar 20 2018 Alexander Kurtakov <akurtako@redhat.com> 6.14.3-1
|
||||
- Update to upstream 6.14.3.
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 6.12-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Aug 23 2017 Mat Booth <mat.booth@redhat.com> - 6.12-2
|
||||
- Allow OSGi metadata to export all packages including internal ones
|
||||
|
||||
* Fri Jul 28 2017 Mat Booth <mat.booth@redhat.com> - 6.12-1
|
||||
- Update to latest release of testng
|
||||
- Fixes classloading from ant rhbz#1475842
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 6.11-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Tue Jul 04 2017 Mat Booth <mat.booth@redhat.com> - 6.11-1
|
||||
- Update to latest upstream release
|
||||
- Continue building with maven for now, instead of moving to gradle due to
|
||||
rhbz#1467724
|
||||
|
||||
* Wed May 31 2017 Michael Simacek <msimacek@redhat.com> - 6.9.12-5
|
||||
- Avoid accidental javascript in comment
|
||||
|
||||
* Fri Feb 17 2017 Mat Booth <mat.booth@redhat.com> - 6.9.12-4
|
||||
- License correction
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 6.9.12-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Wed Feb 1 2017 Mikolaj Izdebski <mizdebsk@redhat.com> - 6.9.12-2
|
||||
- Introduce build-conditional to allow building without groovy
|
||||
|
||||
* Tue Nov 01 2016 Mat Booth <mat.booth@redhat.com> - 6.9.12-1
|
||||
- Update to upstream version 6.9.12
|
||||
- Avoid 'SNAPSHOT' in pom version to fix tests in testng-remote package
|
||||
|
||||
* Wed Apr 20 2016 Mikolaj Izdebski <mizdebsk@redhat.com> - 6.9.11-1
|
||||
- Update to upstream version 6.9.11
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 6.9.10-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jan 08 2016 gil cattaneo <puntogil@libero.it> 6.9.10-1
|
||||
- Update to 6.9.10
|
||||
|
||||
* Tue Oct 27 2015 gil cattaneo <puntogil@libero.it> 6.9.9-1
|
||||
- Update to 6.9.9
|
||||
|
||||
* Tue Oct 13 2015 gil cattaneo <puntogil@libero.it> 6.9.8-1
|
||||
- Update to 6.9.8
|
||||
|
||||
* Mon Sep 07 2015 Mat Booth <mat.booth@redhat.com> - 6.9.5-1
|
||||
- Update to 6.9.5
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.8.21-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Jan 20 2015 gil cattaneo <puntogil@libero.it> 6.8.21-1
|
||||
- Update to 6.8.21
|
||||
- introduce license macro
|
||||
|
||||
* Tue Jan 20 2015 gil cattaneo <puntogil@libero.it> 6.8.17-1
|
||||
- Update to 6.8.17
|
||||
|
||||
* Wed Jan 14 2015 gil cattaneo <puntogil@libero.it> 6.8.14-1
|
||||
- Update to 6.8.14
|
||||
|
||||
* Mon Aug 4 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 6.8.8-3
|
||||
- Fix build-requires on sonatype-oss-parent
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.8.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Wed Feb 26 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 6.8.8-1
|
||||
- Update to upstream version 6.8.8
|
||||
|
||||
* Thu Sep 12 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 6.8.7-1
|
||||
- Update to upstream version 6.8.7
|
||||
- Provide additional jdk15 classifier
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.8.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue May 14 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 6.8.5-1
|
||||
- Update to upstream version 6.8.5
|
||||
|
||||
* Sun Feb 10 2013 Mat Booth <fedora@matbooth.co.uk> - 6.8-1
|
||||
- Update to latest upstream release, rhbz #888233
|
||||
|
||||
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 6.0.1-6
|
||||
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||
- Replace maven BuildRequires with maven-local
|
||||
|
||||
* Thu Nov 08 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 6.0.1-5
|
||||
- Part of testng is CPL, add it to license tag
|
||||
|
||||
* Thu Jul 26 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 6.0.1-4
|
||||
- Spec file cleanups and add_maven_depmap macro use
|
||||
- Drop no longer needed depmap
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Thu May 12 2011 Jaromir Capik <jcapik@redhat.com> - 6.0.1-1
|
||||
- Update to 6.0.1
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.11-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Mon Jul 19 2010 Lubomir Rintel <lkundrak@v3.sk> - 5.11-3
|
||||
- Drop backport util concurrent dependency, we don't build jdk14 jar
|
||||
|
||||
* Mon Dec 21 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.11-2
|
||||
- Add POM
|
||||
|
||||
* Sun Dec 20 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.11-1
|
||||
- Bump to 5.11
|
||||
- Add maven depmap fragments
|
||||
- Fix line encoding of README
|
||||
|
||||
* Wed Dec 09 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.10-2
|
||||
- Add javadoc
|
||||
- Don't ship jdk14 jar
|
||||
|
||||
* Fri Nov 27 2009 Lubomir Rintel <lkundrak@v3.sk> - 5.10-1
|
||||
- Initial packaging
|
Loading…
Reference in New Issue
Block a user