Update to upstream version 7.6.1
This commit is contained in:
parent
f9b06b06aa
commit
521d9a4cd9
2
.gitignore
vendored
2
.gitignore
vendored
@ -26,3 +26,5 @@
|
||||
/testng-7.2.0~SNAPSHOT.tar.gz
|
||||
/testng-7.3.0.tar.gz
|
||||
/testng-7.4.0.tar.gz
|
||||
/testng-7.6.1.tar.gz
|
||||
/testng-7.6.1.pom
|
||||
|
@ -4,13 +4,13 @@ Date: Wed, 31 May 2017 13:44:36 +0200
|
||||
Subject: [PATCH 1/2] Avoid accidental javascript in javadoc
|
||||
|
||||
---
|
||||
src/main/java/org/testng/xml/TestNGContentHandler.java | 4 +++-
|
||||
testng-core/src/main/java/org/testng/xml/TestNGContentHandler.java | 4 +++-
|
||||
1 file changed, 3 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/main/java/org/testng/xml/TestNGContentHandler.java b/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
diff --git a/testng-core/src/main/java/org/testng/xml/TestNGContentHandler.java b/testng-core/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
index b74572a..7c490e9 100644
|
||||
--- a/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
+++ b/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
--- a/testng-core/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
+++ b/testng-core/src/main/java/org/testng/xml/TestNGContentHandler.java
|
||||
@@ -250,7 +250,9 @@ public class TestNGContentHandler extends DefaultHandler {
|
||||
}
|
||||
}
|
||||
|
@ -4,32 +4,32 @@ Date: Wed, 18 Jul 2018 15:57:49 +0200
|
||||
Subject: [PATCH 2/2] Replace bundled jquery with CDN link
|
||||
|
||||
---
|
||||
src/main/java/org/testng/reporters/jq/Main.java | 1 -
|
||||
src/main/resources/org/testng/header | 2 +-
|
||||
testng-core/src/main/java/org/testng/reporters/jq/Main.java | 1 -
|
||||
testng-core/src/main/resources/org/testng/header | 2 +-
|
||||
2 files changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/main/java/org/testng/reporters/jq/Main.java b/src/main/java/org/testng/reporters/jq/Main.java
|
||||
diff --git a/testng-core/src/main/java/org/testng/reporters/jq/Main.java b/testng-core/src/main/java/org/testng/reporters/jq/Main.java
|
||||
index efd6799..2d8b74e 100644
|
||||
--- a/src/main/java/org/testng/reporters/jq/Main.java
|
||||
+++ b/src/main/java/org/testng/reporters/jq/Main.java
|
||||
--- a/testng-core/src/main/java/org/testng/reporters/jq/Main.java
|
||||
+++ b/testng-core/src/main/java/org/testng/reporters/jq/Main.java
|
||||
@@ -21,7 +21,6 @@ public class Main implements IReporter {
|
||||
private static final String TESTNG_RESOURCE_PREFIX = "/org/testng/";
|
||||
private static final String[] RESOURCES =
|
||||
new String[] {
|
||||
- "jquery.min.js",
|
||||
- "jquery-3.6.0.min.js",
|
||||
"testng-reports.css",
|
||||
"testng-reports.js",
|
||||
"testng-reports1.css",
|
||||
diff --git a/src/main/resources/org/testng/header b/src/main/resources/org/testng/header
|
||||
diff --git a/testng-core/src/main/resources/org/testng/header b/testng-core/src/main/resources/org/testng/header
|
||||
index f5abbc3..817badc 100644
|
||||
--- a/src/main/resources/org/testng/header
|
||||
+++ b/src/main/resources/org/testng/header
|
||||
--- a/testng-core/src/main/resources/org/testng/header
|
||||
+++ b/testng-core/src/main/resources/org/testng/header
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
<link type="text/css" href="testng-reports1.css" rel="stylesheet" id="ultra" />
|
||||
<link type="text/css" href="testng-reports.css" rel="stylesheet" id="retro" disabled="false"/>
|
||||
- <script type="text/javascript" src="jquery.min.js"></script>
|
||||
+ <script type="text/javascript" src="https://code.jquery.com/jquery-3.5.1.min.js"></script>
|
||||
- <script type="text/javascript" src="jquery-3.6.0.min.js"></script>
|
||||
+ <script type="text/javascript" src="https://code.jquery.com/jquery-3.6.0.min.js"></script>
|
||||
<script type="text/javascript" src="testng-reports.js"></script>
|
||||
<script type="text/javascript" src="https://www.google.com/jsapi"></script>
|
||||
<script type='text/javascript'>
|
||||
|
@ -16,6 +16,7 @@ tar -xf "../${name}-${upstream_version}.orig.tar.gz"
|
||||
# CLEAN TARBALL
|
||||
rm -r */bin*
|
||||
rm -r */gradle*
|
||||
find -name 'jquery-*.min.js' -delete
|
||||
|
||||
tar -czf "../${name}-${version}.tar.gz" *
|
||||
popd
|
||||
|
240
pom.xml
240
pom.xml
@ -1,240 +0,0 @@
|
||||
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
|
||||
|
||||
<!-- Refer to the file ./build-with-maven for instruction on how to use this pom.xml -->
|
||||
|
||||
<modelVersion>4.0.0</modelVersion>
|
||||
<groupId>org.testng</groupId>
|
||||
<artifactId>testng</artifactId>
|
||||
<packaging>jar</packaging>
|
||||
<name>TestNG</name>
|
||||
<version>@VERSION@</version>
|
||||
<description>TestNG is a testing framework.</description>
|
||||
<url>http://testng.org</url>
|
||||
|
||||
<licenses>
|
||||
<license>
|
||||
<name>Apache License, Version 2.0</name>
|
||||
<url>http://apache.org/licenses/LICENSE-2.0</url>
|
||||
<distribution>repo</distribution>
|
||||
</license>
|
||||
</licenses>
|
||||
|
||||
<scm>
|
||||
<connection>scm:git:git@github.com:cbeust/testng.git</connection>
|
||||
<developerConnection>scm:git:git@github.com:cbeust/testng.git</developerConnection>
|
||||
<url>git@github.com:cbeust/testng.git</url>
|
||||
</scm>
|
||||
|
||||
<developers>
|
||||
<developer>
|
||||
<name>Cedric Beust</name>
|
||||
</developer>
|
||||
</developers>
|
||||
|
||||
<distributionManagement>
|
||||
<repository>
|
||||
<id>bintray</id>
|
||||
<url>https://api.bintray.com/maven/cbeust/maven/testng</url>
|
||||
</repository>
|
||||
</distributionManagement>
|
||||
|
||||
<dependencies>
|
||||
<dependency>
|
||||
<groupId>com.beust</groupId>
|
||||
<artifactId>jcommander</artifactId>
|
||||
<version>1.64</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.yaml</groupId>
|
||||
<artifactId>snakeyaml</artifactId>
|
||||
<version>1.17</version>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>junit</groupId>
|
||||
<artifactId>junit</artifactId>
|
||||
<version>4.12</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.apache.ant</groupId>
|
||||
<artifactId>ant</artifactId>
|
||||
<version>1.9.7</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>org.apache-extras.beanshell</groupId>
|
||||
<artifactId>bsh</artifactId>
|
||||
<version>2.0b6</version>
|
||||
<optional>true</optional>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>com.google.inject</groupId>
|
||||
<artifactId>guice</artifactId>
|
||||
<version>4.1.0</version>
|
||||
<scope>provided</scope>
|
||||
</dependency>
|
||||
<dependency>
|
||||
<groupId>com.google.code.findbugs</groupId>
|
||||
<artifactId>jsr305</artifactId>
|
||||
<version>3.0.1</version>
|
||||
<scope>provided</scope>
|
||||
</dependency>
|
||||
</dependencies>
|
||||
|
||||
<build>
|
||||
<resources>
|
||||
<resource>
|
||||
<directory>src/main/resources</directory>
|
||||
</resource>
|
||||
</resources>
|
||||
<plugins>
|
||||
|
||||
<!-- Generating Javadoc -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-javadoc-plugin</artifactId>
|
||||
<version>2.10.3</version>
|
||||
<configuration>
|
||||
<failOnError>false</failOnError>
|
||||
<excludePackageNames>*internal</excludePackageNames>
|
||||
</configuration>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>attach-javadocs</id>
|
||||
<goals>
|
||||
<goal>jar</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- Bundle sources -->
|
||||
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-source-plugin</artifactId>
|
||||
<version>2.1.1</version>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>attach-sources</id>
|
||||
<goals>
|
||||
<goal>jar</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- Compilation -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-compiler-plugin</artifactId>
|
||||
<version>3.1</version>
|
||||
<configuration>
|
||||
<source>1.8</source>
|
||||
<target>1.8</target>
|
||||
</configuration>
|
||||
</plugin>
|
||||
|
||||
<!-- Resource handling -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-resources-plugin</artifactId>
|
||||
<version>2.4.3</version>
|
||||
<configuration>
|
||||
<encoding>UTF-8</encoding>
|
||||
</configuration>
|
||||
<executions>
|
||||
<execution>
|
||||
<phase>process-sources</phase>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- OSGi manifest creation -->
|
||||
<plugin>
|
||||
<groupId>org.apache.felix</groupId>
|
||||
<artifactId>maven-bundle-plugin</artifactId>
|
||||
<version>2.1.0</version>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>bundle-manifest</id>
|
||||
<phase>process-classes</phase>
|
||||
<goals>
|
||||
<goal>manifest</goal>
|
||||
</goals>
|
||||
<configuration>
|
||||
<instructions>
|
||||
<_versionpolicy>$(@)</_versionpolicy>
|
||||
<Export-Package>com.beust.testng,org.testng*</Export-Package>
|
||||
<Import-Package>
|
||||
com.beust.jcommander.*;version="[1.7.0,3.0.0)",
|
||||
bsh.*;version="[2.0.0,3.0.0)";resolution:=optional,
|
||||
com.google.inject.*;version="[1.2,1.3)";resolution:=optional,
|
||||
junit.framework;version="[3.8.1, 5.0.0)";resolution:=optional,
|
||||
org.junit.*;resolution:=optional,
|
||||
org.apache.tools.ant.*;version="[1.7.0, 2.0.0)";resolution:=optional,
|
||||
org.yaml.*;version="[1.6,2.0)";resolution:=optional,
|
||||
!com.beust.testng,
|
||||
!org.testng.*,
|
||||
!com.sun.*,
|
||||
*
|
||||
</Import-Package>
|
||||
</instructions>
|
||||
</configuration>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
<!-- Add OSGi manifest in JAR -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-jar-plugin</artifactId>
|
||||
<version>2.3.1</version>
|
||||
<configuration>
|
||||
<archive>
|
||||
<manifestFile>${project.build.outputDirectory}/META-INF/MANIFEST.MF</manifestFile>
|
||||
</archive>
|
||||
</configuration>
|
||||
</plugin>
|
||||
|
||||
<!-- Tests -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-surefire-plugin</artifactId>
|
||||
<version>2.19</version>
|
||||
<configuration>
|
||||
<suiteXmlFiles>
|
||||
<suiteXmlFile>src/test/resources/testng.xml</suiteXmlFile>
|
||||
</suiteXmlFiles>
|
||||
<properties>
|
||||
<property>
|
||||
<name>listener</name>
|
||||
<value>test.invokedmethodlistener.MyListener</value>
|
||||
</property>
|
||||
</properties>
|
||||
<systemPropertyVariables>
|
||||
<test.resources.dir>${project.build.testOutputDirectory}</test.resources.dir>
|
||||
</systemPropertyVariables>
|
||||
</configuration>
|
||||
</plugin>
|
||||
|
||||
<!-- Signing with gpg -->
|
||||
<plugin>
|
||||
<groupId>org.apache.maven.plugins</groupId>
|
||||
<artifactId>maven-gpg-plugin</artifactId>
|
||||
<version>1.4</version>
|
||||
<executions>
|
||||
<execution>
|
||||
<id>sign-artifacts</id>
|
||||
<phase>verify</phase>
|
||||
<goals>
|
||||
<goal>sign</goal>
|
||||
</goals>
|
||||
</execution>
|
||||
</executions>
|
||||
</plugin>
|
||||
|
||||
</plugins>
|
||||
|
||||
</build>
|
||||
</project>
|
3
sources
3
sources
@ -1 +1,2 @@
|
||||
SHA512 (testng-7.4.0.tar.gz) = 7cb2c47e4169c56f7b65c8213af1b88b516d4f6d84a5e3046c83a543c5124689cc95197cb291856c408784a78a8b7d1aae1fb5c426bd7e61c42504e5f92d65db
|
||||
SHA512 (testng-7.6.1.tar.gz) = ac68ac36ef880aa6c07d50d371a0d2c1281500d78329e5397fa63e62fee097cef4763efa855c536a09dbf46e4753a65823930e5f5ed54c6171b37318c346ae66
|
||||
SHA512 (testng-7.6.1.pom) = f47d9365cc005798c8d748d66d34dd73b11d484e36d555623b0676729b47069aae2dad829deffa8b44b870d3fa5296fa44258edcede1a8062582cecc2926e5a1
|
||||
|
28
testng.spec
28
testng.spec
@ -1,8 +1,8 @@
|
||||
%bcond_with bootstrap
|
||||
|
||||
Name: testng
|
||||
Version: 7.4.0
|
||||
Release: 4%{?dist}
|
||||
Version: 7.6.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Java-based testing framework
|
||||
License: ASL 2.0
|
||||
URL: http://testng.org/
|
||||
@ -11,7 +11,7 @@ URL: http://testng.org/
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
|
||||
# Allows building with maven instead of gradle
|
||||
Source1: pom.xml
|
||||
Source1: https://repo1.maven.org/maven2/org/testng/testng/%{version}/testng-%{version}.pom
|
||||
|
||||
# Remove bundled binaries to make sure we don't ship anything forbidden
|
||||
Source2: generate-tarball.sh
|
||||
@ -49,30 +49,28 @@ This package contains the API documentation for %{name}.
|
||||
%prep
|
||||
%setup -q -n %{name}-%(echo %{version} | tr '~' '-')
|
||||
|
||||
cp %{SOURCE1} pom.xml
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
sed 's/@VERSION@/%{version}/' %{SOURCE1} > pom.xml
|
||||
# Contains differently licensed sources
|
||||
rm -rf testng-test-osgi
|
||||
|
||||
find . -mindepth 2 -name src -type d -exec cp -r -t . {} +
|
||||
|
||||
# remove any bundled libs, but not test resources
|
||||
find ! -path "*/test/*" -name *.jar -print -delete
|
||||
find -name *.class -delete
|
||||
|
||||
# these are unnecessary
|
||||
%pom_remove_plugin :maven-gpg-plugin
|
||||
%pom_remove_plugin :maven-source-plugin
|
||||
%pom_remove_plugin :maven-javadoc-plugin
|
||||
%pom_remove_dep org.webjars:jquery
|
||||
|
||||
%pom_remove_dep org.yaml:snakeyaml
|
||||
rm src/main/java/org/testng/internal/Yaml*.java
|
||||
rm src/main/java/org/testng/Converter.java
|
||||
|
||||
%pom_remove_dep :bsh
|
||||
|
||||
%pom_xpath_inject "pom:dependency[pom:artifactId='guice']" "<classifier>no_aop</classifier>"
|
||||
|
||||
sed -i -e 's/DEV-SNAPSHOT/%{version}/' src/main/java/org/testng/internal/Version.java
|
||||
|
||||
cp -p ./src/main/java/*.dtd.html ./src/main/resources/.
|
||||
|
||||
%mvn_file : %{name}
|
||||
@ -80,7 +78,8 @@ cp -p ./src/main/java/*.dtd.html ./src/main/resources/.
|
||||
%mvn_alias : :::jdk15:
|
||||
|
||||
%build
|
||||
%mvn_build -f
|
||||
# Tests extend a class written in Kotlin
|
||||
%mvn_build -f -- -Dmaven.compiler.source=8 -Dmaven.compiler.target=8
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
@ -93,6 +92,9 @@ cp -p ./src/main/java/*.dtd.html ./src/main/resources/.
|
||||
%license LICENSE.txt
|
||||
|
||||
%changelog
|
||||
* Fri Sep 09 2022 Marian Koncek <mkoncek@redhat.com> - 7.6.1-1
|
||||
- Update to upstream version 7.6.1
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 7.4.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user