diff --git a/.gitignore b/.gitignore
index c49e6bc..5eb362b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -16,3 +16,4 @@
/6.9.11.tar.gz
/6.9.12.tar.gz
/6.11.tar.gz
+/6.12.tar.gz
diff --git a/pom.xml b/pom.xml
index 940931e..22b65ca 100644
--- a/pom.xml
+++ b/pom.xml
@@ -8,7 +8,7 @@
testng
jar
TestNG
- 6.11
+ 6.12
TestNG is a testing framework.
http://testng.org
@@ -80,6 +80,12 @@
4.1.0
provided
+
+ com.google.code.findbugs
+ jsr305
+ 3.0.1
+ provided
+
diff --git a/sources b/sources
index 0570ef3..09eb7a0 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (6.11.tar.gz) = 996d7a18399e16626756b7a790182c7b6bf3453280209d0a09d4a509d698fcad1a80e58ec36702de95bd59c90c237463719ad44934c14390620fc9655d871252
+SHA512 (6.12.tar.gz) = cfbeadef0f21c27060bf5a8b49182562bb3dbfb6c471bef73b9d1b799ea64da69f40dd1c8559436d2884b09892ef483fd98bdf896aa3b528b55d3ada347d329c
diff --git a/testng.spec b/testng.spec
index 0b95332..0ecf6fd 100644
--- a/testng.spec
+++ b/testng.spec
@@ -1,8 +1,8 @@
%bcond_without groovy
Name: testng
-Version: 6.11
-Release: 2%{?dist}
+Version: 6.12
+Release: 1%{?dist}
Summary: Java-based testing framework
License: ASL 2.0
URL: http://testng.org/
@@ -18,6 +18,7 @@ BuildArch: noarch
BuildRequires: maven-local
BuildRequires: mvn(com.beust:jcommander)
BuildRequires: mvn(com.google.inject:guice)
+BuildRequires: mvn(com.google.code.findbugs:jsr305)
BuildRequires: mvn(junit:junit)
BuildRequires: mvn(org.apache.ant:ant)
BuildRequires: mvn(org.apache-extras.beanshell:bsh)
@@ -25,7 +26,7 @@ BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.sonatype.oss:oss-parent:pom:)
BuildRequires: mvn(org.yaml:snakeyaml)
%if %{with groovy}
-BuildRequires: mvn(org.assertj:assertj-core)
+BuildRequires: mvn(org.assertj:assertj-core) >= 3.8.0
BuildRequires: mvn(org.codehaus.gmavenplus:gmavenplus-plugin)
BuildRequires: mvn(org.codehaus.groovy:groovy-all)
BuildRequires: mvn(org.spockframework:spock-core)
@@ -97,6 +98,10 @@ cp -p ./src/main/java/*.dtd.html ./src/main/resources/.
%license LICENSE.txt
%changelog
+* Fri Jul 28 2017 Mat Booth - 6.12-1
+- Update to latest release of testng
+- Fixes classloading from ant rhbz#1475842
+
* Thu Jul 27 2017 Fedora Release Engineering - 6.11-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild