tcsh-6.19.00-015-set-LC_COLLATE-to-C-and-add-HTML-makefile.patch added
> Set LC_COLLATE=C when calling sort for reproducible results. > Add a Makefile for creating the HTML version of the manual page.
This commit is contained in:
parent
155cffaca8
commit
e1f4da490f
@ -0,0 +1,78 @@
|
|||||||
|
From db1c9b4ef9e30ec12a0a3cd15311ddfb208ef57c Mon Sep 17 00:00:00 2001
|
||||||
|
From: kim <kim>
|
||||||
|
Date: Mon, 24 Aug 2015 20:09:04 +0000
|
||||||
|
Subject: [PATCH 1/2] Set LC_COLLATE=C when calling sort for reproducible
|
||||||
|
results.
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile.in | 2 +-
|
||||||
|
Makefile.std | 2 +-
|
||||||
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile.in b/Makefile.in
|
||||||
|
index 6d1f964..1ef8cb7 100644
|
||||||
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
|
@@ -533,7 +533,7 @@ tc.const.h: tc.const.c sh.char.h config.h config_f.h sh.types.h sh.err.h
|
||||||
|
${CPP} $(CPPFLAGS) ${DFLAGS} ${EXTRAFLAGS} -D_h_tc_const\
|
||||||
|
$(srcdir)/tc.const.c | \
|
||||||
|
sed -n -e 's/^\(Char STR[a-zA-Z0-9_]*\) *\[ *\].*/extern \1[];/p' | \
|
||||||
|
- sort >> $@.tmp
|
||||||
|
+ LC_COLLATE=C sort >> $@.tmp
|
||||||
|
@echo '#endif /* _h_tc_const */' >> $@.tmp
|
||||||
|
@if [ -f $@ ] && cmp -s $@.tmp $@; then echo $@ unchanged.; rm -f $@.tmp; else mv -f $@.tmp $@; echo $@ recreated.; fi
|
||||||
|
|
||||||
|
diff --git a/Makefile.std b/Makefile.std
|
||||||
|
index 2cbc1b1..5d2e89f 100644
|
||||||
|
--- a/Makefile.std
|
||||||
|
+++ b/Makefile.std
|
||||||
|
@@ -425,7 +425,7 @@ tc.const.h: tc.const.c sh.char.h config.h config_f.h sh.types.h sh.err.h
|
||||||
|
${CPP} $(INCLUDES) ${DFLAGS} ${EXTRAFLAGS} -D_h_tc_const\
|
||||||
|
$(srcdir)/tc.const.c | grep 'Char STR' | \
|
||||||
|
sed -e 's/Char \([a-zA-Z0-9_]*\) *\[ *\].*/extern Char \1[];/' | \
|
||||||
|
- sort >> $@
|
||||||
|
+ LC_COLLATE=C sort >> $@
|
||||||
|
@echo '#endif /* _h_tc_const */' >> $@
|
||||||
|
|
||||||
|
csh.prof: ${OBJS} sh.prof.${SUF} mcrt0.${SUF}
|
||||||
|
--
|
||||||
|
2.5.5
|
||||||
|
|
||||||
|
|
||||||
|
From 52fb6c229feea0ccaa3002b4d2b681e60922a4df Mon Sep 17 00:00:00 2001
|
||||||
|
From: kim <kim>
|
||||||
|
Date: Wed, 26 Aug 2015 09:50:31 +0000
|
||||||
|
Subject: [PATCH 2/2] Add a Makefile for creating the HTML version of the
|
||||||
|
manual page.
|
||||||
|
|
||||||
|
---
|
||||||
|
Makefile.man2html | 17 +++++++++++++++++
|
||||||
|
1 file changed, 17 insertions(+)
|
||||||
|
create mode 100644 Makefile.man2html
|
||||||
|
|
||||||
|
diff --git a/Makefile.man2html b/Makefile.man2html
|
||||||
|
new file mode 100644
|
||||||
|
index 0000000..a1bd86a
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/Makefile.man2html
|
||||||
|
@@ -0,0 +1,17 @@
|
||||||
|
+#
|
||||||
|
+# Create the HTML version of the manual page
|
||||||
|
+#
|
||||||
|
+
|
||||||
|
+CGI=tcsh.html/tcsh.cgi
|
||||||
|
+
|
||||||
|
+tcsh.html/top.html: tcsh.man tcsh.man2html
|
||||||
|
+ perl tcsh.man2html -i
|
||||||
|
+ -rm -f tcsh.html/index.html
|
||||||
|
+ chmod -R a+rX tcsh.html
|
||||||
|
+ mv ${CGI} ${CGI}.bak
|
||||||
|
+ sed -e '1s,^.*$$,#!/usr/bin/perl,' < ${CGI}.bak > ${CGI}
|
||||||
|
+ chmod a+rx ${CGI}
|
||||||
|
+ rm -f ${CGI}.bak
|
||||||
|
+
|
||||||
|
+clean:
|
||||||
|
+ -rm -rf tcsh.html
|
||||||
|
--
|
||||||
|
2.5.5
|
||||||
|
|
@ -43,6 +43,7 @@ Patch011: tcsh-6.19.00-011-man-page-spelling-fixes.patch
|
|||||||
Patch012: tcsh-6.19.00-012-display-default-in-editor.patch
|
Patch012: tcsh-6.19.00-012-display-default-in-editor.patch
|
||||||
Patch013: tcsh-6.19.00-013-VImode-variable-provided.patch
|
Patch013: tcsh-6.19.00-013-VImode-variable-provided.patch
|
||||||
Patch014: tcsh-6.19.00-014-do-not-use-union-wait.patch
|
Patch014: tcsh-6.19.00-014-do-not-use-union-wait.patch
|
||||||
|
Patch015: tcsh-6.19.00-015-set-LC_COLLATE-to-C-and-add-HTML-makefile.patch
|
||||||
|
|
||||||
|
|
||||||
# Downstream patches -- these should be always included when doing rebase:
|
# Downstream patches -- these should be always included when doing rebase:
|
||||||
@ -178,6 +179,7 @@ fi
|
|||||||
tcsh-6.19.00-012-display-default-in-editor.patch
|
tcsh-6.19.00-012-display-default-in-editor.patch
|
||||||
tcsh-6.19.00-013-VImode-variable-provided.patch
|
tcsh-6.19.00-013-VImode-variable-provided.patch
|
||||||
tcsh-6.19.00-014-do-not-use-union-wait.patch
|
tcsh-6.19.00-014-do-not-use-union-wait.patch
|
||||||
|
tcsh-6.19.00-015-set-LC_COLLATE-to-C-and-add-HTML-makefile.patch
|
||||||
|
|
||||||
* Thu Apr 21 2016 David Kaspar [Dee'Kej] <dkaspar@redhat.com> - 6.19.00-6
|
* Thu Apr 21 2016 David Kaspar [Dee'Kej] <dkaspar@redhat.com> - 6.19.00-6
|
||||||
- Drop tcsh-6.15.00-closem.patch - issue not reproducible, patch not accepted by upstream
|
- Drop tcsh-6.15.00-closem.patch - issue not reproducible, patch not accepted by upstream
|
||||||
|
Loading…
Reference in New Issue
Block a user