- Modify verbose patch to match with upstream (don't print on history -S)
Resolves: #672810
This commit is contained in:
parent
03c261a07b
commit
66d60fc038
@ -1,26 +0,0 @@
|
|||||||
commit 888f217aba727063885356099ae4a726c60934d0
|
|
||||||
Author: Jeffrey Bastian <jbastian@redhat.com>
|
|
||||||
Date: Wed May 5 17:55:17 2010 -0500
|
|
||||||
|
|
||||||
Don't print the history if in verbose mode
|
|
||||||
|
|
||||||
Author: Vojtech Vitek (V-Teq) <vvitek@redhat.com>
|
|
||||||
Date: Wed Jan 26 15:28:17 2011 +0100
|
|
||||||
|
|
||||||
- Add if statement to fix error message on exit
|
|
||||||
"verbose: Undefined variable."
|
|
||||||
|
|
||||||
diff --git a/sh.c b/sh.c
|
|
||||||
index 178b972..0caa51b 100644
|
|
||||||
--- a/sh.c
|
|
||||||
+++ b/sh.c
|
|
||||||
@@ -1378,6 +1378,9 @@ main(argc, argv)
|
|
||||||
xprintf("exit\n");
|
|
||||||
}
|
|
||||||
}
|
|
||||||
+ /* Don't print the history file to the terminal */
|
|
||||||
+ if (adrof1(STRverbose, &shvhed) != 0)
|
|
||||||
+ unsetv(STRverbose);
|
|
||||||
record();
|
|
||||||
exitstat();
|
|
||||||
return (0);
|
|
23
tcsh-6.17.00-dont-print-history-on-verbose.patch
Normal file
23
tcsh-6.17.00-dont-print-history-on-verbose.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -u -p -r3.40 -r3.41
|
||||||
|
--- tcsh-6.17.00/sh.hist.c 1 Mar 2007 17:14:51 -0000 3.40
|
||||||
|
+++ tcsh-6.17.00/sh.hist.c 6 May 2010 14:16:24 -0000 3.41
|
||||||
|
@@ -422,8 +422,18 @@ rechist(Char *fname, int ref)
|
||||||
|
oldidfds = didfds;
|
||||||
|
didfds = 0;
|
||||||
|
if ((shist = adrof(STRsavehist)) != NULL && shist->vec != NULL)
|
||||||
|
- if (shist->vec[1] && eq(shist->vec[1], STRmerge))
|
||||||
|
+ if (shist->vec[1] && eq(shist->vec[1], STRmerge)) {
|
||||||
|
+ /*
|
||||||
|
+ * Unset verbose while we read the history file. From:
|
||||||
|
+ * jbastian@redhat.com (Jeffrey Bastian)
|
||||||
|
+ */
|
||||||
|
+ Char *verb = varval(STRverbose);
|
||||||
|
+ if (verb != STRNULL)
|
||||||
|
+ unsetv(STRverbose);
|
||||||
|
loadhist(fname, 1);
|
||||||
|
+ if (verb != STRNULL)
|
||||||
|
+ setv(STRverbose, verb, VAR_READWRITE);
|
||||||
|
+ }
|
||||||
|
fp = xcreat(short2str(fname), 0600);
|
||||||
|
if (fp == -1) {
|
||||||
|
didfds = oldidfds;
|
12
tcsh.spec
12
tcsh.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: An enhanced version of csh, the C shell
|
Summary: An enhanced version of csh, the C shell
|
||||||
Name: tcsh
|
Name: tcsh
|
||||||
Version: 6.17
|
Version: 6.17
|
||||||
Release: 12%{?dist}
|
Release: 13%{?dist}
|
||||||
License: BSD
|
License: BSD
|
||||||
Group: System Environment/Shells
|
Group: System Environment/Shells
|
||||||
Source: ftp://ftp.astron.com/pub/tcsh/%{name}-%{version}.00.tar.gz
|
Source: ftp://ftp.astron.com/pub/tcsh/%{name}-%{version}.00.tar.gz
|
||||||
@ -28,12 +28,12 @@ Patch16: tcsh-6.17.00-printexitvalue.patch
|
|||||||
Patch17: tcsh-6.17.00-testsuite.patch
|
Patch17: tcsh-6.17.00-testsuite.patch
|
||||||
# Accepted by upstream:
|
# Accepted by upstream:
|
||||||
Patch18: tcsh-6.17.00-extrafork.patch
|
Patch18: tcsh-6.17.00-extrafork.patch
|
||||||
# Proposed to upstream (http://bugs.gw.com/view.php?id=109):
|
# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=109):
|
||||||
Patch19: tcsh-6.17.00-wait-intr.patch
|
Patch19: tcsh-6.17.00-wait-intr.patch
|
||||||
# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=112):
|
# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=112):
|
||||||
Patch21: tcsh-6.17.00-dont-set-empty-remotehost.patch
|
Patch21: tcsh-6.17.00-dont-set-empty-remotehost.patch
|
||||||
# Proposed to upstream (http://mx.gw.com/pipermail/tcsh-bugs/2010-May/000673.html):
|
# Patch by upstream (tcsh-6.17.01b http://mx.gw.com/pipermail/tcsh-bugs/2010-May/000673.html):
|
||||||
Patch22: tcsh-6.14.00-dont-print-history-on-verbose.patch
|
Patch22: tcsh-6.17.00-dont-print-history-on-verbose.patch
|
||||||
# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=113):
|
# Accepted by upstream (tcsh-6.17.03b http://bugs.gw.com/view.php?id=113):
|
||||||
Patch23: tcsh-6.17.00-variable-names.patch
|
Patch23: tcsh-6.17.00-variable-names.patch
|
||||||
Provides: csh = %{version}
|
Provides: csh = %{version}
|
||||||
@ -146,6 +146,10 @@ fi
|
|||||||
%{_mandir}/man1/*.1*
|
%{_mandir}/man1/*.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 28 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-13
|
||||||
|
- Modify verbose patch to match with upstream (don't print on history -S)
|
||||||
|
Resolves: #672810
|
||||||
|
|
||||||
* Wed Jan 26 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-12
|
* Wed Jan 26 2011 Vojtech Vitek (V-Teq) <vvitek@redhat.com> - 6.17-12
|
||||||
- Fix error message on exit
|
- Fix error message on exit
|
||||||
Resolves: #672810
|
Resolves: #672810
|
||||||
|
Loading…
Reference in New Issue
Block a user