- Update to tcsh-6.14.00

This commit is contained in:
Miloslav Trmac 2005-03-25 23:26:17 +00:00
parent 482603a0ff
commit 5dd9b97eba
6 changed files with 65 additions and 33 deletions

View File

@ -1 +1 @@
tcsh-6.13.00.tar.gz tcsh-6.14.00.tar.gz

View File

@ -1 +1 @@
11c0c9c9148652dc01270c4880d1cc6e tcsh-6.13.00.tar.gz 353d1bb7d2741bf8de602c7b6f0efd79 tcsh-6.14.00.tar.gz

29
tcsh-6.14.00-closem.patch Normal file
View File

@ -0,0 +1,29 @@
Index: tcsh/sh.misc.c
===================================================================
--- tcsh.orig/sh.misc.c 2005-01-05 17:06:14.000000000 +0100
+++ tcsh/sh.misc.c 2005-01-09 16:47:41.068433880 +0100
@@ -251,6 +251,7 @@
closem()
{
int f;
+ struct stat st;
#ifdef NLS_BUGS
#ifdef NLS_CATALOGS
@@ -267,6 +268,16 @@
#ifdef MALLOC_TRACE
&& f != 25
#endif /* MALLOC_TRACE */
+#ifdef S_ISSOCK
+ /* NSS modules (e.g. Linux nss_ldap) might keep sockets open.
+ * If we close such a socket, both the NSS module and tcsh think
+ * they "own" the descriptor.
+ *
+ * Not closing sockets does not make the cleanup use of closem()
+ * less reliable because tcsh never creates sockets.
+ */
+ && fstat(f, &st) == 0 && !S_ISSOCK(st.st_mode)
+#endif
)
{
(void) close(f);

11
tcsh-6.14.00-config.patch Normal file
View File

@ -0,0 +1,11 @@
--- tcsh-6.14.00/config_f.h.config 2005-03-26 00:12:39.756467744 +0100
+++ tcsh-6.14.00/config_f.h 2005-03-26 00:12:49.831936040 +0100
@@ -69,7 +69,7 @@
* if you don't have <nl_types.h>, you don't want
* to define this.
*/
-#undef NLS_CATALOGS
+#define NLS_CATALOGS
/*
* LOGINFIRST Source ~/.login before ~/.cshrc

12
tcsh-6.14.00-iconv.patch Normal file
View File

@ -0,0 +1,12 @@
diff -urN tcsh-6.13.00/nls/Makefile tcsh/nls/Makefile
--- tcsh-6.13.00/nls/Makefile 2004-02-21 21:34:26.000000000 +0100
+++ tcsh/nls/Makefile 2004-07-16 19:09:58.000000000 +0200
@@ -2,7 +2,7 @@
SUBDIRS= C et finnish french german greek italian ja pl russian \
spanish ukrainian
#GENCAT= gencat --new
-#CHARSET= charset
+CHARSET= charset
GENCAT= gencat
catalogs:

View File

@ -2,25 +2,14 @@
Summary: An enhanced version of csh, the C shell. Summary: An enhanced version of csh, the C shell.
Name: tcsh Name: tcsh
Version: 6.13 Version: 6.14
Release: 13 Release: 1
License: distributable License: distributable
Group: System Environment/Shells Group: System Environment/Shells
Source: ftp://ftp.astron.com/pub/tcsh/tcsh-%{version}.00.tar.gz Source: ftp://ftp.astron.com/pub/tcsh/tcsh-%{version}.00.tar.gz
Patch0: tcsh-6.13.00-utmp.patch Patch0: tcsh-6.14.00-config.patch
Patch1: tcsh-6.13.00-dspmbyte.patch Patch1: tcsh-6.14.00-closem.patch
Patch2: tcsh-6.11.00-termcap.patch Patch2: tcsh-6.14.00-iconv.patch
Patch3: tcsh-6.12.00-setpgrp.patch
Patch4: tcsh-6.13.00-charset.patch
Patch5: tcsh-6.13.00-iconv.patch
Patch6: tcsh-6.13.00-glob.patch
Patch7: tcsh-6.13.00-arch.patch
Patch8: tcsh-6.13.00-fcntl.patch
Patch9: tcsh-6.13.00-winchg.patch
Patch10: tcsh-6.13.00-codeset.patch
Patch11: tcsh-6.13.00-closem.patch
Patch12: tcsh-6.13.00-cstr.patch
Patch13: tcsh-6.13.00-cgets.patch
Provides: csh = %{version} Provides: csh = %{version}
Prereq: fileutils, grep Prereq: fileutils, grep
URL: http://www.tcsh.org/ URL: http://www.tcsh.org/
@ -37,23 +26,11 @@ like syntax.
%prep %prep
%setup -q -n %{name}-%{version}.00 %setup -q -n %{name}-%{version}.00
%patch0 -p1 -b .utmp %patch0 -p1 -b .config
%patch1 -p1 -b .mbyte %patch1 -p1 -b .closem
%patch2 -p1 -b .termcap %patch2 -p1 -b .iconv
%patch3 -p1 -b .setpgrp
%patch4 -p1 -b .charset
%patch5 -p1 -b .iconv
%patch6 -p1 -b .glob
%patch7 -p1 -b .arch
%patch8 -p1 -b .fcntl
%patch9 -p1 -b .winchg
%patch10 -p1 -b .codeset
%patch11 -p1 -b .closem
%patch12 -p1 -b .cstr
%patch13 -p1 -b .cgets
nroff -me eight-bit.me > eight-bit.txt nroff -me eight-bit.me > eight-bit.txt
autoreconf
%build %build
%configure --without-hesiod %configure --without-hesiod
@ -119,6 +96,9 @@ fi
%{_mandir}/*/* %{_mandir}/*/*
%changelog %changelog
* Fri Mar 25 2005 Miloslav Trmac <mitr@redhat.com> - 6.14-1
- Update to tcsh-6.14.00
* Sat Mar 5 2005 Miloslav Trmac <mitr@redhat.com> - 6.13-13 * Sat Mar 5 2005 Miloslav Trmac <mitr@redhat.com> - 6.13-13
- Rebuild with gcc 4 - Rebuild with gcc 4