Rediffed all patches to work with patch --fuzz=0
This commit is contained in:
parent
84183ded32
commit
5b0f4da405
@ -1,6 +1,7 @@
|
||||
--- tcsh-6.14.00/configure.in.ncurses 2006-11-30 15:51:16.000000000 +0100
|
||||
+++ tcsh-6.14.00/configure.in 2006-11-30 15:51:30.000000000 +0100
|
||||
@@ -257,7 +257,7 @@
|
||||
diff -up tcsh-6.15.00/configure.in.tinfo tcsh-6.15.00/configure.in
|
||||
--- tcsh-6.15.00/configure.in.tinfo 2007-03-03 21:01:26.000000000 +0100
|
||||
+++ tcsh-6.15.00/configure.in 2008-08-29 12:27:47.000000000 +0200
|
||||
@@ -263,7 +263,7 @@ fi
|
||||
dnl Checks for libraries
|
||||
AC_SEARCH_LIBS(crypt, crypt)
|
||||
AC_SEARCH_LIBS(getspnam, sec)
|
||||
@ -8,4 +9,4 @@
|
||||
+AC_SEARCH_LIBS(tgetent, tinfo)
|
||||
AC_SEARCH_LIBS(gethostbyname, nsl)
|
||||
AC_SEARCH_LIBS(connect, socket)
|
||||
AC_SEARCH_LIBS([iconv], [iconv], [AC_DEFINE([HAVE_ICONV], [1],
|
||||
AM_ICONV
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- tcsh-6.14.00/tw.parse.c.old 2007-04-24 16:46:32.000000000 +0200
|
||||
+++ tcsh-6.14.00/tw.parse.c 2007-04-24 17:02:28.000000000 +0200
|
||||
@@ -2065,7 +2065,8 @@
|
||||
diff -up tcsh-6.15.00/tw.parse.c.unprintable tcsh-6.15.00/tw.parse.c
|
||||
--- tcsh-6.15.00/tw.parse.c.unprintable 2007-03-01 22:21:42.000000000 +0100
|
||||
+++ tcsh-6.15.00/tw.parse.c 2008-08-29 12:28:56.000000000 +0200
|
||||
@@ -2119,7 +2119,8 @@ print_by_column(Char *dir, Char *items[]
|
||||
(Strchr(val, 'x') != NULL);
|
||||
|
||||
for (i = 0; i < count; i++) { /* find widest string */
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -ruN tcsh-6.15.00.orig/tw.color.c tcsh-6.15.00/tw.color.c
|
||||
--- tcsh-6.15.00.orig/tw.color.c 2006-03-02 19:46:45.000000000 +0100
|
||||
+++ tcsh-6.15.00/tw.color.c 2008-07-31 14:10:34.000000000 +0200
|
||||
@@ -85,6 +85,7 @@
|
||||
diff -up tcsh-6.15.00/tw.color.c.ca-color tcsh-6.15.00/tw.color.c
|
||||
--- tcsh-6.15.00/tw.color.c.ca-color 2006-03-02 19:46:45.000000000 +0100
|
||||
+++ tcsh-6.15.00/tw.color.c 2008-08-29 12:37:53.000000000 +0200
|
||||
@@ -85,6 +85,7 @@ static Variable variables[] = {
|
||||
VAR(NOS, "tw", ""), /* Sticky and other writable dir (+t,o+w) */
|
||||
VAR(NOS, "ow", ""), /* Other writable dir (o+w) but not sticky */
|
||||
VAR(NOS, "st", ""), /* Sticky dir (+t) but not other writable */
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- tcsh-6.15.00/sh.misc.c_old 2006-10-14 19:57:21.000000000 +0200
|
||||
+++ tcsh-6.15.00/sh.misc.c 2007-08-27 15:55:20.000000000 +0200
|
||||
@@ -255,6 +255,7 @@
|
||||
diff -up tcsh-6.15.00/sh.misc.c.closem tcsh-6.15.00/sh.misc.c
|
||||
--- tcsh-6.15.00/sh.misc.c.closem 2006-10-14 19:57:21.000000000 +0200
|
||||
+++ tcsh-6.15.00/sh.misc.c 2008-08-29 12:26:41.000000000 +0200
|
||||
@@ -255,6 +255,7 @@ void
|
||||
closem(void)
|
||||
{
|
||||
int f, num_files;
|
||||
@ -8,7 +9,7 @@
|
||||
|
||||
#ifdef NLS_BUGS
|
||||
#ifdef NLS_CATALOGS
|
||||
@@ -272,6 +273,16 @@
|
||||
@@ -272,6 +273,16 @@ closem(void)
|
||||
#ifdef MALLOC_TRACE
|
||||
&& f != 25
|
||||
#endif /* MALLOC_TRACE */
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff --git a/tcsh.man b/tcsh.man
|
||||
index 0c9c3b6..3e389f4 100644
|
||||
--- a/tcsh.man
|
||||
+++ b/tcsh.man
|
||||
diff -up tcsh-6.15.00/tcsh.man.hist-sub tcsh-6.15.00/tcsh.man
|
||||
--- tcsh-6.15.00/tcsh.man.hist-sub 2007-03-03 21:01:26.000000000 +0100
|
||||
+++ tcsh-6.15.00/tcsh.man 2008-08-29 12:29:47.000000000 +0200
|
||||
@@ -1035,7 +1035,7 @@ Substitute \fIl\fR for \fIr\fR.
|
||||
\fIl\fR is simply a string like \fIr\fR, not a regular expression as in
|
||||
the eponymous \fIed\fR(1) command.
|
||||
|
@ -1,7 +1,6 @@
|
||||
diff --git a/sh.dol.c b/sh.dol.c
|
||||
index 73ac3b2..0e7c87d 100755
|
||||
--- a/sh.dol.c
|
||||
+++ b/sh.dol.c
|
||||
diff -up tcsh-6.15.00/sh.dol.c.var-sub tcsh-6.15.00/sh.dol.c
|
||||
--- tcsh-6.15.00/sh.dol.c.var-sub 2006-09-14 20:30:16.000000000 +0200
|
||||
+++ tcsh-6.15.00/sh.dol.c 2008-08-29 12:37:18.000000000 +0200
|
||||
@@ -613,7 +613,7 @@ Dgetdol(void)
|
||||
|
||||
for (i = 0; Isdigit(*np); i = i * 10 + *np++ - '0')
|
||||
|
Loading…
Reference in New Issue
Block a user