Update to tcsh-6.17.00
This commit is contained in:
parent
f8b2e8b2e6
commit
4dfb4bc7a2
@ -1,3 +1,4 @@
|
||||
tcsh-6.14.00.tar.gz
|
||||
tcsh-6.15.00.tar.gz
|
||||
tcsh-6.16.00.tar.gz
|
||||
tcsh-6.17.00.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
55f1a41512250168ec4bf1db0e246db4 tcsh-6.16.00.tar.gz
|
||||
c47de903e3d52f6824c8dd0c91eeb477 tcsh-6.17.00.tar.gz
|
||||
|
@ -1,16 +1,16 @@
|
||||
diff -up tcsh-6.15.00/sh.func.c.syntax tcsh-6.15.00/sh.func.c
|
||||
--- tcsh-6.15.00/sh.func.c.syntax 2006-08-24 22:56:31.000000000 +0200
|
||||
+++ tcsh-6.15.00/sh.func.c 2008-09-03 11:53:05.000000000 +0200
|
||||
@@ -751,8 +751,6 @@ search(int type, int level, Char *goal)
|
||||
diff -up tcsh-6.17.00/sh.func.c_old tcsh-6.17.00/sh.func.c
|
||||
--- tcsh-6.17.00/sh.func.c_old 2009-07-20 14:54:16.000000000 +0200
|
||||
+++ tcsh-6.17.00/sh.func.c 2009-07-20 14:55:34.000000000 +0200
|
||||
@@ -753,8 +753,6 @@ search(int type, int level, Char *goal)
|
||||
{
|
||||
struct Strbuf word = Strbuf_INIT;
|
||||
Char *cp;
|
||||
- struct whyle *wp;
|
||||
- int wlevel = 0;
|
||||
struct wordent *histent = NULL, *ohistent = NULL;
|
||||
|
||||
Stype = type;
|
||||
Sgoal = goal;
|
||||
@@ -791,24 +789,13 @@ search(int type, int level, Char *goal)
|
||||
@@ -811,24 +809,13 @@ search(int type, int level, Char *goal)
|
||||
|
||||
case TC_FOREACH:
|
||||
case TC_WHILE:
|
||||
|
@ -1,10 +1,10 @@
|
||||
diff -up tcsh-6.15.00/tw.color.c.ca-color tcsh-6.15.00/tw.color.c
|
||||
--- tcsh-6.15.00/tw.color.c.ca-color 2006-03-02 19:46:45.000000000 +0100
|
||||
+++ tcsh-6.15.00/tw.color.c 2008-08-29 12:37:53.000000000 +0200
|
||||
@@ -85,6 +85,7 @@ static Variable variables[] = {
|
||||
VAR(NOS, "tw", ""), /* Sticky and other writable dir (+t,o+w) */
|
||||
diff -up tcsh-6.17.00/tw.color.c_old tcsh-6.17.00/tw.color.c
|
||||
--- tcsh-6.17.00/tw.color.c_old 2009-07-20 14:35:59.000000000 +0200
|
||||
+++ tcsh-6.17.00/tw.color.c 2009-07-20 14:36:54.000000000 +0200
|
||||
@@ -86,6 +86,7 @@ static Variable variables[] = {
|
||||
VAR(NOS, "ow", ""), /* Other writable dir (o+w) but not sticky */
|
||||
VAR(NOS, "st", ""), /* Sticky dir (+t) but not other writable */
|
||||
VAR(NOS, "rs", "0"), /* Reset to normal color */
|
||||
+ VAR(NOS, "ca", ""), /* file with capability */
|
||||
};
|
||||
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- tcsh-6.15.00/tw.color.c.rs 2009-02-27 16:03:44.000000000 -0500
|
||||
+++ tcsh-6.15.00/tw.color.c 2009-02-27 16:05:57.000000000 -0500
|
||||
@@ -86,6 +86,8 @@ static Variable variables[] = {
|
||||
VAR(NOS, "ow", ""), /* Other writable dir (o+w) but not sticky */
|
||||
diff -up tcsh-6.17.00/tw.color.c_old tcsh-6.17.00/tw.color.c
|
||||
--- tcsh-6.17.00/tw.color.c_old 2009-07-20 15:14:22.000000000 +0200
|
||||
+++ tcsh-6.17.00/tw.color.c 2009-07-20 15:15:26.000000000 +0200
|
||||
@@ -87,6 +87,7 @@ static Variable variables[] = {
|
||||
VAR(NOS, "st", ""), /* Sticky dir (+t) but not other writable */
|
||||
VAR(NOS, "rs", "0"), /* Reset to normal color */
|
||||
VAR(NOS, "ca", ""), /* file with capability */
|
||||
+ VAR(NOS, "rs", ""), /* RESET */
|
||||
+ VAR(NOS, "hl", ""), /* Hardlink */
|
||||
};
|
||||
|
||||
|
@ -1,28 +0,0 @@
|
||||
diff -up tcsh-6.15.00/tc.str.c_old tcsh-6.15.00/tc.str.c
|
||||
--- tcsh-6.15.00/tc.str.c_old 2008-09-03 13:08:44.000000000 +0200
|
||||
+++ tcsh-6.15.00/tc.str.c 2008-09-03 13:11:32.000000000 +0200
|
||||
@@ -154,7 +154,7 @@ short2str(const Char *src)
|
||||
{
|
||||
static char *sdst = NULL;
|
||||
static size_t dstsize = 0;
|
||||
- char *dst, *edst;
|
||||
+ char *dst, *edst, *wdst, *wedst;
|
||||
|
||||
if (src == NULL)
|
||||
return (NULL);
|
||||
@@ -171,8 +171,15 @@ short2str(const Char *src)
|
||||
if (dst >= edst) {
|
||||
dstsize += MALLOC_INCR;
|
||||
sdst = xrealloc(sdst, (dstsize + MALLOC_SURPLUS) * sizeof(char));
|
||||
+ wdst = dst;
|
||||
+ wedst = edst;
|
||||
edst = &sdst[dstsize];
|
||||
dst = &edst[-MALLOC_INCR];
|
||||
+ while (wdst > wedst) {
|
||||
+ dst++;
|
||||
+ wdst--;
|
||||
+ }
|
||||
+
|
||||
}
|
||||
}
|
||||
*dst = 0;
|
11
tcsh.spec
11
tcsh.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Summary: An enhanced version of csh, the C shell
|
||||
Name: tcsh
|
||||
Version: 6.16
|
||||
Version: 6.17
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: System Environment/Shells
|
||||
@ -16,8 +16,7 @@ Patch7: tcsh-6.14.00-set.patch
|
||||
Patch8: tcsh-6.14.00-syntax.patch
|
||||
Patch9: tcsh-6.13.00-memoryuse.patch
|
||||
Patch11: tcsh-6.14.00-order.patch
|
||||
Patch12: tcsh-6.15.00-wide-str.patch
|
||||
Patch13: tcsh-6.15.00-rs-color.patch
|
||||
Patch12: tcsh-6.15.00-rs-color.patch
|
||||
Provides: csh = %{version}
|
||||
Requires(post): grep
|
||||
Requires(postun): coreutils, grep
|
||||
@ -44,8 +43,7 @@ like syntax.
|
||||
%patch8 -p1 -b .syntax
|
||||
%patch9 -p1 -b .memoryuse
|
||||
%patch11 -p1 -b .order
|
||||
%patch12 -p1 -b .wide-str
|
||||
%patch13 -p1 -b .rs-color
|
||||
%patch12 -p1 -b .rs-color
|
||||
|
||||
for i in Fixes WishList; do
|
||||
iconv -f iso-8859-1 -t utf-8 "$i" > "${i}_" && \
|
||||
@ -119,6 +117,9 @@ fi
|
||||
%{_mandir}/man1/*.1*
|
||||
|
||||
%changelog
|
||||
* Mon Jul 20 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.17-1
|
||||
- Update to tcsh-6.17.00
|
||||
|
||||
* Thu Apr 30 2009 Vitezslav Crhonek <vcrhonek@redhat.com> - 6.16-1
|
||||
- Update to tcsh-6.16.00
|
||||
- Merge Review (fix License, add BUGS and WishList to documentation, convert Fixes and
|
||||
|
Loading…
Reference in New Issue
Block a user