Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/tcsh.git#4feabb13f2d5891936f707c56393556b21e9ba2c
This commit is contained in:
parent
d6ca4b35c4
commit
33593f6b1b
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ tcsh-6.17.00.tar.gz
|
||||
/tcsh-TCSH6_22_00.tar.gz
|
||||
/tcsh-6.22.00.tar.gz
|
||||
/tcsh-6.22.02.tar.gz
|
||||
/tcsh-6.22.03.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tcsh-6.22.02.tar.gz) = 32d271b568c63265ea4c98494f5e60b37c3a3fc2594e8763b8f6f0b09018ab9db7ef6f951120b37f7880ccf04ba3a2559e30dc08d24f4ba9dc36853238d55980
|
||||
SHA512 (tcsh-6.22.03.tar.gz) = 348ab3706ad334133f211251458b40e9e68816ae0b505aba9091589b77ddb10a444fea6662844f6366fa6026a71fac5e7f3c4bbc7ff972bce7f5a8d19612f390
|
||||
|
@ -1,47 +0,0 @@
|
||||
From 7d25c5d5ad5e9c0cd17a21f73aeb2374a29ecd83 Mon Sep 17 00:00:00 2001
|
||||
From: zoulasc <christos@zoulas.com>
|
||||
Date: Fri, 31 Jul 2020 14:30:40 -0400
|
||||
Subject: [PATCH] Switch to stderror() when parsing history so that we stop
|
||||
processing immediately (Jan Macku)
|
||||
|
||||
---
|
||||
sh.lex.c | 9 +++------
|
||||
1 file changed, 3 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/sh.lex.c b/sh.lex.c
|
||||
index ecab059..d83ffa0 100644
|
||||
--- a/sh.lex.c
|
||||
+++ b/sh.lex.c
|
||||
@@ -183,8 +183,7 @@ lex(struct wordent *hp)
|
||||
wdp->word = word(parsehtime);
|
||||
parsehtime = 0;
|
||||
if (enterhist && toolong++ > 10 * 1024) {
|
||||
- seterror(ERR_LTOOLONG);
|
||||
- break;
|
||||
+ stderror(ERR_LTOOLONG);
|
||||
}
|
||||
} while (wdp->word[0] != '\n');
|
||||
cleanup_ignore(hp);
|
||||
@@ -303,8 +302,7 @@ word(int parsehtime)
|
||||
cleanup_push(&wbuf, Strbuf_cleanup);
|
||||
loop:
|
||||
if (enterhist && toolong++ > 256 * 1024) {
|
||||
- seterror(ERR_WTOOLONG);
|
||||
- goto ret;
|
||||
+ stderror(ERR_WTOOLONG);
|
||||
}
|
||||
while ((c = getC(DOALL)) == ' ' || c == '\t')
|
||||
continue;
|
||||
@@ -365,8 +363,7 @@ loop:
|
||||
dolflg = DOALL;
|
||||
for (;;) {
|
||||
if (enterhist && toolong++ > 256 * 1024) {
|
||||
- seterror(ERR_WTOOLONG);
|
||||
- goto ret;
|
||||
+ stderror(ERR_WTOOLONG);
|
||||
}
|
||||
if (c1) {
|
||||
if (c == c1) {
|
||||
--
|
||||
2.25.4
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff --git a/tc.sig.c b/tc.sig.c
|
||||
index 77659ca..576605a 100644
|
||||
--- a/tc.sig.c
|
||||
+++ b/tc.sig.c
|
||||
@@ -56,7 +56,6 @@ int alrmcatch_disabled; /* = 0; */
|
||||
int phup_disabled; /* = 0; */
|
||||
int pchild_disabled; /* = 0; */
|
||||
int pintr_disabled; /* = 0; */
|
||||
-int handle_interrupt; /* = 0; */
|
||||
|
||||
int
|
||||
handle_pending_signals(void)
|
@ -1,53 +0,0 @@
|
||||
From 064853aa25f498aa7bc4554393a53240696813fa Mon Sep 17 00:00:00 2001
|
||||
From: Christos Zoulas <christos@zoulas.com>
|
||||
Date: Fri, 24 Jul 2020 13:49:21 -0400
|
||||
Subject: [PATCH] Call seterror consistently and abort quickly (Jan Macku)
|
||||
|
||||
---
|
||||
sh.lex.c | 14 ++++++++++----
|
||||
1 file changed, 10 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/sh.lex.c b/sh.lex.c
|
||||
index d7d0ac5..ecab059 100644
|
||||
--- a/sh.lex.c
|
||||
+++ b/sh.lex.c
|
||||
@@ -182,8 +182,10 @@ lex(struct wordent *hp)
|
||||
wdp = new;
|
||||
wdp->word = word(parsehtime);
|
||||
parsehtime = 0;
|
||||
- if (enterhist && toolong++ > 10 * 1024)
|
||||
- stderror(ERR_LTOOLONG);
|
||||
+ if (enterhist && toolong++ > 10 * 1024) {
|
||||
+ seterror(ERR_LTOOLONG);
|
||||
+ break;
|
||||
+ }
|
||||
} while (wdp->word[0] != '\n');
|
||||
cleanup_ignore(hp);
|
||||
cleanup_until(hp);
|
||||
@@ -300,8 +302,10 @@ word(int parsehtime)
|
||||
|
||||
cleanup_push(&wbuf, Strbuf_cleanup);
|
||||
loop:
|
||||
- if (enterhist && toolong++ > 256 * 1024)
|
||||
+ if (enterhist && toolong++ > 256 * 1024) {
|
||||
seterror(ERR_WTOOLONG);
|
||||
+ goto ret;
|
||||
+ }
|
||||
while ((c = getC(DOALL)) == ' ' || c == '\t')
|
||||
continue;
|
||||
if (cmap(c, _META | _ESC))
|
||||
@@ -360,8 +364,10 @@ loop:
|
||||
c1 = 0;
|
||||
dolflg = DOALL;
|
||||
for (;;) {
|
||||
- if (enterhist && toolong++ > 256 * 1024)
|
||||
+ if (enterhist && toolong++ > 256 * 1024) {
|
||||
seterror(ERR_WTOOLONG);
|
||||
+ goto ret;
|
||||
+ }
|
||||
if (c1) {
|
||||
if (c == c1) {
|
||||
c1 = 0;
|
||||
--
|
||||
2.25.4
|
||||
|
13
tcsh.spec
13
tcsh.spec
@ -12,8 +12,8 @@
|
||||
|
||||
Name: tcsh
|
||||
Summary: An enhanced version of csh, the C shell
|
||||
Version: 6.22.02
|
||||
Release: 5%{?dist}
|
||||
Version: 6.22.03
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
|
||||
URL: http://www.tcsh.org/
|
||||
@ -42,9 +42,6 @@ BuildRequires: ncurses-devel
|
||||
|
||||
# Upstream patches -- official upstream patches released by upstream since the
|
||||
# ---------------- last rebase that are necessary for any reason:
|
||||
Patch001: tcsh-6.22.02-avoid-gcc-to-fail.patch
|
||||
Patch002: tcsh-6.22.02-call-seterror-consistently-and-abort-quickly.patch
|
||||
Patch003: tcsh-6.22.02-avoid-crashing-when-loading-corrupted-history.patch
|
||||
|
||||
|
||||
# Downstream patches -- these should be always included when doing rebase:
|
||||
@ -179,6 +176,12 @@ fi
|
||||
# =============================================================================
|
||||
|
||||
%changelog
|
||||
* Thu Nov 19 2020 Jan Macku <jamacku@redhat.com> - 6.22.03-1
|
||||
- Update to tcsh-6.22.03
|
||||
- Drop tcsh-6.22.02-avoid-gcc-to-fail.patch - applied by upstream
|
||||
- Drop tcsh-6.22.02-call-seterror-consistently-and-abort-quickly.patch - applied by upstream
|
||||
- Drop tcsh-6.22.02-avoid-crashing-when-loading-corrupted-history.patch - applied by upstream
|
||||
|
||||
* Wed Oct 14 2020 Jan Macku <jamacku@redhat.com> - 6.22.02-5
|
||||
- Switch to stderror() when parsing history so that we stop processing immediately to avoid crashes
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user