- Re-enable -Wstringop-overflow and instead make the problematical
pointer volatile to avoid the false positive diagnostic
This commit is contained in:
parent
383268517c
commit
f2bc8403f4
@ -67,16 +67,16 @@ index 2974602..8dbcc7c 100644
|
|||||||
+ unsigned char [16]);
|
+ unsigned char [16]);
|
||||||
|
|
||||||
#endif /* __RIJNDAEL_H */
|
#endif /* __RIJNDAEL_H */
|
||||||
diff --git a/Config.mk b/Config.mk
|
diff --git a/tboot/common/loader.c b/tboot/common/loader.c
|
||||||
index 6d2fe14..8234edd 100644
|
index cbb7def..6169564 100644
|
||||||
--- a/Config.mk
|
--- a/tboot/common/loader.c
|
||||||
+++ b/Config.mk
|
+++ b/tboot/common/loader.c
|
||||||
@@ -74,6 +74,8 @@ TARGET_ARCH ?= $(shell uname -m | sed -e s/i.86/x86_32/ -e s/i86pc/x86_32/)
|
@@ -59,7 +59,7 @@
|
||||||
CFLAGS += $(CFLAGS_WARN) -fno-strict-aliasing -std=gnu99
|
#include <tpm.h>
|
||||||
# due to bug in gcc v4.2,3,?
|
|
||||||
CFLAGS += $(call cc-option,$(CC),-Wno-array-bounds,)
|
|
||||||
+# Due to a bug in gcc-11
|
|
||||||
+CFLAGS += $(call cc-option,$(CC),-Wno-stringop-overflow,)
|
|
||||||
|
|
||||||
|
/* copy of kernel/VMM command line so that can append 'tboot=0x1234' */
|
||||||
|
-static char *new_cmdline = (char *)TBOOT_KERNEL_CMDLINE_ADDR;
|
||||||
|
+static char * volatile new_cmdline = (char *)TBOOT_KERNEL_CMDLINE_ADDR;
|
||||||
|
|
||||||
ifeq ($(debug),y)
|
/* MLE/kernel shared data page (in boot.S) */
|
||||||
|
extern tboot_shared_t _tboot_shared;
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Performs a verified launch using Intel TXT
|
Summary: Performs a verified launch using Intel TXT
|
||||||
Name: tboot
|
Name: tboot
|
||||||
Version: 1.9.11
|
Version: 1.9.11
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -66,6 +66,10 @@ make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
|||||||
/boot/tboot-syms
|
/boot/tboot-syms
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 30 2020 Jeff Law <law@redhat.com> - 1:1.9.11-5
|
||||||
|
- Re-enable -Wstringop-overflow and instead make the problematical
|
||||||
|
pointer volatile to avoid the false positive diagnostic
|
||||||
|
|
||||||
* Thu Oct 29 2020 Jeff Law <law@redhat.com> - 1:1.9.11-4
|
* Thu Oct 29 2020 Jeff Law <law@redhat.com> - 1:1.9.11-4
|
||||||
- Fix buglet exposed by gcc-11 -Warray-parameter
|
- Fix buglet exposed by gcc-11 -Warray-parameter
|
||||||
- Temporarily disable -Wstringop-overflow due to false positive in gcc-11
|
- Temporarily disable -Wstringop-overflow due to false positive in gcc-11
|
||||||
|
Loading…
Reference in New Issue
Block a user