Update to latest upstream release 1.8.1

This commit is contained in:
Gang Wei 2014-06-18 15:35:40 +08:00
parent f80b4052ae
commit e4b5315e8d
4 changed files with 11 additions and 53 deletions

View File

@ -1 +1 @@
bc7ec3bdd71b21fb73368f24bf697739 tboot-1.7.3.tar.gz
b471f3230cddb33b458020dc7b88810c tboot-1.8.1.tar.gz

View File

@ -1,33 +0,0 @@
# HG changeset patch
# User Gang Wei <gang.wei@intel.com>
# Date 1364897853 -28800
# Node ID 7e8dd5f8b1cd672b6cc876727984dd9cc4077c0e
# Parent 984468adc8fbbf086fac1cfcd97e62bdf3195e39
Fix possible empty submenu block in generated grub.cfg
Signed-off-by: Gang Wei <gang.wei@intel.com>
diff -r 984468adc8fb -r 7e8dd5f8b1cd tboot/20_linux_tboot
--- a/tboot/20_linux_tboot Fri Mar 29 12:48:06 2013 +0800
+++ b/tboot/20_linux_tboot Tue Apr 02 18:17:33 2013 +0800
@@ -127,7 +127,7 @@
done`
prepare_boot_cache=
-while [ "x${tboot_list}" != "x" ] ; do
+while [ "x${tboot_list}" != "x" ] && [ "x$linux_list" != "x" ] ; do
list="${linux_list}"
current_tboot=`version_find_latest $tboot_list`
tboot_basename=`basename ${current_tboot}`
diff -r 984468adc8fb -r 7e8dd5f8b1cd tboot/20_linux_xen_tboot
--- a/tboot/20_linux_xen_tboot Fri Mar 29 12:48:06 2013 +0800
+++ b/tboot/20_linux_xen_tboot Tue Apr 02 18:17:33 2013 +0800
@@ -171,7 +171,7 @@
rel_xen_dirname=`make_system_path_relative_to_its_root $xen_dirname`
xen_version=`echo $xen_basename | sed -e "s,.gz$,,g;s,^xen-,,g"`
tlist="${tboot_list}"
- while [ "x${tlist}" != "x" ] ; do
+ while [ "x${tlist}" != "x" ] && [ "x$linux_list" != "x" ] ; do
current_tboot=`version_find_latest $tlist`
tboot_basename=`basename ${current_tboot}`
tboot_dirname=`dirname ${current_tboot}`

View File

@ -1,12 +0,0 @@
diff -r 5192fef95f6f tboot/Config.mk
--- a/tboot/Config.mk Fri Dec 28 14:30:13 2012 +0800
+++ b/tboot/Config.mk Wed Feb 20 03:32:49 2013 -0500
@@ -32,7 +32,7 @@
CFLAGS += $(call cc-option,$(CC),-fno-stack-protector-all,)
# changeset variable for banner
-CFLAGS += -DTBOOT_CHANGESET=\""$(shell ((hg parents --template "{isodate|isodate} {rev}:{node|short}" >/dev/null && hg parents --template "{isodate|isodate} {rev}:{node|short}") || echo "2012-09-29 15:30 +0800 1.7.2") 2>/dev/null)"\"
+CFLAGS += -DTBOOT_CHANGESET=\""$(shell ((hg parents --template "{isodate|isodate} {rev}:{node|short}" >/dev/null && hg parents --template "{isodate|isodate} {rev}:{node|short}") || echo "2012-12-28 14:30 +0800 1.7.3") 2>/dev/null)"\"
AFLAGS += -D__ASSEMBLY__

View File

@ -1,7 +1,7 @@
Summary: Performs a verified launch using Intel TXT
Name: tboot
Version: 1.7.3
Release: 5%{?dist}
Version: 1.8.1
Release: 1%{?dist}
Epoch: 1
Group: System Environment/Base
@ -9,8 +9,6 @@ License: BSD
URL: http://sourceforge.net/projects/tboot/
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
Patch0: tboot-1.7.3-format-string.patch
Patch1: tboot-1.7.3-version-fix.patch
Patch2: tboot-1.7.3-grub-fix.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: trousers-devel
@ -29,8 +27,6 @@ and verified launch of an OS kernel/VMM.
%ifarch %{ix86}
%patch0 -p1
%endif
%patch1 -p1
%patch2 -p1
%build
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
@ -57,6 +53,10 @@ rm -rf $RPM_BUILD_ROOT
%{_sbindir}/lcp_mlehash
%{_sbindir}/lcp_readpol
%{_sbindir}/lcp_writepol
%{_sbindir}/lcp2_crtpol
%{_sbindir}/lcp2_crtpolelt
%{_sbindir}/lcp2_crtpollist
%{_sbindir}/lcp2_mlehash
%{_sbindir}/parse_err
%{_sbindir}/tb_polgen
%{_sbindir}/tpmnv_defindex
@ -79,6 +79,9 @@ rm -rf $RPM_BUILD_ROOT
/boot/tboot-syms
%changelog
* Wed Jun 18 2014 Gang Wei <gang.wei@intel.com> - 1:1.8.1-1
- Upgrade to latest upstream version
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.7.3-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
@ -112,5 +115,5 @@ rm -rf $RPM_BUILD_ROOT
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 20101005-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
* Tue Dec 1 2010 Joseph Cihula <joseph.cihula@intel.com> - 20101005-1.fc13
* Wed Dec 1 2010 Joseph Cihula <joseph.cihula@intel.com> - 20101005-1.fc13
- Initial import