import tboot-1.10.2-1.el8
This commit is contained in:
parent
52e3ac55a4
commit
9514f650e9
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/tboot-1.9.12.tar.gz
|
SOURCES/tboot-1.10.2.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
c79a2a65b3a8d9f2180c3f262940c778745e6993 SOURCES/tboot-1.9.12.tar.gz
|
f11ed63c38588fe17ac6674efc115122dd2fc737 SOURCES/tboot-1.10.2.tar.gz
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
From 363750fb3ee0089755aa6210f092446818ab1296 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lukasz Hawrylko <lukasz.hawrylko@intel.com>
|
|
||||||
Date: Tue, 12 May 2020 10:13:40 +0200
|
|
||||||
Subject: Fix CFLAGS passing to recursive makefiles
|
|
||||||
|
|
||||||
Signed-off-by: Lukasz Hawrylko <lukasz.hawrylko@intel.com>
|
|
||||||
Signed-off-by: Tony Camuso <tcamuso@redhat.com>
|
|
||||||
---
|
|
||||||
Config.mk | 2 ++
|
|
||||||
safestringlib/makefile | 2 +-
|
|
||||||
2 files changed, 3 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/Config.mk b/Config.mk
|
|
||||||
index a47147a..ba997b0 100644
|
|
||||||
--- a/Config.mk
|
|
||||||
+++ b/Config.mk
|
|
||||||
@@ -92,6 +92,8 @@ endif
|
|
||||||
|
|
||||||
CFLAGS += -I$(ROOTDIR)/safestringlib/include
|
|
||||||
|
|
||||||
+export CFLAGS
|
|
||||||
+
|
|
||||||
# common dummy rule to force execution
|
|
||||||
.PHONY: FORCE
|
|
||||||
FORCE :
|
|
||||||
diff --git a/safestringlib/makefile b/safestringlib/makefile
|
|
||||||
index 163defa..d9ca2be 100644
|
|
||||||
--- a/safestringlib/makefile
|
|
||||||
+++ b/safestringlib/makefile
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
IDIR = include
|
|
||||||
CC ?= gcc
|
|
||||||
-CFLAGS += -I$(IDIR) -fstack-protector-strong -fPIE -fPIC -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -DSTDC_HEADERS
|
|
||||||
+CFLAGS += -I$(IDIR) -fstack-protector-strong -fPIE -fPIC -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -DSTDC_HEADERS -Wno-implicit-fallthrough
|
|
||||||
LDFLAGS += -z noexecstack -z relo -z now
|
|
||||||
|
|
||||||
ODIR=obj
|
|
||||||
--
|
|
||||||
2.18.1
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Performs a verified launch using Intel TXT
|
Summary: Performs a verified launch using Intel TXT
|
||||||
Name: tboot
|
Name: tboot
|
||||||
Version: 1.9.12
|
Version: 1.10.2
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -9,20 +9,18 @@ License: BSD
|
|||||||
URL: http://sourceforge.net/projects/tboot/
|
URL: http://sourceforge.net/projects/tboot/
|
||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
BuildRequires: trousers-devel
|
BuildRequires: grub2-efi-x64-modules
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
|
BuildRequires: perl
|
||||||
ExclusiveArch: %{ix86} x86_64
|
ExclusiveArch: %{ix86} x86_64
|
||||||
|
|
||||||
Patch01: 0001-Fix-CFLAGS-passing-to-recursive-makefiles.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Trusted Boot (tboot) is an open source, pre-kernel/VMM module that uses
|
Trusted Boot (tboot) is an open source, pre-kernel/VMM module that uses
|
||||||
Intel Trusted Execution Technology (Intel TXT) to perform a measured
|
Intel Trusted Execution Technology (Intel TXT) to perform a measured
|
||||||
and verified launch of an OS kernel/VMM.
|
and verified launch of an OS kernel/VMM.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -S git
|
||||||
%patch01 -p1 -b .0001
|
|
||||||
|
|
||||||
# do not override OPTFLAGS
|
# do not override OPTFLAGS
|
||||||
sed -i -e 's/-march=i686//' Config.mk
|
sed -i -e 's/-march=i686//' Config.mk
|
||||||
@ -37,38 +35,59 @@ echo "installing tboot"
|
|||||||
make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README COPYING docs/* lcptools-v2/lcptools.txt lcptools/Linux_LCP_Tools_User_Manual.pdf
|
%doc README.md COPYING docs/* lcptools-v2/lcptools.txt
|
||||||
%config %{_sysconfdir}/grub.d/20_linux_tboot
|
%config %{_sysconfdir}/grub.d/20_linux_tboot
|
||||||
%config %{_sysconfdir}/grub.d/20_linux_xen_tboot
|
%config %{_sysconfdir}/grub.d/20_linux_xen_tboot
|
||||||
%{_sbindir}/acminfo
|
%{_sbindir}/txt-acminfo
|
||||||
%{_sbindir}/lcp_readpol
|
|
||||||
%{_sbindir}/lcp_writepol
|
|
||||||
%{_sbindir}/lcp2_crtpol
|
%{_sbindir}/lcp2_crtpol
|
||||||
%{_sbindir}/lcp2_crtpolelt
|
%{_sbindir}/lcp2_crtpolelt
|
||||||
%{_sbindir}/lcp2_crtpollist
|
%{_sbindir}/lcp2_crtpollist
|
||||||
%{_sbindir}/lcp2_mlehash
|
%{_sbindir}/lcp2_mlehash
|
||||||
%{_sbindir}/parse_err
|
%{_sbindir}/txt-parse_err
|
||||||
%{_sbindir}/tb_polgen
|
%{_sbindir}/tb_polgen
|
||||||
%{_sbindir}/tpmnv_defindex
|
|
||||||
%{_sbindir}/tpmnv_getcap
|
|
||||||
%{_sbindir}/tpmnv_lock
|
|
||||||
%{_sbindir}/tpmnv_relindex
|
|
||||||
%{_sbindir}/txt-stat
|
%{_sbindir}/txt-stat
|
||||||
%{_mandir}/man8/acminfo.8.gz
|
%{_mandir}/man8/txt-acminfo.8.gz
|
||||||
%{_mandir}/man8/lcp_crtpconf.8.gz
|
|
||||||
%{_mandir}/man8/lcp_crtpol.8.gz
|
|
||||||
%{_mandir}/man8/lcp_crtpol2.8.gz
|
|
||||||
%{_mandir}/man8/lcp_crtpolelt.8.gz
|
|
||||||
%{_mandir}/man8/lcp_crtpollist.8.gz
|
|
||||||
%{_mandir}/man8/lcp_mlehash.8.gz
|
|
||||||
%{_mandir}/man8/lcp_readpol.8.gz
|
|
||||||
%{_mandir}/man8/lcp_writepol.8.gz
|
|
||||||
%{_mandir}/man8/tb_polgen.8.gz
|
%{_mandir}/man8/tb_polgen.8.gz
|
||||||
%{_mandir}/man8/txt-stat.8.gz
|
%{_mandir}/man8/txt-stat.8.gz
|
||||||
|
%{_mandir}/man8/lcp2_crtpol.8.gz
|
||||||
|
%{_mandir}/man8/lcp2_crtpolelt.8.gz
|
||||||
|
%{_mandir}/man8/lcp2_crtpollist.8.gz
|
||||||
|
%{_mandir}/man8/lcp2_mlehash.8.gz
|
||||||
|
%{_mandir}/man8/txt-parse_err.8.gz
|
||||||
/boot/tboot.gz
|
/boot/tboot.gz
|
||||||
/boot/tboot-syms
|
/boot/tboot-syms
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jun 10 2021 Tony Camuso <tcamuso@redhat.com> - 1:1.10.1-1
|
||||||
|
Upgrade to tboot-1.10.2-1 provides some bug fixes and updates.
|
||||||
|
Remove 0001-Do-not-install-man-pages-for-deprecated-tools.patch
|
||||||
|
from the git repo, since it is no longer needed.
|
||||||
|
Resolves: rhbz#1857068
|
||||||
|
Resolves: rhbz#1873296
|
||||||
|
Resolves: rhbz#1920386
|
||||||
|
|
||||||
|
* Mon Feb 22 2021 Tony Camuso <tcamuso@redhat.com> - 1:1.10.0-1
|
||||||
|
Need to add BuildRequires: perl, since it has beem moved
|
||||||
|
from BuildRoot.
|
||||||
|
See: https://fedoraproject.org/wiki/Packaging:Perl#Build_Dependencies
|
||||||
|
Resolves: rhbz#1857068
|
||||||
|
|
||||||
|
* Mon Feb 22 2021 Tony Camuso <tcamuso@redhat.com> - 1:1.10.0-1
|
||||||
|
Build problem creating directory for grub modules. We can't
|
||||||
|
know if the modules are there, so it's up to the end user to
|
||||||
|
find the modules and copy them to the correct location.
|
||||||
|
Specifically, for systems booting from EFI, the
|
||||||
|
/boot/efi/EFI/redhat/x86_64-efi/multiboot2.mod file, if it
|
||||||
|
exists, must be copied to the /boot/efi/EFI/redhat/x86_64-efi/
|
||||||
|
directory. If that file does not exist, then the system has
|
||||||
|
the wrong version of grub for using tboot in an EFI system.
|
||||||
|
Resolves: rhbz#1857068
|
||||||
|
|
||||||
|
* Fri Dec 11 2020 Tony Camuso <tcamuso@redhat.com> - 1:1.10.0-0
|
||||||
|
Upgrade to latest upstream version
|
||||||
|
Added upstream patch to remove deprecated man pages
|
||||||
|
Resolves: rhbz#1857068
|
||||||
|
|
||||||
* Tue Jun 23 2020 Tony Camuso <tcamuso@redhat.com> - 1:1.9.12-2
|
* Tue Jun 23 2020 Tony Camuso <tcamuso@redhat.com> - 1:1.9.12-2
|
||||||
- Fix build issues with one upstream patch.
|
- Fix build issues with one upstream patch.
|
||||||
This patch also reverts the previous patch concerning the
|
This patch also reverts the previous patch concerning the
|
||||||
|
Loading…
Reference in New Issue
Block a user