Updated to v1.10.3 release
This commit is contained in:
parent
0b56c90fc7
commit
6adfba76eb
@ -1,25 +0,0 @@
|
||||
From 1cf1c3e6af1f43555de7ec89cd1e8bc3ea0aaefe Mon Sep 17 00:00:00 2001
|
||||
From: Yunying Sun <yunying.sun@intel.com>
|
||||
Date: Mon, 13 May 2019 17:26:13 +0800
|
||||
Subject: [PATCH] disable address of packed member warning
|
||||
|
||||
---
|
||||
Config.mk | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Config.mk b/Config.mk
|
||||
index 6a64d1a..27bce1b 100644
|
||||
--- a/Config.mk
|
||||
+++ b/Config.mk
|
||||
@@ -43,7 +43,7 @@ CFLAGS_WARN = -Wall -Wformat-security -Werror -Wstrict-prototypes \
|
||||
-Wextra -Winit-self -Wswitch-default -Wunused-parameter \
|
||||
-Wwrite-strings \
|
||||
$(call cc-option,$(CC),-Wlogical-op,) \
|
||||
- -Wno-missing-field-initializers
|
||||
+ -Wno-missing-field-initializers -Wno-address-of-packed-member
|
||||
|
||||
AS = as
|
||||
LD = ld
|
||||
--
|
||||
2.21.0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (tboot-1.10.2.tar.gz) = a906617b733411f0e672bfea28edb65cf7b586e100c3b6af45a8a0a0088fdc103b8c27518f1d6421537653c6b4ed48d78993a2df44188ddeaa5dc536cc272060
|
||||
SHA512 (tboot-1.10.3.tar.gz) = 998501cfb23511adf63c0e2a70f203b3a92328cba39948a6be2e0dc6600aaaf9fcc18dc1ffcdd00c43a5d2c688c34c912c7525fd54a5c673a764c34141be4b77
|
||||
|
@ -1,82 +0,0 @@
|
||||
diff --git a/tboot/common/tpm_12.c b/tboot/common/tpm_12.c
|
||||
index a62e570..504b874 100644
|
||||
--- a/tboot/common/tpm_12.c
|
||||
+++ b/tboot/common/tpm_12.c
|
||||
@@ -766,6 +766,8 @@ static uint32_t tpm12_osap(uint32_t locality, tpm_entity_type_t ent_type,
|
||||
tpm_authhandle_t *hauth, tpm_nonce_t *nonce_even,
|
||||
tpm_nonce_t *even_osap)
|
||||
{
|
||||
+#pragma GCC diagnostic push
|
||||
+#pragma GCC diagnostic ignored "-Wmaybe-uninitialized"
|
||||
uint32_t ret, offset, out_size;
|
||||
|
||||
if ( odd_osap == NULL || hauth == NULL ||
|
||||
@@ -801,6 +803,7 @@ static uint32_t tpm12_osap(uint32_t locality, tpm_entity_type_t ent_type,
|
||||
LOAD_BLOB_TYPE(WRAPPER_OUT_BUF, offset, even_osap);
|
||||
|
||||
return ret;
|
||||
+#pragma GCC diagnostic pop
|
||||
}
|
||||
|
||||
static uint32_t _tpm12_seal(uint32_t locality, tpm_key_handle_t hkey,
|
||||
@@ -1044,6 +1047,8 @@ static uint32_t _tpm12_wrap_seal(uint32_t locality,
|
||||
static uint32_t _tpm12_wrap_unseal(uint32_t locality, const uint8_t *in_data,
|
||||
uint32_t *secret_size, uint8_t *secret)
|
||||
{
|
||||
+#pragma GCC diagnostic push
|
||||
+#pragma GCC diagnostic ignored "-Wmaybe-uninitialized"
|
||||
uint32_t ret;
|
||||
tpm_nonce_t odd_osap, even_osap;
|
||||
tpm_nonce_t nonce_even, nonce_odd, nonce_even_d, nonce_odd_d;
|
||||
@@ -1116,6 +1121,7 @@ static uint32_t _tpm12_wrap_unseal(uint32_t locality, const uint8_t *in_data,
|
||||
/* skip check for res_auth */
|
||||
|
||||
return ret;
|
||||
+#pragma GCC diagnostic pop
|
||||
}
|
||||
|
||||
static bool init_pcr_info(uint32_t locality,
|
||||
@@ -1948,6 +1954,8 @@ static bool tpm12_get_random(struct tpm_if *ti, uint32_t locality,
|
||||
|
||||
static bool tpm12_cap_pcrs(struct tpm_if *ti, u32 locality, int pcr)
|
||||
{
|
||||
+#pragma GCC diagnostic push
|
||||
+#pragma GCC diagnostic ignored "-Wmaybe-uninitialized"
|
||||
bool was_capped[TPM_NR_PCRS] = {false};
|
||||
tpm_pcr_value_t cap_val; /* use whatever val is on stack */
|
||||
|
||||
@@ -1976,6 +1984,7 @@ static bool tpm12_cap_pcrs(struct tpm_if *ti, u32 locality, int pcr)
|
||||
|
||||
printk(TBOOT_INFO"cap'ed dynamic PCRs\n");
|
||||
return true;
|
||||
+#pragma GCC diagnostic pop
|
||||
}
|
||||
|
||||
static bool tpm12_check(void)
|
||||
diff --git a/tboot/include/rijndael.h b/tboot/include/rijndael.h
|
||||
index 2974602..8dbcc7c 100644
|
||||
--- a/tboot/include/rijndael.h
|
||||
+++ b/tboot/include/rijndael.h
|
||||
@@ -52,7 +52,7 @@ void rijndael_encrypt(rijndael_ctx *, const u_char *, u_char *);
|
||||
|
||||
int rijndaelKeySetupEnc(unsigned int [], const unsigned char [], int);
|
||||
int rijndaelKeySetupDec(unsigned int [], const unsigned char [], int);
|
||||
-void rijndaelEncrypt(const unsigned int [], int, const unsigned char [],
|
||||
- unsigned char []);
|
||||
+void rijndaelEncrypt(const unsigned int [], int, const unsigned char [16],
|
||||
+ unsigned char [16]);
|
||||
|
||||
#endif /* __RIJNDAEL_H */
|
||||
diff --git a/tboot/common/loader.c b/tboot/common/loader.c
|
||||
index cbb7def..6169564 100644
|
||||
--- a/tboot/common/loader.c
|
||||
+++ b/tboot/common/loader.c
|
||||
@@ -59,7 +59,7 @@
|
||||
#include <tpm.h>
|
||||
|
||||
/* copy of kernel/VMM command line so that can append 'tboot=0x1234' */
|
||||
-static char *new_cmdline = (char *)TBOOT_KERNEL_CMDLINE_ADDR;
|
||||
+static char * volatile new_cmdline = (char *)TBOOT_KERNEL_CMDLINE_ADDR;
|
||||
|
||||
/* MLE/kernel shared data page (in boot.S) */
|
||||
extern tboot_shared_t _tboot_shared;
|
12
tboot.spec
12
tboot.spec
@ -1,7 +1,7 @@
|
||||
Summary: Performs a verified launch using Intel TXT
|
||||
Name: tboot
|
||||
Version: 1.10.2
|
||||
Release: 3%{?dist}
|
||||
Version: 1.10.3
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
License: BSD
|
||||
@ -55,6 +55,14 @@ make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
||||
/boot/tboot-syms
|
||||
|
||||
%changelog
|
||||
* Thu Dec 23 2021 Yunying Sun <yunying.sun@intel.com> - 1:1.10.3-1
|
||||
- Updated to 1.10.3 which added OpenSSL 3.0.0 support
|
||||
- Bugzilla 2021901 is fixed with this updated release
|
||||
- Removed obsolete patch files
|
||||
|
||||
* Fri Dec 3 2021 Yunying Sun <yunying.sun@intel.com> - 1:1.10.2-4
|
||||
- Rebuilt again with OpenSSL 3.0.0 fix patch
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 1:1.10.2-3
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user