import tboot-1.9.12-2.el8
This commit is contained in:
parent
aeb2c6235e
commit
52e3ac55a4
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
SOURCES/tboot-1.9.10.tar.gz
|
SOURCES/tboot-1.9.12.tar.gz
|
||||||
|
@ -1 +1 @@
|
|||||||
0a5dba9b9c3d01856a5b8c5e0fe0ccb55e8a62ad SOURCES/tboot-1.9.10.tar.gz
|
c79a2a65b3a8d9f2180c3f262940c778745e6993 SOURCES/tboot-1.9.12.tar.gz
|
||||||
|
40
SOURCES/0001-Fix-CFLAGS-passing-to-recursive-makefiles.patch
Normal file
40
SOURCES/0001-Fix-CFLAGS-passing-to-recursive-makefiles.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
From 363750fb3ee0089755aa6210f092446818ab1296 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Lukasz Hawrylko <lukasz.hawrylko@intel.com>
|
||||||
|
Date: Tue, 12 May 2020 10:13:40 +0200
|
||||||
|
Subject: Fix CFLAGS passing to recursive makefiles
|
||||||
|
|
||||||
|
Signed-off-by: Lukasz Hawrylko <lukasz.hawrylko@intel.com>
|
||||||
|
Signed-off-by: Tony Camuso <tcamuso@redhat.com>
|
||||||
|
---
|
||||||
|
Config.mk | 2 ++
|
||||||
|
safestringlib/makefile | 2 +-
|
||||||
|
2 files changed, 3 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Config.mk b/Config.mk
|
||||||
|
index a47147a..ba997b0 100644
|
||||||
|
--- a/Config.mk
|
||||||
|
+++ b/Config.mk
|
||||||
|
@@ -92,6 +92,8 @@ endif
|
||||||
|
|
||||||
|
CFLAGS += -I$(ROOTDIR)/safestringlib/include
|
||||||
|
|
||||||
|
+export CFLAGS
|
||||||
|
+
|
||||||
|
# common dummy rule to force execution
|
||||||
|
.PHONY: FORCE
|
||||||
|
FORCE :
|
||||||
|
diff --git a/safestringlib/makefile b/safestringlib/makefile
|
||||||
|
index 163defa..d9ca2be 100644
|
||||||
|
--- a/safestringlib/makefile
|
||||||
|
+++ b/safestringlib/makefile
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
IDIR = include
|
||||||
|
CC ?= gcc
|
||||||
|
-CFLAGS += -I$(IDIR) -fstack-protector-strong -fPIE -fPIC -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -DSTDC_HEADERS
|
||||||
|
+CFLAGS += -I$(IDIR) -fstack-protector-strong -fPIE -fPIC -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -DSTDC_HEADERS -Wno-implicit-fallthrough
|
||||||
|
LDFLAGS += -z noexecstack -z relo -z now
|
||||||
|
|
||||||
|
ODIR=obj
|
||||||
|
--
|
||||||
|
2.18.1
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Performs a verified launch using Intel TXT
|
Summary: Performs a verified launch using Intel TXT
|
||||||
Name: tboot
|
Name: tboot
|
||||||
Version: 1.9.10
|
Version: 1.9.12
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -13,6 +13,8 @@ BuildRequires: trousers-devel
|
|||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
ExclusiveArch: %{ix86} x86_64
|
ExclusiveArch: %{ix86} x86_64
|
||||||
|
|
||||||
|
Patch01: 0001-Fix-CFLAGS-passing-to-recursive-makefiles.patch
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Trusted Boot (tboot) is an open source, pre-kernel/VMM module that uses
|
Trusted Boot (tboot) is an open source, pre-kernel/VMM module that uses
|
||||||
Intel Trusted Execution Technology (Intel TXT) to perform a measured
|
Intel Trusted Execution Technology (Intel TXT) to perform a measured
|
||||||
@ -20,6 +22,7 @@ and verified launch of an OS kernel/VMM.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch01 -p1 -b .0001
|
||||||
|
|
||||||
# do not override OPTFLAGS
|
# do not override OPTFLAGS
|
||||||
sed -i -e 's/-march=i686//' Config.mk
|
sed -i -e 's/-march=i686//' Config.mk
|
||||||
@ -66,6 +69,23 @@ make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
|||||||
/boot/tboot-syms
|
/boot/tboot-syms
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 23 2020 Tony Camuso <tcamuso@redhat.com> - 1:1.9.12-2
|
||||||
|
- Fix build issues with one upstream patch.
|
||||||
|
This patch also reverts the previous patch concerning the
|
||||||
|
-Wno-address-of-packed-member cflag.
|
||||||
|
Resolves: rhbz#1847938
|
||||||
|
|
||||||
|
* Fri Jun 12 2020 Tony Camuso <tcamuso@redhat.com> - 1:1.9.12-1
|
||||||
|
- Add patch to revert "Disable GCC9 address-of-packed-member warning"
|
||||||
|
While it was able to build locally with 'rhpkg local', the brew
|
||||||
|
build failed, because the compiler on the brew systems did not
|
||||||
|
recognized the new GCC9 command line flag:
|
||||||
|
-Wno-address-of-packed-member
|
||||||
|
|
||||||
|
* Fri May 29 2020 Tony Camuso <tcamuso@redhat.com> - 1:1.9.12-1
|
||||||
|
- Upgrade to latest upstream version
|
||||||
|
Resolves: rhbz#1790169
|
||||||
|
|
||||||
* Fri Nov 15 2019 Tony Camuso <tcamuso@redhat.com> - 1:1.9.10-1
|
* Fri Nov 15 2019 Tony Camuso <tcamuso@redhat.com> - 1:1.9.10-1
|
||||||
- Rebase to the lastest upstream version.
|
- Rebase to the lastest upstream version.
|
||||||
Resolves: rhbz#1725661
|
Resolves: rhbz#1725661
|
||||||
|
Loading…
Reference in New Issue
Block a user