Update to upstream 1.9.7 release
This commit is contained in:
parent
45a50d74ab
commit
4df7b5b7cb
8
.gitignore
vendored
8
.gitignore
vendored
@ -1,7 +1 @@
|
|||||||
/tboot-20101005.tar.gz
|
/tboot-1.9.7.tar.gz
|
||||||
/tboot-1.5.0.tar.gz
|
|
||||||
/tboot-20110429.tar.gz
|
|
||||||
/tboot-1.7.0.tar.gz
|
|
||||||
/tboot-1.7.3.tar.gz
|
|
||||||
/tboot-1.8.2.tar.gz
|
|
||||||
/tboot-1.9.6.tar.gz
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (tboot-1.9.6.tar.gz) = f53f5535f7ab031439514b43811cd2ec93efcb7614cb7bc7d1f3051d808d942e8a4942fd1d0ab6fe0c245740c2a10ba7adbcd44f2c42b2a577d9a20c0c5df90e
|
SHA512 (tboot-1.9.7.tar.gz) = 78bc6ea3a1a1d295fc9531a419aeed61aa6b1252e546b68fb37a9628a1389cf7ab0817df89f80748e102bb1c6d07d1ad819061084417fa1201a8fd8755a4425e
|
||||||
|
@ -1,27 +0,0 @@
|
|||||||
diff -up tboot-1.9.6/lcptools/hash.c.openssl11 tboot-1.9.6/lcptools/hash.c
|
|
||||||
--- tboot-1.9.6/lcptools/hash.c.openssl11 2017-07-12 01:03:58.000000000 +0200
|
|
||||||
+++ tboot-1.9.6/lcptools/hash.c 2018-02-06 11:28:05.062843233 +0100
|
|
||||||
@@ -74,13 +74,19 @@ bool hash_buffer(const unsigned char* bu
|
|
||||||
return false;
|
|
||||||
|
|
||||||
if ( hash_alg == TB_HALG_SHA1_LG ) {
|
|
||||||
- EVP_MD_CTX ctx;
|
|
||||||
+ EVP_MD_CTX *ctx;
|
|
||||||
const EVP_MD *md;
|
|
||||||
|
|
||||||
md = EVP_sha1();
|
|
||||||
- EVP_DigestInit(&ctx, md);
|
|
||||||
- EVP_DigestUpdate(&ctx, buf, size);
|
|
||||||
- EVP_DigestFinal(&ctx, hash->sha1, NULL);
|
|
||||||
+ if ( md == NULL )
|
|
||||||
+ return false;
|
|
||||||
+ ctx = EVP_MD_CTX_create();
|
|
||||||
+ if ( ctx == NULL )
|
|
||||||
+ return false;
|
|
||||||
+ EVP_DigestInit(ctx, md);
|
|
||||||
+ EVP_DigestUpdate(ctx, buf, size);
|
|
||||||
+ EVP_DigestFinal(ctx, hash->sha1, NULL);
|
|
||||||
+ EVP_MD_CTX_destroy(ctx);
|
|
||||||
return true;
|
|
||||||
}
|
|
||||||
else
|
|
11
tboot.spec
11
tboot.spec
@ -1,14 +1,14 @@
|
|||||||
Summary: Performs a verified launch using Intel TXT
|
Summary: Performs a verified launch using Intel TXT
|
||||||
Name: tboot
|
Name: tboot
|
||||||
Version: 1.9.6
|
Version: 1.9.7
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://sourceforge.net/projects/tboot/
|
URL: http://sourceforge.net/projects/tboot/
|
||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
Patch1: tboot-1.9.6-openssl11.patch
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: trousers-devel
|
BuildRequires: trousers-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
@ -21,7 +21,6 @@ and verified launch of an OS kernel/VMM.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1 -b .openssl11
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
||||||
@ -70,6 +69,10 @@ make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
|||||||
/boot/tboot-syms
|
/boot/tboot-syms
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 4 2018 Yunying Sun <yunying.sun@intel.com> - 1:1.9.7-1
|
||||||
|
- Updated to upstream 1.9.7 release
|
||||||
|
- Removed the patch for openssl 1.1 as it is included in 1.9.7 already
|
||||||
|
|
||||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9.6-3
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9.6-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user