fix package build error and update to 1.9.10
This commit is contained in:
parent
9005a15afb
commit
417eff3d10
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/tboot-1.9.8.tar.gz
|
/tboot-1.9.*.tar.gz
|
||||||
|
25
disable-address-of-packed-member-warning.patch
Normal file
25
disable-address-of-packed-member-warning.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 1cf1c3e6af1f43555de7ec89cd1e8bc3ea0aaefe Mon Sep 17 00:00:00 2001
|
||||||
|
From: Yunying Sun <yunying.sun@intel.com>
|
||||||
|
Date: Mon, 13 May 2019 17:26:13 +0800
|
||||||
|
Subject: [PATCH] disable address of packed member warning
|
||||||
|
|
||||||
|
---
|
||||||
|
Config.mk | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/Config.mk b/Config.mk
|
||||||
|
index 6a64d1a..27bce1b 100644
|
||||||
|
--- a/Config.mk
|
||||||
|
+++ b/Config.mk
|
||||||
|
@@ -43,7 +43,7 @@ CFLAGS_WARN = -Wall -Wformat-security -Werror -Wstrict-prototypes \
|
||||||
|
-Wextra -Winit-self -Wswitch-default -Wunused-parameter \
|
||||||
|
-Wwrite-strings \
|
||||||
|
$(call cc-option,$(CC),-Wlogical-op,) \
|
||||||
|
- -Wno-missing-field-initializers
|
||||||
|
+ -Wno-missing-field-initializers -Wno-address-of-packed-member
|
||||||
|
|
||||||
|
AS = as
|
||||||
|
LD = ld
|
||||||
|
--
|
||||||
|
2.21.0
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (tboot-1.9.8.tar.gz) = 8753fbf50c7fa18b3d67763935a6d6c493b1c618455b8a7ea248e8432d093f24936d397fb65096c19db969981e7a2fa03b79006ea476c9f68cfcfedd44f54402
|
SHA512 (tboot-1.9.10.tar.gz) = 832a708c6d4498836add0b2cf66347baf32ecf39090c529bcee7cfc2b9341b5c0924bc1170a16ca13c47913f5bdcfe7cbbc62f9ae0ff9180ad0f9672e536b2c5
|
||||||
|
22
tboot.spec
22
tboot.spec
@ -1,16 +1,19 @@
|
|||||||
Summary: Performs a verified launch using Intel TXT
|
Summary: Performs a verified launch using Intel TXT
|
||||||
Name: tboot
|
Name: tboot
|
||||||
Version: 1.9.8
|
Version: 1.9.10
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
URL: http://sourceforge.net/projects/tboot/
|
URL: http://sourceforge.net/projects/tboot/
|
||||||
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
|
Patch0: disable-address-of-packed-member-warning.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: trousers-devel
|
BuildRequires: trousers-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
|
BuildRequires: zlib-devel
|
||||||
ExclusiveArch: %{ix86} x86_64
|
ExclusiveArch: %{ix86} x86_64
|
||||||
|
|
||||||
%description
|
%description
|
||||||
@ -19,7 +22,7 @@ Intel Trusted Execution Technology (Intel TXT) to perform a measured
|
|||||||
and verified launch of an OS kernel/VMM.
|
and verified launch of an OS kernel/VMM.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%autosetup -p1 -n %{name}-%{version}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
||||||
@ -30,16 +33,10 @@ make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
|||||||
|
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc README COPYING docs/* lcptools/lcptools2.txt lcptools/Linux_LCP_Tools_User_Manual.pdf
|
%doc README COPYING docs/* lcptools/Linux_LCP_Tools_User_Manual.pdf
|
||||||
%config %{_sysconfdir}/grub.d/20_linux_tboot
|
%config %{_sysconfdir}/grub.d/20_linux_tboot
|
||||||
%config %{_sysconfdir}/grub.d/20_linux_xen_tboot
|
%config %{_sysconfdir}/grub.d/20_linux_xen_tboot
|
||||||
%{_sbindir}/acminfo
|
%{_sbindir}/acminfo
|
||||||
%{_sbindir}/lcp_crtpconf
|
|
||||||
%{_sbindir}/lcp_crtpol
|
|
||||||
%{_sbindir}/lcp_crtpol2
|
|
||||||
%{_sbindir}/lcp_crtpolelt
|
|
||||||
%{_sbindir}/lcp_crtpollist
|
|
||||||
%{_sbindir}/lcp_mlehash
|
|
||||||
%{_sbindir}/lcp_readpol
|
%{_sbindir}/lcp_readpol
|
||||||
%{_sbindir}/lcp_writepol
|
%{_sbindir}/lcp_writepol
|
||||||
%{_sbindir}/lcp2_crtpol
|
%{_sbindir}/lcp2_crtpol
|
||||||
@ -68,6 +65,11 @@ make debug=y DISTDIR=$RPM_BUILD_ROOT install
|
|||||||
/boot/tboot-syms
|
/boot/tboot-syms
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 14 2019 Yunying Sun <yunying.sun@intel.com> - 1:1.9.10-1
|
||||||
|
- Add patch to fix package build error
|
||||||
|
- Add build dependency to zlib-devel
|
||||||
|
- Update to latest release 1.9.10
|
||||||
|
|
||||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9.8-2
|
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.9.8-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user